E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-20-2012, 03:57 PM   #1
Bimmaforthewin
Registered User
 
Join Date: Dec 2012
Location: Staines
Posts: 4
My Ride: 330ci
Exclamation Please help harman people

Hi people

I have a e46 330ci coupe on an X plate and I have an issue that's driving me nuts on my stereo !

My amp on my subs died (the little one on the speakers) so I brought a working one from eBay with speakers and only recently got to fit them so the stereo has been with out the subs for a couple of months any way I fit these subs and amp turn the stereo on and bam no subs ?????? So I'm thinking ok must be a fuse nope can't find anything there so I probe up the plug to check power and I have a live and earth and I've plugged it in to DIS system and NCS but to no avail so I'm really stuck now any one that's had this problem or got any tips they wanna share would be much appreciated I don't really want to put an after market set in want to keep it standard I'm a mechanic by trade so no my way around the Bm any help please people

Cheers and happy Xmas !!,!,!
Bimmaforthewin is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-21-2012, 08:16 AM   #2
Grande D
Registered User
 
Join Date: Dec 2006
Location: PA
Posts: 3,327
My Ride: E90 M-Sport
Maybe the speakers themselves shorted and is blowing out the amp(s). Do you have any spare 6x9s by chance? I'd try replacing the speakers and the mini-amplifier again, and it should fix the problem.

Last edited by Grande D; 12-21-2012 at 08:16 AM.
Grande D is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use