E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > BMW Regional Forums > Regional Forums > UK

UK
Have you seen another BMW while driving around in your area? Find other members from your area in the E46Fanatics Garage HERE

If you don't have your garage setup, sign up today HERE

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 12-21-2012, 02:28 PM   #1
Kandivandit
Registered User
 
Join Date: Dec 2012
Location: Uk
Posts: 5
My Ride: BMW 318i
Idle/starting problems

Hi guys.
I'm new here so let me introduce myself.
I'm ian from the uk.

Iv just brought myself an 02 plate 318i and have had nothing but problems with it. Took it for a test drive. Drove like a dream. No clunks or bangs. So decided to buy. After picking it up. Drove the 20 miles home and had a smell of burning oil coming through the interior heater vents. Had a look and it looks like someone has spilt oil while changing it. Anyway decided to carry on. Stopped on the way home for some food. Got back in and it wouldn't start. After about 4/5 times of trying it finally went. Got it back home. Tried it again and the coolant hose burst. Rang the garage. They took it back as u see warranty. They had it 2 weeks. Changed the crank sensor. The thermostat and the O2 sensor that they said were flagged on a diog. Finally got the car back today and still having the starting problems. Only when warm tho. Starts first time when cold. Also when pulling off in 1st have to put the power right down as it feels like it will stall. Wich it did a couple of times. Then took a few times of trying to start it to get going again. And this is quite worrying as it stalled at lights on a main road and held traffic up etc. and am now petrified of driving it. The EML doesn't come on or anything like that.
I kno a little about cars. Not a great deal but enough. Does this sound like an ignition coil problem or something a lot more deep rooted? I have been reading posts about rough idle wich mine is experiencing a lot until I put my foot down and it seems to sort out until I stop again at lights etc.


Have spoken to someone who seems to think remapping the ecu might help a bit? Am getting to the point where I am petrified of driving it incase it stalls on a roundabout and I can't get it started again.

Thanks in advance
Kandivandit is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is ON





All times are GMT -5. The time now is 12:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use