E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Forced Induction Forum Sponsored by Active Autowerke

Forced Induction Forum Sponsored by Active Autowerke
Discuss supercharging, turbocharging and even nitrous and water injection here.
Sponsored by Active Autowerke

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-18-2012, 09:45 AM   #21
MaverickM3
Registered User
 
Join Date: Oct 2008
Location: Savannah
Posts: 78
My Ride: gets badge
Glad you got it worked out.
__________________
MaverickM3 is offline   Reply With Quote
Old 12-18-2012, 11:53 AM   #22
nnacpil
Registered User
 
Join Date: Nov 2010
Location: WV
Posts: 217
My Ride: 2006 BMW M3
Thanks for replying. I checked my wg lines and one of the connectors from the skinny hose to the thick hose was broken. Went to advanced auto to pick up a vacuum connector and fixed the line. Put everything back together along with testing the solenoids which btw works properly. Tested the car and was still over boosting.

Wanted to mention that I recently swapped my SS race exhaust to hpf's ti exhaust. Since the back pressure is reduced, would this cause my over boosting issues? I've read that people would have to send their ems back to HPF for a new tune. After checking the map sensor, boost solenoids, and wg lines, it has lead me to believe that I need a new tune.

Anyone care to input? Thanks.
__________________

2006 BMW lllM3 SilverGrayMetallic/Cinnamon/Apex Arc-8
llHPF/ProEFI Stage 2.25 w/6766
SOLD!!!!!!!!!!!
nnacpil is offline   Reply With Quote
Old 12-18-2012, 12:19 PM   #23
Commanderwiggin
Registered User
 
Join Date: Jun 2010
Location: Calgary, Canada
Posts: 3,861
My Ride: 900rwhp Turbo M3
Quote:
Originally Posted by nnacpil View Post
Thanks for replying. I checked my wg lines and one of the connectors from the skinny hose to the thick hose was broken. Went to advanced auto to pick up a vacuum connector and fixed the line. Put everything back together along with testing the solenoids which btw works properly. Tested the car and was still over boosting.

Wanted to mention that I recently swapped my SS race exhaust to hpf's ti exhaust. Since the back pressure is reduced, would this cause my over boosting issues? I've read that people would have to send their ems back to HPF for a new tune. After checking the map sensor, boost solenoids, and wg lines, it has lead me to believe that I need a new tune.

Anyone care to input? Thanks.
You went from a muffler to straight pipes...so I would say you definitely have quite a bit of reduced backpressure which would cause some overboost most likely if it wasn't tuned for it...that much overboost? Tough to say...
__________________

Last edited by Commanderwiggin; 12-18-2012 at 12:20 PM.
Commanderwiggin is online now   Reply With Quote
Old 12-18-2012, 12:29 PM   #24
nnacpil
Registered User
 
Join Date: Nov 2010
Location: WV
Posts: 217
My Ride: 2006 BMW M3
Quote:
Originally Posted by Commanderwiggin View Post
You went from a muffler to straight pipes...so I would say you definitely have quite a bit of reduced backpressure which would cause some overboost most likely if it wasn't tuned for it...that much overboost? Tough to say...
Thanks. I'm waiting for Chris k to reply back to see what he thinks. He's been helping me.

We've lead to think it was wg related so he had me check the lines. My dump isn't even opening up on boost. The Tial wg is brand new but could it be the dump itself or wg?
__________________

2006 BMW lllM3 SilverGrayMetallic/Cinnamon/Apex Arc-8
llHPF/ProEFI Stage 2.25 w/6766
SOLD!!!!!!!!!!!
nnacpil is offline   Reply With Quote
Old 12-18-2012, 12:45 PM   #25
Commanderwiggin
Registered User
 
Join Date: Jun 2010
Location: Calgary, Canada
Posts: 3,861
My Ride: 900rwhp Turbo M3
Quote:
Originally Posted by nnacpil View Post
Thanks. I'm waiting for Chris k to reply back to see what he thinks. He's been helping me.

We've lead to think it was wg related so he had me check the lines. My dump isn't even opening up on boost. The Tial wg is brand new but could it be the dump itself or wg?
If it's not opening up on boost then something else is wrong.
__________________
Commanderwiggin is online now   Reply With Quote
Old 12-18-2012, 12:55 PM   #26
nnacpil
Registered User
 
Join Date: Nov 2010
Location: WV
Posts: 217
My Ride: 2006 BMW M3
Quote:
Originally Posted by Commanderwiggin View Post
If it's not opening up on boost then something else is wrong.
Any ideas? Wg or dump issues?
__________________

2006 BMW lllM3 SilverGrayMetallic/Cinnamon/Apex Arc-8
llHPF/ProEFI Stage 2.25 w/6766
SOLD!!!!!!!!!!!
nnacpil is offline   Reply With Quote
Old 12-18-2012, 09:08 PM   #27
GRK///M3
Registered User
 
Join Date: Jun 2007
Location: Easton,PA/ Montreal,Canada
Posts: 185
My Ride: LSB M3
Quote:
Originally Posted by zac5 View Post
No, I can't. but then if I get the meth system, i have to send the ems back to HPF to get a retune, right?
No you don't, HPF loads the stage 2 tune on your AEM by default . I called and asked before I put my meth kit on. Worked just fine without sending the AEM back.

Sent from my SAMSUNG-SGH-I717 using Bimmer App
__________________
GRK///M3 is offline   Reply With Quote
Old 12-19-2012, 02:57 AM   #28
zac5
Registered User
 
Join Date: Jun 2010
Location: Beijing, China
Posts: 60
My Ride: Turbo M3
Quote:
Originally Posted by GRK///M3 View Post
No you don't, HPF loads the stage 2 tune on your AEM by default . I called and asked before I put my meth kit on. Worked just fine without sending the AEM back.

Sent from my SAMSUNG-SGH-I717 using Bimmer App
Yes, I figured that out when I had meth kit installed later. Thanks all the same.
zac5 is offline   Reply With Quote
Old 12-20-2012, 04:41 AM   #29
Evil Twin Rob
Registered User
 
Join Date: Aug 2007
Location: Spokane Wa.
Posts: 1,086
My Ride: 2004 M3
My car was overboosting and it turned out to be a bad wire in one of the HPF harnesses. I believe they replaced the harness that tied the AEM to the factory ECU, but I can't say for sure.
__________________
HPF 2.5
Evil Twin Rob is offline   Reply With Quote
Old 12-20-2012, 05:17 AM   #30
nnacpil
Registered User
 
Join Date: Nov 2010
Location: WV
Posts: 217
My Ride: 2006 BMW M3
Quote:
Originally Posted by Evil Twin Rob View Post
My car was overboosting and it turned out to be a bad wire in one of the HPF harnesses. I believe they replaced the harness that tied the AEM to the factory ECU, but I can't say for sure.
Thanks. I hope that's not the case. How was that determined the problem?

I was thinking to buy race gas next weekend to record some solid pulls to show you guys what I'm seeing.
__________________

2006 BMW lllM3 SilverGrayMetallic/Cinnamon/Apex Arc-8
llHPF/ProEFI Stage 2.25 w/6766
SOLD!!!!!!!!!!!
nnacpil is offline   Reply With Quote
Old 12-23-2012, 01:50 AM   #31
Evil Twin Rob
Registered User
 
Join Date: Aug 2007
Location: Spokane Wa.
Posts: 1,086
My Ride: 2004 M3
Quote:
Originally Posted by nnacpil View Post
Thanks. I hope that's not the case. How was that determined the problem?

I was thinking to buy race gas next weekend to record some solid pulls to show you guys what I'm seeing.
Pretty much just trial and error. It ended up being the last thing on the checklist because it was the hardest component to swap. Fortunately the car was already at HPF when it happened.
__________________
HPF 2.5
Evil Twin Rob is offline   Reply With Quote
Old 12-23-2012, 01:58 AM   #32
nnacpil
Registered User
 
Join Date: Nov 2010
Location: WV
Posts: 217
My Ride: 2006 BMW M3
Quote:
Originally Posted by Evil Twin Rob View Post
Pretty much just trial and error. It ended up being the last thing on the checklist because it was the hardest component to swap. Fortunately the car was already at HPF when it happened.
I see. Well I've talked to HPF and they want me to send my ems out to them for a new tune. I'm hoping this will be an easy fix. I'll keep the thread posted for results once I get it back.
__________________

2006 BMW lllM3 SilverGrayMetallic/Cinnamon/Apex Arc-8
llHPF/ProEFI Stage 2.25 w/6766
SOLD!!!!!!!!!!!
nnacpil is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use