E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-30-2012, 12:28 AM   #1
ScouseYank
Registered User
 
Join Date: Dec 2012
Location: Oakland,Ca
Posts: 13
My Ride: 2001 325ci coupe
Yellow Brake light and Triangle with ! with Circle

Ok, so bought i used bmw and have had a few issues of which a quick search on here has found the right fixes, one thing i have searched for and cant really geta clear answer for is that when i start the car, there is a yellow brake light on as well as the triangle with the ! with a circle, all the searching has done nothing as i could not find anyone else with the same problem,

any help would be great,

Thanks
ScouseYank is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-30-2012, 12:30 AM   #2
eneka
Registered User
 
Join Date: May 2007
Location: SoCal
Posts: 1,818
My Ride: 2003 325i
something is wrong with DSC
__________________
eneka is online now   Reply With Quote
Old 12-30-2012, 12:48 AM   #3
ScouseYank
Registered User
 
Join Date: Dec 2012
Location: Oakland,Ca
Posts: 13
My Ride: 2001 325ci coupe
Quote:
Originally Posted by eneka View Post
something is wrong with DSC
ok, so what would one do ? take it to a shop?
is this something i could fix my self?

also pushing and holding the dcs button for 3-30 seconds does nothing

Last edited by ScouseYank; 12-30-2012 at 01:00 AM. Reason: extra info
ScouseYank is offline   Reply With Quote
Old 12-30-2012, 01:07 AM   #4
eneka
Registered User
 
Join Date: May 2007
Location: SoCal
Posts: 1,818
My Ride: 2003 325i
you need to diagnose it, it could be anything. Check the fuses, take it to an indy or someone that has a BMW scanner and they can pull codes and tell you exactly what's wrong.
__________________
eneka is online now   Reply With Quote
Old 12-30-2012, 01:21 AM   #5
mcr_driver
Registered User
 
Join Date: Aug 2007
Location: los angeles
Posts: 27,477
My Ride: my favorite two feet
you could try the stomp test and see if you get any codes from that if not, try the basics like unplug the battery for 30-60 minutes then repeat stomp test and see if any new codes come up. Agreed on checking the fuses as well after doing the code test. If possible use a code reader but if you don't that's a good place to start
__________________
http://img164.imageshack.us/my.php?image=ken10hm2.jpg
mcr_driver is offline   Reply With Quote
Old 12-30-2012, 08:54 AM   #6
zhenkaaaM3
Registered User
 
Join Date: Feb 2011
Location: New york
Posts: 5,609
My Ride: Fst'r then your e46
Its either a steering angle sensor or a wheel speed sensor.
__________________
.:Eugene:.

I used to be an e46 owner. I love this one more.

zhenkaaaM3 is offline   Reply With Quote
Old 12-30-2012, 09:04 AM   #7
chrism24
Registered User
 
Join Date: Aug 2012
Location: Colorado
Posts: 69
My Ride: 2002 325i
Have you tried just pressing the DSC button once and releasing it immediately?
__________________
chrism24 is offline   Reply With Quote
Old 12-30-2012, 09:16 AM   #8
BMW#3
Banned User
 
Join Date: Dec 2012
Location: SF Bay Area
Posts: 15
My Ride: Jet Black 330ci
Quote:
Originally Posted by E46tknv View Post
Its either a steering angle sensor or a wheel speed sensor.
It was the steering angle sensor for me. Fastest thing to do like people have said is to go get it scanned by an indi, or if you're suicidal by the dealer. The steering angle sensor was fairly expensive from what I remember. Good luck!
BMW#3 is offline   Reply With Quote
Old 12-30-2012, 09:33 AM   #9
Sh0ty
Registered User
 
Join Date: Jun 2012
Location: Michigan
Posts: 28
My Ride: 2004 330Ci
The steering angle sensor (SZL or SLZ, can't remember) was around $1000 when I was pricing it for an E90, to give a ballpark.
Sh0ty is offline   Reply With Quote
Old 12-30-2012, 09:44 AM   #10
BMW#3
Banned User
 
Join Date: Dec 2012
Location: SF Bay Area
Posts: 15
My Ride: Jet Black 330ci
Quote:
Originally Posted by Sh0ty View Post
The steering angle sensor (SZL or SLZ, can't remember) was around $1000 when I was pricing it for an E90, to give a ballpark.
Yea, I don't think I walked out of there for less than $750.
BMW#3 is offline   Reply With Quote
Old 12-30-2012, 10:32 AM   #11
RayPooley
Registered User
 
Join Date: Jul 2012
Location: Liverpool
Posts: 1,454
My Ride: 320i SE Coupe
Quote:
Originally Posted by ScouseYank View Post
Ok, so bought i used bmw and have had a few issues of which a quick search on here has found the right fixes, one thing i have searched for and cant really geta clear answer for is that when i start the car, there is a yellow brake light on as well as the triangle with the ! with a circle, all the searching has done nothing as i could not find anyone else with the same problem,

any help would be great,

Thanks
Like this? This indicates that the DSC is switched off. Normally on by default and you need to hold the DSC button down fro three seconds to switch it off. If these lights are on by default may indicate dirty wheel speed sensors or faulty ones, a malfunctioning steering position sensor and so forth. Start with cleaning wheel sensors. That's a cheap and easy place to start. Take a look at the attached PDF for more info on the components involved. Also press your DSC button see if the go out and then come back on again. I should also say that this happened a month or so ago when I had a faulty crank position sensor which caused my car to stall momentarilly while on the move. These lights came on and stayed on until I switched of the ignition. The lights don't mean that you can't drive the car by the way.
Attached Thumbnails
Click image for larger version

Name:	IMAG0174.jpg
Views:	167
Size:	102.4 KB
ID:	483991  
Attached Files
File Type: pdf DSC part 1.pdf (979.6 KB, 114 views)

Last edited by RayPooley; 12-30-2012 at 10:50 AM.
RayPooley is offline   Reply With Quote
Old 12-30-2012, 10:36 AM   #12
darksideracer69
Registered User
 
Join Date: Jan 2008
Location: TX
Posts: 2,886
My Ride: 01 325ci
Don't start anywhere with out getting the codes read first. You'll just waste time and money ****ing around.

Sent from my PC36100 using Bimmer App
__________________
Quote:
Originally Posted by dmax View Post
If she ever yells 'oh god, oh god' just say, 'no, just Doug.'


IMAG02051
darksideracer69 is offline   Reply With Quote
Old 12-30-2012, 10:43 AM   #13
BMW#3
Banned User
 
Join Date: Dec 2012
Location: SF Bay Area
Posts: 15
My Ride: Jet Black 330ci
Quote:
Originally Posted by darksideracer69 View Post
Don't start anywhere with out getting the codes read first. You'll just waste time and money ****ing around.

Sent from my PC36100 using Bimmer App
Bam! He speaks the truth!
BMW#3 is offline   Reply With Quote
Old 12-30-2012, 12:07 PM   #14
SidewaysBimmer413
Registered User
 
Join Date: Dec 2012
Location: Menifee
Posts: 1
My Ride: 2002 325i Auto
Correct me if i am wrong but is the ! with the Circle around it just the traction control? the DISC button just needs to be pressed for a second or so to turn it off and on.
SidewaysBimmer413 is offline   Reply With Quote
Old 12-30-2012, 12:11 PM   #15
BMW#3
Banned User
 
Join Date: Dec 2012
Location: SF Bay Area
Posts: 15
My Ride: Jet Black 330ci
Quote:
Originally Posted by SidewaysBimmer413 View Post
Correct me if i am wrong but is the ! with the Circle around it just the traction control? the DISC button just needs to be pressed for a second or so to turn it off and on.
If evrything is working properly that's true but combined with the yellow brake light it means you've got a more serious problem like the ones above.
BMW#3 is offline   Reply With Quote
Old 12-30-2012, 12:14 PM   #16
sweetbro858
Registered User
 
Join Date: Mar 2008
Location: San Diego
Posts: 552
My Ride: BMW
Could be thinking of different dash light, but one would come on all the time driving in the snow. Snow got stuck up all in the brakes and by that sensor...
__________________
sweetbro858 is offline   Reply With Quote
Old 12-30-2012, 01:27 PM   #17
RayPooley
Registered User
 
Join Date: Jul 2012
Location: Liverpool
Posts: 1,454
My Ride: 320i SE Coupe
Quote:
Originally Posted by sweetbro858 View Post
Could be thinking of different dash light, but one would come on all the time driving in the snow. Snow got stuck up all in the brakes and by that sensor...
Speed sensors work by detecting changes in magnetic flux density as rotating elements move in and out of the sensor's magnetic field. They are basically permanent magnets with a coil wrapped around them. Anything that interferes, obstructs or bridges the normal gap between the magnet and the rotating element (eg: snow, mud) can have an impact on the voltage of the pulses received by the DME which, in turn, can be interpreted as fault resulting in automatic shutting down of DSC as precaution. So check the cleanliness and integrity of the wheel sensors first.

Last edited by RayPooley; 12-30-2012 at 01:28 PM.
RayPooley is offline   Reply With Quote
Old 12-30-2012, 01:33 PM   #18
TrickTizzle
Registered User
 
Join Date: Nov 2008
Location: Minneapolis/Milwaukee
Posts: 3,111
My Ride: 325i
Send a message via AIM to TrickTizzle
Bad wheel speed sensor.
Scan the car to see which is throwing error and clean it with a wire brush. Might as well clean all of them while your at it. If cleaning doesn't work just replace the sensor. Takes 5 min .
TrickTizzle is offline   Reply With Quote
Old 12-30-2012, 01:41 PM   #19
sweetbro858
Registered User
 
Join Date: Mar 2008
Location: San Diego
Posts: 552
My Ride: BMW
Quote:
Originally Posted by RayPooley View Post
Speed sensors work by detecting changes in magnetic flux density as rotating elements move in and out of the sensor's magnetic field. They are basically permanent magnets with a coil wrapped around them. Anything that interferes, obstructs or bridges the normal gap between the magnet and the rotating element (eg: snow, mud) can have an impact on the voltage of the pulses received by the DME which, in turn, can be interpreted as fault resulting in automatic shutting down of DSC as precaution. So check the cleanliness and integrity of the wheel sensors first.
It's like you took the words right outta my mouth

What I meant was, when snow got packed up in my brakes, the light would sometimes come on and then go off when it was clear again.
__________________

Last edited by sweetbro858; 12-30-2012 at 01:43 PM.
sweetbro858 is offline   Reply With Quote
Old 12-30-2012, 09:14 PM   #20
E46LR
Registered User
 
Join Date: Dec 2012
Location: Puerto Rico
Posts: 2
My Ride: E46
If is the steering angle is about $300 in E90 the SZL brings the steering angle that is the reason of the price $1,000
E46LR is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use