E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 12-31-2012, 01:04 PM   #1
mkt3c
Registered User
 
Join Date: Apr 2011
Location: Tennessee
Posts: 27
My Ride: 2001 330xi
Need help with rough idle and stalling

Alright so the alternator on my 2001 330xi went out last week so I replaced it. After install I tried to start it and it would just turn over but never fire. I searched and read somewhere that if the battery is low it won't start so I charged the battery fully and it started up and then bogged down and died. After a few more tries got the same thing, fires up for a few seconds then dies. I found that if I give it gas after start up I could keep it running. The next day I tried it again and it idles rough but would run by itself. But if I rev the engine up to 3k or higher and let off it bogs down and dies when it gets back to idle. I researched some more and thought it might be the fuel pump since I have 170,000 on what seemed to be the original one. So I changed the fuel pump but it died not fix the problem. Still idles the same but dies if I rev it up and let off. I need help diagnosing this. I've searched but can't figure it out. I went back and retraced all my install steps for the alternator and don't see anything I left unplugged or disconnected. Any suggestion are appreciated. Thanks

Sent from my DROID RAZR using Bimmer App
mkt3c is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use