E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Forced Induction Forum Sponsored by Active Autowerke

Forced Induction Forum Sponsored by Active Autowerke
Discuss supercharging, turbocharging and even nitrous and water injection here.
Sponsored by Active Autowerke

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-30-2012, 01:16 PM   #1
05aazhp
Registered User
 
Join Date: Jan 2012
Location: Milwaukee, Wisconsin
Posts: 15
My Ride: 05 330i ZHP
Bad AA Diverter valve?

Hey,

I have been trying to track down a possible vacuum leak. I have been getting a "idle speed implausible, air leakage" code. I clear it and it comes back in a day. I did several boost leak tests without finding anything. Today I did a smoke test with a home made smoke machine (glow plug and mineral oil). The only smoke leak I could find was one out of the back of the diverter valve, the port that vents to atmosphere. My understanding is that that is there to allow the diaphragm/spring to move up and down as necessary. If that is the case and I am getting smoke out of it, could the diaphragm be torn??? Any ideas would help.

Symptoms
Engine Code Idle speed implausible, air leakage
High idle - 1000rpm
Idle hangs once clutch is pressed, hangs at 1300 or so for about 2 seconds before seddling down to 1000rpm.

Set up
05 zhp
aa stage 2.5
__________________
2005 BMW 330i ZHP
Black on Black
AA stage 2.5
05aazhp is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-30-2012, 07:26 PM   #2
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,384
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
I am about to change my Diverter Valve to a Tial Recir Q Valve. It will be the last thing that AA build/label on my car. (All been replace with better or higher quality parts)

Last edited by TrippinBimmer; 12-30-2012 at 07:26 PM.
TrippinBimmer is offline   Reply With Quote
Old 12-30-2012, 07:56 PM   #3
05aazhp
Registered User
 
Join Date: Jan 2012
Location: Milwaukee, Wisconsin
Posts: 15
My Ride: 05 330i ZHP
Are you changing it as a preventative measure or changing it due to suspected failure?
__________________
2005 BMW 330i ZHP
Black on Black
AA stage 2.5
05aazhp is offline   Reply With Quote
Old 12-31-2012, 01:16 AM   #4
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,384
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
Quote:
Originally Posted by 05aazhp View Post
Are you changing it as a preventative measure or changing it due to suspected failure?
Both...As the valve is adjusted by a screw. So I really don't know what HgV when the valve opening. So I rather go to a spring setup...to me more reliable and proven setup. Personal Preference...

As for your issues. I would hit up Viral hopefully he can help you.
TrippinBimmer is offline   Reply With Quote
Old 12-31-2012, 11:18 AM   #5
drumbum624
Registered User
 
Join Date: Dec 2010
Location: Baltimore, MD/DC
Posts: 653
My Ride: 325xi
Send a message via AIM to drumbum624
Just a thought, might your diverter valve not be hooked up properly? I accidentally ran mine backwards for a little bit. Make sure your entry and exit from the valve is right
__________________
drumbum624 is offline   Reply With Quote
Old 12-31-2012, 11:24 AM   #6
coinage
Registered User
 
Join Date: Mar 2010
Location: Hershey,PA
Posts: 32
My Ride: 02 M3
Have you pulled vacuum on the valve to see if it holds?
__________________
02 M3 JB/IR
VF Stage 2+,Meth Inj, HPF Fuel Pump,AA Gen3 Muffler, TCK S/A 500/500,Turner sways,VMR V718,StopTech 355, PF FCAB and RTAB

To be installed: SuperSprint V1,ClutchMaster FX700 twin disc clutch,VAC Solid Diff Bushings, Solid Sub Frame Bushings, AS SSK


03 TiAg/Black SMG- For Sale $17K PM for details

Performance Installs,Maintenance,GT1,Engine Builds,Diff Installs,Fab Work PM for details
coinage is offline   Reply With Quote
Old 12-31-2012, 01:39 PM   #7
05aazhp
Registered User
 
Join Date: Jan 2012
Location: Milwaukee, Wisconsin
Posts: 15
My Ride: 05 330i ZHP
Quote:
Originally Posted by drumbum624 View Post
Just a thought, might your diverter valve not be hooked up properly? I accidentally ran mine backwards for a little bit. Make sure your entry and exit from the valve is right
The in and out is not changeable on this diverter valve. One side gets bolted onto the intake pipe and the other is round and gets sent back towards the supercharger via a small rubber coupler.
__________________
2005 BMW 330i ZHP
Black on Black
AA stage 2.5
05aazhp is offline   Reply With Quote
Old 12-31-2012, 01:40 PM   #8
05aazhp
Registered User
 
Join Date: Jan 2012
Location: Milwaukee, Wisconsin
Posts: 15
My Ride: 05 330i ZHP
Quote:
Originally Posted by coinage View Post
Have you pulled vacuum on the valve to see if it holds?
I don't have a small vacuum pump to try this. Could I just force open the valve and cover the vacuum nipple. This should hold the valve open correct??
__________________
2005 BMW 330i ZHP
Black on Black
AA stage 2.5
05aazhp is offline   Reply With Quote
Old 01-02-2013, 07:24 AM   #9
bigjae1976
Registered User
 
bigjae1976's Avatar
 
Join Date: Dec 2003
Location: Earth
Posts: 11,474
My Ride: A car
Send a message via MSN to bigjae1976
Mine does the same thing. Swap in a new recirc valve from AA...did the same thing.
bigjae1976 is offline   Reply With Quote
Old 01-02-2013, 09:28 AM   #10
05aazhp
Registered User
 
Join Date: Jan 2012
Location: Milwaukee, Wisconsin
Posts: 15
My Ride: 05 330i ZHP
Quote:
Originally Posted by bigjae1976 View Post
Mine does the same thing. Swap in a new recirc valve from AA...did the same thing.
So I am assuming that the my valve is working properly. I did email AA about this and am waiting for a response. I will update you on what they say. Im thinking that this may be an issue with the tune. I forgot to mention that this started once I installed my re flashed computer. The computers estimated MPG also way off saying im getting an average of 29 mpg....in winter.....in Wisconsin. Its 12 degrees out today. There is no way im getting that. The little instantaneous gauge also is off saying that I am typically getting 50mpg, which is also incorrect.
__________________
2005 BMW 330i ZHP
Black on Black
AA stage 2.5
05aazhp is offline   Reply With Quote
Old 01-02-2013, 07:56 PM   #11
bigjae1976
Registered User
 
bigjae1976's Avatar
 
Join Date: Dec 2003
Location: Earth
Posts: 11,474
My Ride: A car
Send a message via MSN to bigjae1976
I've been told that an exhaust leak with aftermarket headers can cause idle surge and weird idling. The claim was that exhaust air is pulled back up across the O2 sensors between pulses. I guess this is not an issue with the OEM manifolds since the cat is between the precat O2 sensors? I kept burning through gaskets so I just had some V-bands installed.

But my idle still surges a bit but not terrible. I still think the tune is not totally correct.

I plan to get Eurocharged to do my tune in the near future. Remote tuning was such a PIA.

Last edited by bigjae1976; 01-02-2013 at 07:57 PM.
bigjae1976 is offline   Reply With Quote
Old 01-03-2013, 09:19 AM   #12
05aazhp
Registered User
 
Join Date: Jan 2012
Location: Milwaukee, Wisconsin
Posts: 15
My Ride: 05 330i ZHP
Quote:
Originally Posted by bigjae1976 View Post
I've been told that an exhaust leak with aftermarket headers can cause idle surge and weird idling. The claim was that exhaust air is pulled back up across the O2 sensors between pulses. I guess this is not an issue with the OEM manifolds since the cat is between the precat O2 sensors? I kept burning through gaskets so I just had some V-bands installed.

But my idle still surges a bit but not terrible. I still think the tune is not totally correct.

I plan to get Eurocharged to do my tune in the near future. Remote tuning was such a PIA.
I have heard this as well but I do not think that this is the issue. The idle issue started immediately after I installed the returned AA computer.
__________________
2005 BMW 330i ZHP
Black on Black
AA stage 2.5
05aazhp is offline   Reply With Quote
Old 01-03-2013, 09:27 AM   #13
05aazhp
Registered User
 
Join Date: Jan 2012
Location: Milwaukee, Wisconsin
Posts: 15
My Ride: 05 330i ZHP
This is AA's response to my guestion

"The BOV leak seems to be your biggest issue. Do you have the ability to test it with a vacuum pump, or have a local shop that could look the car over? The nipple on the other side should not have smoke coming out of it, and the diaphragm could be torn.

The MPG reading will be off because of the larger injectors that go along with the kit. Instantaneous MPG is calculated by using the injector duty cycle signal. This signal is going to be very different with larger injectors and will therefore register incorrectly."

I am going to test the valve this weekend using a hand held vacuum pump. If it is for sure bad, is there a rebuild kit for this? I would hate to spend a bunch of money on a new valve when I could just replace a molded piece of rubber......
__________________
2005 BMW 330i ZHP
Black on Black
AA stage 2.5
05aazhp is offline   Reply With Quote
Old 01-03-2013, 10:38 AM   #14
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,384
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
Should ask active that question. As its there BOV.
TrippinBimmer is offline   Reply With Quote
Old 01-03-2013, 11:21 AM   #15
05aazhp
Registered User
 
Join Date: Jan 2012
Location: Milwaukee, Wisconsin
Posts: 15
My Ride: 05 330i ZHP
Quote:
Originally Posted by TrippinBimmer View Post
Should ask active that question. As its there BOV.
I did earlier, I am waiting for a response. I was just wondering if anybody has repaired them before. I have had no luck searching.
__________________
2005 BMW 330i ZHP
Black on Black
AA stage 2.5
05aazhp is offline   Reply With Quote
Old 01-03-2013, 09:40 PM   #16
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,384
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
Is your car an Auto?
TrippinBimmer is offline   Reply With Quote
Old 01-03-2013, 10:51 PM   #17
BrianSpilner
Registered User
 
Join Date: Feb 2006
Location: Chicago - Greece
Posts: 463
My Ride: Max PSI Stage 2
You should look into running an Alpha-N tune so you do not have to recirculate, and to avoid these problems. Also, upgrade to a Tial Q blowoff valve.
__________________
Follow Me: Facebook | Youtube | Zima Motorsports
Follow My Builds: Max PSI Stage 2 E46 M3 Turbo Build | 1972 2002 Restomod Build
2004 BMW E46 ///M3 | Maximum PSI Stage 2 Turbo | SMGII | Non-Catted | Epic Motorsports Rod Bearing Kit | ARP Head Studs | Bimmerworld 3.5" Non-Resonated Single Race Exhaust
BrianSpilner is offline   Reply With Quote
Old 01-03-2013, 11:03 PM   #18
bigjae1976
Registered User
 
bigjae1976's Avatar
 
Join Date: Dec 2003
Location: Earth
Posts: 11,474
My Ride: A car
Send a message via MSN to bigjae1976
Has anyone got Alpha-N right on an MS45 DME?
bigjae1976 is offline   Reply With Quote
Old 01-04-2013, 12:22 AM   #19
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,384
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
Quote:
Originally Posted by bigjae1976 View Post
Has anyone got Alpha-N right on an MS45 DME?
Nope...
TrippinBimmer is offline   Reply With Quote
Old 01-04-2013, 03:37 PM   #20
Mormon
Registered User
 
Join Date: May 2011
Location: Yuma, Az
Posts: 52
My Ride: 2001 330xi
Subbed
Mormon is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use