E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 3 votes, 5.00 average. Display Modes
Old 04-21-2012, 10:00 PM   #1
nughaud
Registered User
 
Join Date: Sep 2003
Location: NW FL
Posts: 138
My Ride: '01 330CI / '11 335i
2001 330Ci Tail Light Fix (Fast Blinker, Headlights flicker, Grounding issue)

So, I see there is a recall for the following vehicles:
Affected vehicles
325I - 2002-2005, 325XI - 2002-2005, 330I - 2002-2005, 330XI - 2002-2005

I've heard there is a recall for 2001 cars, but haven't seen it.

The 2002-2005 cars are different from the 2001, so I thought I'd take some photos and post them.

The concept is the same as other threads on here, but I show you the look for the 2001 car and what I did to secure a new working ground.

On my car I always have fast blinkers and in my case it was the left side of my car. The right side never really did it, and if it did it was a bad bulb. So after looking at the rear left lights I saw I only had a problem on that side and not the left. I also would get intermittent rear light out on the cluster panel, which was a false alarm. In the end this fix has stopped me from years of this pain. It's a 2001, so it goes to show that BMW should be covering this issue also.

Parts needed 14-18 gauge wire ($.30 to .40) cents a foot at Lowes or Home Depot
T-taps or Wire tap connectors ($2-$4) at hardware store or Radio Shack.

Contact cleaner to spray in both the connector and the assembly. (allow time for it to dry before assembling the connects back together.)
Electrical tape or other component to protect the wire from contacting other metal parts.
Any type of pliers to crush the male end of the taps that go into the female end.



On internal rear light assembly there is the metal structure that connect all 3 bulbs together and since ours doesn't have metal end for a butt connector to slide over, we can use the hole which I have circled in red. That whole is used on the outside tail light, but you can easily break off the pin that sticks out and thus allow your new ground wire to utilize the hole in the internal light assembly. When you break off the super small pin, it doesn't have any effect or cause any issues. I'm not even sure what the purpose of it was to be honest. I could of broke it off with my pinky finger.

As you can see the problem on my car is the tail light socket connector is bad.



The old part number above was: 61138369702
The new 6 pin part number below is: 61136984758



Another issue you might run into, but it was not my issue, even though you can see the carrier housing on the tail light is not in the best shape.
If yours is not functioning then you will need to buy a the whole rear light carrier/housing for the left and right.
You only need this part if your socket connector is bad or melted/burnt.



If you need the tail light carrier/housing parts, here they are:
left light carrier housing: 63218364729
right light carrier housing: 63218364730
Example of left:



left light carrier housing, clear light signals: 63218383827
right light carrier housing, clear light signals: 63218383828

Example of left:



Here are photos of what I did below. These are similar to others, but this is specific to my 2001 330Ci.

Here is a photo showing the 14-18 gauge wire should use to fully ground your rear lights. On my 2001 I have a whole which I'm not sure what it's used for, but there was a really small pin sticking out of the bulb housing. It almost broke by just barely touching it with my pinky, so I don't think it really serves any purpose. I broke it off on both of my rear light housings.



Here is the photo of where the small plastic pin used to be.
With this removed you can use the hole for your grounding wire.
Otherwise you would need to either use a self taping metal screw or bend the metal up so you can wrap the wire under it.


Different lighting photo of same thing:


Here is just another close up:



Here is how it was initially wired up, but then I decided I needed to change it in the last photo to get the new grounding wire out of the way. As you can see the connection is to the brown wire or #4 slot. If you have a different pin out check to see which yours is.



The way it was ultimately routed and the black electric tape I used over the ground wire on the housing assembly:



If you need an 8 pin here is the part: 61136909008
http://www.realoem.com/bmw/showparts...80&hg=61&fg=15
__________________
nughaud is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 05-05-2012, 08:58 PM   #2
nughaud
Registered User
 
Join Date: Sep 2003
Location: NW FL
Posts: 138
My Ride: '01 330CI / '11 335i
Well, I thought I'd get at least one reply, specifically since this was for a 2001 car and not the normal 2002+ and I posted it more than two weeks ago. I know I personally had to search for a lot of information for my car on this. Oh well, maybe it got buried since I posted it in the lighting section.
__________________
nughaud is offline   Reply With Quote
Old 05-12-2012, 01:31 AM   #3
NJfistpumpin
Registered User
 
Join Date: Mar 2012
Location: Middletown NJ
Posts: 257
My Ride: 2003 OG M3
I just bought led taillights from Khoalty and it threw the codes and all and they won't even light up. I believe it's because I have nowhere to mount that stupid ground...
__________________
Oxford green / cinnamon / Vert
NJfistpumpin is offline   Reply With Quote
Old 06-21-2012, 06:55 AM   #4
junglee
Registered User
 
Join Date: Aug 2002
Location: Toronto
Posts: 3
My Ride: Steel Gray 325i
Thanks nughaud, exactly the steps i was looking for. Will try this tonight
junglee is offline   Reply With Quote
Old 06-21-2012, 06:21 PM   #5
junglee
Registered User
 
Join Date: Aug 2002
Location: Toronto
Posts: 3
My Ride: Steel Gray 325i
Job Done..my assembly was a bit different than yours since I have a 325i. In any case I was able to screw in a round terminator into the ground and the lights are back on
junglee is offline   Reply With Quote
Old 06-26-2012, 04:29 PM   #6
nughaud
Registered User
 
Join Date: Sep 2003
Location: NW FL
Posts: 138
My Ride: '01 330CI / '11 335i
I'm glad someone got some use out of it, I'm just sad it took me a few years to realize it was the lights not being grounded instead of the bulbs and lighting harness.
__________________
nughaud is offline   Reply With Quote
Old 10-09-2012, 07:26 AM   #7
ALinVirginia
Registered User
 
Join Date: Oct 2012
Location: Virginia
Posts: 1
My Ride: 2001 330CI
Hey nughaud, my 2001 330CI within the past 3 months has randomly gone to fast blink mode. I had issues in my FR signal in the past, but apparently the deer I hit two years ago and follow-on work in that are fixed that issue. But recently, I realized it was the RR lights. I found dimming bulbs, and good bulbs tried there obviously did the same dimming, so figured it was the bulb holder part. I did a Google search yesterday and found your post, what I had was exactly the same problem you had.

I went home last night after work, grabbed a few parts from my workbench that I had on hand, and did the fix as you presented, took about 10 minutes of my time. Your solution worked perfectly.

Thank you for taking the time to post the explanation, pictures and solution. It saved me a little headache and time to diagnose and/or a trip to the shop.

AL

Last edited by ALinVirginia; 10-09-2012 at 07:27 AM.
ALinVirginia is offline   Reply With Quote
Old 10-09-2012, 08:42 AM   #8
Dirty Mike
Registered User
 
Join Date: Jan 2011
Location: Alabama
Posts: 317
My Ride: Fern Green 330ci
Glad there's finally a write up. I fixed mine this summer and I just bypassed the ground connection all together and spliced the ground wire to another wire and connected that straight to the ground. This seems easier and less crackheady
Dirty Mike is offline   Reply With Quote
Old 10-15-2012, 11:10 AM   #9
eph6jonprice
Registered User
 
Join Date: Oct 2012
Location: Mount Crawford, VA
Posts: 115
My Ride: 2001 330Ci
So do these need replacing or can they be salvaged?

Thanks VERY much for the help of your post! In trying to figure this out (among MANY other problems recently) I looked at the connections and here is what I found...

So do I need to order the new connector (expecting that), but also, does it look like I'll need to order a new assembly for the tail lights, or does that look cleanable/fixable? Thanks again for the help, NOT an expert as I am just now starting to do DIY stuff, and these forums have been extremely helpful!
Attached Thumbnails
Click image for larger version

Name:	2012-10-15_11-44-44_817.jpg
Views:	277
Size:	92.7 KB
ID:	473976   Click image for larger version

Name:	2012-10-15_11-42-53_946.jpg
Views:	259
Size:	55.6 KB
ID:	473977   Click image for larger version

Name:	2012-10-15_11-43-05_323.jpg
Views:	217
Size:	53.8 KB
ID:	473978   Click image for larger version

Name:	2012-10-15_11-44-11_457.jpg
Views:	205
Size:	79.8 KB
ID:	473979  

Click image for larger version

Name:	2012-10-15_11-44-52_79.jpg
Views:	214
Size:	131.3 KB
ID:	473980  
eph6jonprice is offline   Reply With Quote
Old 10-16-2012, 04:42 PM   #10
nughaud
Registered User
 
Join Date: Sep 2003
Location: NW FL
Posts: 138
My Ride: '01 330CI / '11 335i
Hello,

I'm out of town right now, but wow, you need both the tail light carrier housing and the main connector in my opinion. If it was my car I would replace both. It is possible the housing can be cleaned with rust remover and the electrical contact cleaner spray solution. Those wires are also majorly frayed and so you should cut the ends off and then proceed to strip them. Also, I see a lot of rust which should be removed from anything that might be staying. You still need to make that additional ground which will cure any future issues.

One question, why is there so much rust and damage? It looks like your car goes for a swim on a monthly basis, no pun intended.
__________________

Last edited by nughaud; 10-16-2012 at 04:45 PM.
nughaud is offline   Reply With Quote
Old 10-17-2012, 05:21 PM   #11
eph6jonprice
Registered User
 
Join Date: Oct 2012
Location: Mount Crawford, VA
Posts: 115
My Ride: 2001 330Ci
I think the person who had it before me had an accident on the back left side and I'm guessing water (rain) got in there and was never thoroughly cleaned out... thanks for the reply though, and thanks for posting!
eph6jonprice is offline   Reply With Quote
Old 10-17-2012, 05:23 PM   #12
eph6jonprice
Registered User
 
Join Date: Oct 2012
Location: Mount Crawford, VA
Posts: 115
My Ride: 2001 330Ci
Turn signal works now! Still getting a code for brake light out, is this something that needs to be reset somehow?
eph6jonprice is offline   Reply With Quote
Old 01-13-2013, 09:36 AM   #13
BavarianBombshell
Registered User
 
Join Date: Jun 2012
Location: East Lansing
Posts: 19
My Ride: 2001 BMW 330Ci
My cluster panel indicates that both rear lights are out, but from what I can tell everything is working fine. Both warning lights came on simultaneously. Could this be the issue?

I was planning to go ahead and reground the wires, but I thought it was unlikely that a bad ground on one side would cause both warnings to light up.
BavarianBombshell is offline   Reply With Quote
Old 08-19-2013, 11:04 PM   #14
RickGrad
Registered User
 
Join Date: Aug 2013
Location: Portland
Posts: 2
My Ride: 2001 330
Nughaud, Thank you soo much for taking the time to post the work you did on you 2001 330. I have the same problem with my 2001 330 and I thought it was going to cost me hundreds of dollars to fix, I owe you a beer man.
RickGrad is offline   Reply With Quote
Old 08-30-2013, 09:30 AM   #15
jcolome
Registered User
 
Join Date: Oct 2011
Location: Miami
Posts: 5
My Ride: 325i BMW - 2002
your post

Bro - your instructions are a God send. Having to not have to deal with BMW here in town is priceless.

Thank you soooo much


JC

Miami, Fl


jcolome is offline   Reply With Quote
Old 08-30-2013, 09:34 AM   #16
jcolome
Registered User
 
Join Date: Oct 2011
Location: Miami
Posts: 5
My Ride: 325i BMW - 2002
2002 325i faulty wiring

How do you know what wire color to "tap" into ? always brown ?

Last edited by jcolome; 08-30-2013 at 09:39 AM. Reason: wrong question
jcolome is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use