E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 01-17-2013, 07:49 AM   #1
flyin_lo
Registered User
 
Join Date: Dec 2007
Location: Louisiana
Posts: 5
My Ride: 2004 330i
330i keeps destroying CSB's

My 2004 330i seems to have an appetite for center support bearings. About 6 months ago, my car started to get the shudder under acceleration. After a little forum searching, I decided thet the guibo was probably the problem, so I replaced it. The csb rubber was a little cracked, but I'd not ordered one, so I put it all back together. A few weeks later, I was back under the car replacing the csb. Apparently, driving with a bad csb doesn't do the guibo any good, because it was already showing wear signs (replaced again). During the csb replacement, the driveshaft was marked so it went back in the same position. Since this time, I've been through 2 more csb's. I've preloaded the bearing, put the mount back in the exact position it came out from, etc.
The rubber around the bearing is lasting about 2 weeks. Does anyone out there have any idea why this car might be continually destroying these bearings? This is getting rather expensive. On the positive side, I've become extremely proficient at replacing it (out and back in in 1 1/2 hours).

Thanks in advance for any suggestions.
flyin_lo is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use