E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 01-17-2013, 09:44 PM   #1
CK325
Registered User
 
Join Date: Sep 2012
Location: Philadelphia, PA
Posts: 495
My Ride: 323Ci, 325xi
car dies when braking?

Tried researching this a bit on here as well as via google but can't seem to find anything that directly relates to my issue, so;

this has happened 3 days in a row now, I start to slow down and by the time i'm still my engine has already stopped running. That's the gist of it. Before I get into the specifics that I managed to notice so far, some background info on the car.

04 325xi, 5-speed. Purchased a few months ago, put about a 1000 miles on it so far. I can't remember off the top of my head exactly but the car has about 90k miles on it. Runs and drives fine, apart from this damned thing.

First time this happened I was coming to a stop at a red light and I believe it happened when I took the car out of 2nd gear, but I had to turn a bit to avoid a pothole and realized my power steering wasn't working which then lead me to realize my gas pedal wasn't functioning as you'd expect it to as my car shut off.
Second time this happened was under similar circumstances but while the engine was still on, I noticed the battery light go on, then check engine light, then oil.
Third time, similar story.

The car starts right up right after this happens without any hesitation. It doesn't stutter as if I stalled out or anything of that sort. I don't have any sort of warning light on at a constant basis, the car runs and drives great.
It's almost as if fuel just gets cut off but I don't think that this is the case.
As I'm writing this, I'm thinking maybe a battery terminal came loose? I'll check on that in the morning but again, I don't think that's so as I wouldn't be able to start my car right away, right?

Also, not sure if this relates to anything, but when I first start my car in the morning and it's fairly cold and I give it a bit of gas in neutral the revs actually go down and eventually it stalls unless I give it a good quick tap. I mean I usually wait until the car is warmed up to drive it but I never had the same issue with my old car.

Last edited by CK325; 01-21-2013 at 05:17 PM.
CK325 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use