E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 01-18-2013, 10:37 AM   #1
glhx
Registered User
 
Join Date: Jan 2012
Location: Nashville, Tennessee
Posts: 1,186
My Ride: 2002 BMW 330ci
CEL light on....SAP bad and other engine performance problems

I received an item that allows me to use the torque pro app today.

vacuum 24 according to torque pro
engine rpm 700
engine rpm in drive 640 rpm
coolant temp was 84C
throttle showed at 10
o2 sensor data bouncing between .1and .7 volts will post pictures between the bank 1 and 2
they do look different. bank 1 is more up and down and bank two is more smooth.
post cat o2 runs live at .45 straight across

obd rediness....evap is unready
SAP system unready (because its not even on the car right now) The electric motor melted.

o2, catalyst, o2 heater.....show ready

I used PA soft to get bmw specific codes because the CEL was on
The first time was
P0491 = Secondary Air Injection System Insufficient Flow (Bank 1)
P0492 = Secondary Air Injection System Insufficient Flow (Bank 2)

I cleared it and a day later i got
E4/B1 - Oxygen sensor controller, bank 2, deviation too great, deviation rich
E3/B1 - Oxygen sensor controller, bank 1, deviation too great, deviation rich

I know the SAP is not working and that the pump is bad.

Could this be why my car is running so rich? Average gas mileage is decreasing and is now down to 15mpg on the obc

Last edited by glhx; 01-18-2013 at 02:18 PM.
glhx is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use