E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 28 votes, 5.00 average. Display Modes
Old 09-21-2011, 10:57 PM   #241
bwallace530
Registered User
 
Join Date: Jan 2011
Location: Oregon
Posts: 1,866
My Ride: 325
Mine runs a lil rich also. If you take it up to the rev limiter and let it bounce off in nuetral it almost sounds like it pops out of the exahust. I do not have o2 sims either. Need to get them last time I went to buy they were sold out.
bwallace530 is offline   Reply With Quote
Old 09-22-2011, 08:30 AM   #242
///Mostarac
Registered User
 
///Mostarac's Avatar
 
Join Date: Jun 2010
Location: Bosnia-Hercegovina, New Jersey
Posts: 4,967
My Ride: SiennaE46 & Cbr600rr
Quote:
Originally Posted by redlin'r View Post
Got them installed! Great fitment and fairly easy to tackle. I still have to do the o2 sim.

I have no muffler or second resonator and boy is it loud. Seems to be running rich as it pops a lot on declaration.

I went for a test drive and I had the car turn off and throw a ses after going to redline then neutral...normal? I am thinking this will go away after o2 sim.

Sent from my ADR6300 using Bimmer
post vid or go home
__________________
PARTING OUT MY CAR!!!!!! CLICK HERE
Eurowerkz | East Coast
-Benny
///Mostarac is offline   Reply With Quote
Old 09-23-2011, 12:54 PM   #243
redlin'r
Registered User
 
Join Date: Jul 2008
Location: New Market
Posts: 338
My Ride: (E46) 330Ci
Quote:
Originally Posted by ///Mostarac View Post
post vid or go home
Will do. I am babying it right now until I get the o2 sim wired in tonight. It sounds like a beast after 2500rpm. Video to follow by the end of the weekend.

As for updates I was thinking about the neutral stall-out. My belief is that with the back pressure reducing it cause the car to stall out after redlining and throwing it in neutral.
redlin'r is offline   Reply With Quote
Old 09-23-2011, 06:59 PM   #244
///Mostarac
Registered User
 
///Mostarac's Avatar
 
Join Date: Jun 2010
Location: Bosnia-Hercegovina, New Jersey
Posts: 4,967
My Ride: SiennaE46 & Cbr600rr
lol i dont even have 02 sims, in fact my 02 sensors arent even plugged in
__________________
PARTING OUT MY CAR!!!!!! CLICK HERE
Eurowerkz | East Coast
-Benny
///Mostarac is offline   Reply With Quote
Old 09-26-2011, 08:59 PM   #245
chanlon7
Registered User
 
Join Date: Jul 2008
Location: Michigan
Posts: 342
My Ride: 03' BMW 330xi
installed my headers today, took me about 5 hours from start to finish. Nothing special about an xi.In fact I got all the bolts out without having to jack the engine up. I did however take off the motor mounts to get those enormous cats to fit up through the top. installed o2 simulator and I thought it wasn't working until I drove it for a mile and the service engine soon light turned off, so I'm pretty sure I'm good there as well. There was some initial smoke coming from my engine bay after I first started it up and gave it some gas, but it stopped after I played with the throttle for about 1 minute. I assumed this was simply the new gaskets? I didn't use threadlock or loctite so it couldnt have been that. I think I'm going to take it back into the shop tomorrow just to make sure that everything is tightened down when its hot. I think the hardest part was realizing that in order to get the front header to turn and fit onto the studs I had to bend a useless piece of metal that was attached to the subframe in order to turn it to match the face of the motor. I would also highly recommend air tools haha, there was no way I was going to be able to do this DIY without having some power to get the studs out of the engine. It was too dark to take a video today, I'll be installing a Magnaflow Catback later this week... Then ill video it up. Should be fun having to extend, bend, cut, weld the header to 1st resonator section to fit the xi, but I'll make it work.
__________________
HR Sports, Konis, Tints, Angel Eyes, Black headliner swap, BimmerBrakes Headers
Gruppe M Intake, Clear tails/markers/corners, Alufelgen SF-71 Black Diamonds, Magnaflow Catback

Last edited by chanlon7; 09-26-2011 at 09:02 PM.
chanlon7 is offline   Reply With Quote
Old 01-22-2012, 12:15 AM   #246
co3deron
Registered User
 
Join Date: Oct 2007
Location: The Hauge, The Netherlands
Posts: 26
My Ride: E46 320I Touring
Can somebody tell me if I have to unbolt the exhaust from the headers, when I only want to replace the gasket between the engine and the manifold? Is there any room to get the new gaskets out/in when I don't unbolt the exhaust?
My BMW is changing into a Harley Davidson.
Thanks

Last edited by co3deron; 01-22-2012 at 12:18 AM. Reason: bad english
co3deron is offline   Reply With Quote
Old 01-22-2012, 01:21 PM   #247
cardsfan007
Registered User
 
Join Date: Apr 2010
Location: Missouri
Posts: 460
My Ride: 2002 330xi
It is probably possible to do it without but its gunna be hard as hell. Trick with the exhaust is use your jack under the muffler. Makes taking it on and off a TON easier.

Sent from my MB865 using Bimmer
cardsfan007 is online now   Reply With Quote
Old 01-26-2012, 11:36 PM   #248
co3deron
Registered User
 
Join Date: Oct 2007
Location: The Hauge, The Netherlands
Posts: 26
My Ride: E46 320I Touring
Thanks for the info, I think I'm taking my Bimmer to the shop (not the stealer) as it is becomming very cold these days and I can not risk braking off exhaust studs, the ones that are mounted to the engine.
co3deron is offline   Reply With Quote
Old 05-17-2012, 03:40 AM   #249
choleaoum
Ceiling missing!
 
choleaoum's Avatar
 
Join Date: Jan 2010
Location: Long Beach, CA
Posts: 1,736
My Ride: BMW 330Ci
Send a message via AIM to choleaoum
Was I the only one having issues with the header hitting the AC lines?
choleaoum is offline   Reply With Quote
Old 01-05-2013, 10:37 AM   #250
aleksankazakov
Registered User
 
Join Date: Mar 2011
Location: U.S.A
Posts: 236
My Ride: 04 E46 330i sport
A simple question. Often I see you guys have "SERVICEENGINE" light on after installation. Does it reset , or you just drive with all the errors?
aleksankazakov is offline   Reply With Quote
Old 01-11-2013, 05:33 PM   #251
driftingSOCALE46
Registered User
 
Join Date: Nov 2012
Location: Riverside, CA
Posts: 85
My Ride: 2002 325i
Quote:
Originally Posted by bwallace530 View Post
How did you get the top O2's off. I cant seem to get a wrench on them?
because there is a special tool to remove it due to the wire, have to unplug the sensor first and use the special socket after
driftingSOCALE46 is offline   Reply With Quote
Old 01-19-2013, 03:09 PM   #252
driftingSOCALE46
Registered User
 
Join Date: Nov 2012
Location: Riverside, CA
Posts: 85
My Ride: 2002 325i
I have a problem, HOW THE HELL DID YOU GUYS EXCESS THE nuts on the exhaust manifold? what tools should I be using I got the front 2 off the bottom cuz I was able 2 reach while laying on my back with a wrench and socket. I cant see what im working on all 8 tops but can feel but cant really work since the tin wrapped cords are in the way. Know what im talking about?
driftingSOCALE46 is offline   Reply With Quote
Old 01-19-2013, 03:11 PM   #253
driftingSOCALE46
Registered User
 
Join Date: Nov 2012
Location: Riverside, CA
Posts: 85
My Ride: 2002 325i
this was on another post."Step 5
Break off heat shields from manifolds by working up and down until the riviots let go.This will allow better acess to all the studs and is nessicary in my opinion."

but im just gonna remove all nuts and remove headers and

Last edited by driftingSOCALE46; 01-19-2013 at 03:58 PM.
driftingSOCALE46 is offline   Reply With Quote
Old 01-19-2013, 03:20 PM   #254
HiHoBrian
OEM ///Member
 
HiHoBrian's Avatar
 
Join Date: Jul 2011
Location: Connecticut
Posts: 1,113
My Ride: 05 M3
Quote:
Originally Posted by driftingSOCALE46 View Post
because there is a special tool to remove it due to the wire, have to unplug the sensor first and use the special socket after
Or take out the original manifold with the O2's in them still. Then just use a closed end box wrench. Special socket isn't required that way.

sent from my ATARI sc1224
__________________
HiHoBrian is offline   Reply With Quote
Old 01-19-2013, 03:23 PM   #255
driftingSOCALE46
Registered User
 
Join Date: Nov 2012
Location: Riverside, CA
Posts: 85
My Ride: 2002 325i
fast response please..... in need of thew answer by the end of the day
"I have a problem, HOW THE HELL DID YOU GUYS EXCESS THE nuts on the exhaust manifold? what tools should I be using I got the front 2 off the bottom cuz I was able 2 reach while laying on my back with a wrench and socket. I cant see what im working on all 8 tops but can feel but cant really work since the tin wrapped cords are in the way. Know what im talking about?"
driftingSOCALE46 is offline   Reply With Quote
Old 01-19-2013, 03:39 PM   #256
HiHoBrian
OEM ///Member
 
HiHoBrian's Avatar
 
Join Date: Jul 2011
Location: Connecticut
Posts: 1,113
My Ride: 05 M3
Quote:
Originally Posted by driftingSOCALE46 View Post
fast response please..... in need of thew answer by the end of the day
"I have a problem, HOW THE HELL DID YOU GUYS EXCESS THE nuts on the exhaust manifold? what tools should I be using I got the front 2 off the bottom cuz I was able 2 reach while laying on my back with a wrench and socket. I cant see what im working on all 8 tops but can feel but cant really work since the tin wrapped cords are in the way. Know what im talking about?"
You need a 11mm or 7/16 gear wrench,and a 1/4" drive ratchet with an 11mm swivel socket,also an 11mm deep socket with a short extension. You need to remove the large aluminum brace plate for access from underneath,and you need to break off the heat shields from the gaskets on the top.

sent from my ATARI sc1224
__________________
HiHoBrian is offline   Reply With Quote
Old 01-19-2013, 03:40 PM   #257
HiHoBrian
OEM ///Member
 
HiHoBrian's Avatar
 
Join Date: Jul 2011
Location: Connecticut
Posts: 1,113
My Ride: 05 M3
Or a small air ratchet with 11mm deep. That helped me a lot.


sent from my ATARI sc1224
__________________
HiHoBrian is offline   Reply With Quote
Old 01-19-2013, 04:00 PM   #258
driftingSOCALE46
Registered User
 
Join Date: Nov 2012
Location: Riverside, CA
Posts: 85
My Ride: 2002 325i
will brake them off now then, but I bought gaskets with heat shields to be installed, can i get them installed or should I cut the shields off of the new gaskets
driftingSOCALE46 is offline   Reply With Quote
Old 01-21-2013, 10:57 AM   #259
driftingSOCALE46
Registered User
 
Join Date: Nov 2012
Location: Riverside, CA
Posts: 85
My Ride: 2002 325i
i have all the nuts off the 1st header, but thinking of leaving the studs in, is it possible to remove the manifolds without removing the studs? or is that just wishful thinking. can get the nuts on the second manifold till the 1st one is out
driftingSOCALE46 is offline   Reply With Quote
Old 01-23-2013, 04:32 PM   #260
driftingSOCALE46
Registered User
 
Join Date: Nov 2012
Location: Riverside, CA
Posts: 85
My Ride: 2002 325i
last problems Im having is NONE of the sensors fit in the headers.... DAMN CHINESE CRAP, sensors cant go through the floor or through the other header... damn Chinese crap. The other problem Im having is 1 of the tubes on the header hits the engine mount bracket when lower the engine in.... and prevents me from reaching the top nut from above the engine bay. My solution is just tighten the engine mount before installing so no need to tighten it once installed but the problem of hitting the brace/bracket is still an issue since once I hit a pot hole there is NO PLAY between the engine mount/bracket and headers so the engine will get a jolt and I am thinking that could brake off a stud. And I also cant attach the flanges to the stock exhaust THEY ARE NOT FLUSH. DAMN CHINESE ****!!!!
driftingSOCALE46 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use