E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 9 votes, 4.78 average.
Old 01-21-2013, 10:06 AM   #2001
CTRob
Registered User
 
Join Date: Mar 2012
Location: Dublin
Posts: 127
My Ride: Alpine white e39
Quote:
Originally Posted by jchuillier View Post
Ok guys, hold on.....It roots

swjpilot from xda found this link....

http://www.androidtablets.net/forum/...48-8048-a.html

And rooted his car stereo, it's not a b046 but it's the same tablet telechips 8925....

Can't wait to get home and try this tonight....
CTRob is offline   Reply With Quote
Old 01-21-2013, 12:52 PM   #2002
PainBreak
Registered User
 
Join Date: Dec 2012
Location: Kansas City, MO
Posts: 126
My Ride: 2004 325i
Quote:
Originally Posted by jchuillier View Post
Ok guys, hold on.....It roots

swjpilot from xda found this link....

http://www.androidtablets.net/forum/...48-8048-a.html

And rooted his car stereo, it's not a b046 but it's the same tablet telechips 8925....

Can't wait to get home and try this tonight....
This sounds promising...

I got an email from Charles this morning. He wants me to get on Skype tonight, and he's supposed to send me a system update.

I will keep everyone in the loop, and release it on here if it actually manifests.
__________________
Is your car a Stu Stu Stammering Stan at 2800 RPMS? FLASH THE DME! http://forum.e46fanatics.com/showthread.php?t=966614
Enco B046 Android 4.04 Root/FAQ/Help: http://forum.e46fanatics.com/showthread.php?t=967737
PainBreak is offline   Reply With Quote
Old 01-21-2013, 12:57 PM   #2003
jchuillier
Registered User
 
Join Date: Dec 2012
Location: Toulouse (France)
Posts: 102
My Ride: 330CD
Got the same from him (the skype thing...)
I guess he'll send us the link to the forum

Last edited by jchuillier; 01-21-2013 at 12:58 PM.
jchuillier is offline   Reply With Quote
Old 01-21-2013, 02:05 PM   #2004
PainBreak
Registered User
 
Join Date: Dec 2012
Location: Kansas City, MO
Posts: 126
My Ride: 2004 325i
It worked perfectly. I am now rooted. Time to play.
__________________
Is your car a Stu Stu Stammering Stan at 2800 RPMS? FLASH THE DME! http://forum.e46fanatics.com/showthread.php?t=966614
Enco B046 Android 4.04 Root/FAQ/Help: http://forum.e46fanatics.com/showthread.php?t=967737
PainBreak is offline   Reply With Quote
Old 01-21-2013, 02:08 PM   #2005
CTRob
Registered User
 
Join Date: Mar 2012
Location: Dublin
Posts: 127
My Ride: Alpine white e39
What exactly did you have to do to root painbreak? can you give a step by step please?
CTRob is offline   Reply With Quote
Old 01-21-2013, 02:24 PM   #2006
Wickedly
Registered User
 
Join Date: Jun 2010
Location: Pittsburgh-DC Area
Posts: 846
My Ride: BMW 2003 325i
Quote:
Originally Posted by china man View Post
I found a company call Eonon who have a new canbus unit which claims to be able to solve the random boot problem. I am waiting the confirmation from another user before I go ahead. I try to ask Jolly but no reply yet.
Please keep us updated it if this work. This will be a huge fix .

Thanks
__________________
-------------------BMW AW---------------------
Wickedly is offline   Reply With Quote
Old 01-21-2013, 02:34 PM   #2007
siffion
Registered User
 
Join Date: Jan 2012
Location: hartlepool
Posts: 21
My Ride: 330ci Vert M Sport
Quote:
Originally Posted by PainBreak View Post
It worked perfectly. I am now rooted. Time to play.
Congratulations. I could never root my old 2.3 version.

What's yer plans. If you get bluetooth working on the android side ill pull the trigger on the ICS version
siffion is offline   Reply With Quote
Old 01-21-2013, 03:04 PM   #2008
jchuillier
Registered User
 
Join Date: Dec 2012
Location: Toulouse (France)
Posts: 102
My Ride: 330CD
Did you root with the forum link or did Charles send you a file ?
jchuillier is offline   Reply With Quote
Old 01-21-2013, 03:24 PM   #2009
CTRob
Registered User
 
Join Date: Mar 2012
Location: Dublin
Posts: 127
My Ride: Alpine white e39
Quote:
Originally Posted by siffion View Post
Congratulations. I could never root my old 2.3 version.

What's yer plans. If you get bluetooth working on the android side ill pull the trigger on the ICS version
Reckon if we get Bluetooth on the Android side working would we be able to make and receive calls using the Android O/S?
CTRob is offline   Reply With Quote
Old 01-21-2013, 03:29 PM   #2010
jchuillier
Registered User
 
Join Date: Dec 2012
Location: Toulouse (France)
Posts: 102
My Ride: 330CD
Sip over wifi
jchuillier is offline   Reply With Quote
Old 01-21-2013, 03:32 PM   #2011
PainBreak
Registered User
 
Join Date: Dec 2012
Location: Kansas City, MO
Posts: 126
My Ride: 2004 325i
Quote:
Originally Posted by jchuillier View Post
Did you root with the forum link or did Charles send you a file ?
Via the forum link. I had trouble with it on the external SD card, but was able to make it work fine from the "internal" sd at /mnt/sdcard.

Here was the process I used with success:

1. Downloaded the file.
2. Renamed it to update.zip
3. Used ES File Explorer to move it from a LAN SMB share to /mnt/sdcard
4. Went to Settings > About tablet > System updates > Install system update > From internal storage > Install now
5. Watched it reboot, go through two different Android load screens, then the progress bar started as the Droid robot held a crystal-ball looking thing...
6. It finished up, rebooted. Rooted.

Here's the bad news:
I was able to inject my custom framework.jar into /system/framework, and while it did fix the reported speed issue, Google Navigation still doesn't work. There's a separate problem afoot. Multiple GPS applications show that I'm getting a lock on anywhere from 14 to 22 satellites, so there's no reason Google Navigation should be "Searching for GPS..."

With root, though? It will get fixed.

More good news, though... Now, you can put a reboot widget on your desktop. You can also run Adaway.
__________________
Is your car a Stu Stu Stammering Stan at 2800 RPMS? FLASH THE DME! http://forum.e46fanatics.com/showthread.php?t=966614
Enco B046 Android 4.04 Root/FAQ/Help: http://forum.e46fanatics.com/showthread.php?t=967737
PainBreak is offline   Reply With Quote
Old 01-21-2013, 03:46 PM   #2012
CTRob
Registered User
 
Join Date: Mar 2012
Location: Dublin
Posts: 127
My Ride: Alpine white e39
Hopefully charles file fixes google nav
CTRob is offline   Reply With Quote
Old 01-21-2013, 03:56 PM   #2013
PainBreak
Registered User
 
Join Date: Dec 2012
Location: Kansas City, MO
Posts: 126
My Ride: 2004 325i
Quote:
Originally Posted by CTRob View Post
Hopefully charles file fixes google nav
Yeah, I'm not holding my breath. After doing some research, there may be a bug in Google Navigation. It seems quite a few people are having this problem, on a variety of devices.

I'm about 95% convinced that other GPS software would work flawlessly now. Except for the version of iGO that came with the thing, because there's something wrong with it.
__________________
Is your car a Stu Stu Stammering Stan at 2800 RPMS? FLASH THE DME! http://forum.e46fanatics.com/showthread.php?t=966614
Enco B046 Android 4.04 Root/FAQ/Help: http://forum.e46fanatics.com/showthread.php?t=967737
PainBreak is offline   Reply With Quote
Old 01-21-2013, 04:21 PM   #2014
madbull1986
Registered User
 
Join Date: Jan 2013
Location: Portugal
Posts: 6
My Ride: 320d Touring
Hello to all community,
This is my first post.
I my must thank you all for all the information that you share.
I am searching to buy a new radio for my touring and i have read all the available information about all units available on the market,
i end up here, in my opinion this new Enco unit have all that i search in a radio and you guys are providing excelent tips and sharing your thoughts which help me a lot on my decision.
But i have one question:
There isn't anybody with the new unit thinking in making a youtube video???
That would be awesome to see this unit working.
Please consider that and hope in the near future i can help you guys in some troubleshoots on this unit!!!
Keep the good work.
Regards
madbull1986 is offline   Reply With Quote
Old 01-21-2013, 04:25 PM   #2015
bjornh
Registered User
 
Join Date: Dec 2012
Location: Sandnes, Norway
Posts: 16
My Ride: 320iAT
This is awesome news. Congrats PainBreak and jchuillier, and thanks on behalf of the community. ENCO should compensate you for the boatloads of sales you just ensured them. I'm getting two of them asap. :-D

Last edited by bjornh; 01-21-2013 at 04:47 PM.
bjornh is offline   Reply With Quote
Old 01-21-2013, 08:23 PM   #2016
trentcdrums
Registered User
 
Join Date: Jul 2012
Location: Illinois
Posts: 1,946
My Ride: BMW 323i Sedan
I don't see a price on this.. anyone have it? http://www.szenco.com/page-8-94.html
trentcdrums is offline   Reply With Quote
Old 01-21-2013, 10:54 PM   #2017
monty13
Registered User
 
Join Date: Apr 2007
Location: Sacramento, CA
Posts: 100
My Ride: 1999 e46 323i
Quote:
Originally Posted by PainBreak View Post
Via the forum link. I had trouble with it on the external SD card, but was able to make it work fine from the "internal" sd at /mnt/sdcard.

Here was the process I used with success:

1. Downloaded the file.
2. Renamed it to update.zip
3. Used ES File Explorer to move it from a LAN SMB share to /mnt/sdcard
4. Went to Settings > About tablet > System updates > Install system update > From internal storage > Install now
5. Watched it reboot, go through two different Android load screens, then the progress bar started as the Droid robot held a crystal-ball looking thing...
6. It finished up, rebooted. Rooted.

Here's the bad news:
I was able to inject my custom framework.jar into /system/framework, and while it did fix the reported speed issue, Google Navigation still doesn't work. There's a separate problem afoot. Multiple GPS applications show that I'm getting a lock on anywhere from 14 to 22 satellites, so there's no reason Google Navigation should be "Searching for GPS..."

With root, though? It will get fixed.

More good news, though... Now, you can put a reboot widget on your desktop. You can also run Adaway.
Any chance you can figure out how to get into recovery without the Android system starting up?

Mine is still in a continuous bootloop, and I'm thinking if I can load a particular file/ROM onto the SD card and then turn on the unit, I might be able to get it into Recovery and then wipe Dalvic cache, etc. to get it to boot up again... I'm pretty sure I just need to wipe davlic cache, cache, and then I should be able to get the Android side to boot properly.

Thanks,
monty
__________________
monty13 is offline   Reply With Quote
Old 01-21-2013, 11:24 PM   #2018
PainBreak
Registered User
 
Join Date: Dec 2012
Location: Kansas City, MO
Posts: 126
My Ride: 2004 325i
Quote:
Originally Posted by monty13 View Post
Any chance you can figure out how to get into recovery without the Android system starting up?

Mine is still in a continuous bootloop, and I'm thinking if I can load a particular file/ROM onto the SD card and then turn on the unit, I might be able to get it into Recovery and then wipe Dalvic cache, etc. to get it to boot up again... I'm pretty sure I just need to wipe davlic cache, cache, and then I should be able to get the Android side to boot properly.

Thanks,
monty
Unfortunately, I haven't found any way do that. Don't you have the 2.3 version? It's an entirely different Android board than this one.
__________________
Is your car a Stu Stu Stammering Stan at 2800 RPMS? FLASH THE DME! http://forum.e46fanatics.com/showthread.php?t=966614
Enco B046 Android 4.04 Root/FAQ/Help: http://forum.e46fanatics.com/showthread.php?t=967737
PainBreak is offline   Reply With Quote
Old 01-22-2013, 03:48 AM   #2019
jchuillier
Registered User
 
Join Date: Dec 2012
Location: Toulouse (France)
Posts: 102
My Ride: 330CD
Besides that....found my sound problem !!!

The long cable is dead....I found in the shipment that they have also sent 2 short cables, 1 with the 17 pins connector and 1 with the 40 pins connector, I put the unit in the trunk, connected the short cable and voila....

So in the same 24 hours we have root and I have sound....I should quickly play the lottery....
jchuillier is offline   Reply With Quote
Old 01-22-2013, 03:51 AM   #2020
CTRob
Registered User
 
Join Date: Mar 2012
Location: Dublin
Posts: 127
My Ride: Alpine white e39
Quote:
Originally Posted by jchuillier View Post
Besides that....found my sound problem !!!

The long cable is dead....I found in the shipment that they have also sent 2 short cables, 1 with the 17 pins connector and 1 with the 40 pins connector, I put the unit in the trunk, connected the short cable and voila....

So in the same 24 hours we have root and I have sound....I should quickly play the lottery....
Good so it wasn't the unit after all

Much better to ask them to ship out a new cable than a new unit!

Btw did you have to pay more cash for the long cable that runs to the boot or was it included??

Last edited by CTRob; 01-22-2013 at 04:07 AM.
CTRob is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use