E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 9 votes, 4.78 average.
Old 01-22-2013, 04:03 AM   #2021
jchuillier
Registered User
 
Join Date: Dec 2012
Location: Toulouse (France)
Posts: 102
My Ride: 330CD
I got the long cable for $20 extra, and they also sent the 2 short cables, I think that they include the short cables all the time no matter what
jchuillier is offline   Reply With Quote
Old 01-22-2013, 04:09 AM   #2022
CTRob
Registered User
 
Join Date: Mar 2012
Location: Dublin
Posts: 127
My Ride: Alpine white e39
Quote:
Originally Posted by jchuillier View Post
I got the long cable for $20 extra, and they also sent the 2 short cables, I think that they include the short cables all the time no matter what
Perfect

Any chance you could do me the biggest favour and take a pic of the radio end connector and also how the connector is wired (there should be a picture on top of the head actual unit explaining where each wire goes)?

Reason I ask is I have a Dynavin currently with the long Fakra cable and I have a hunch it is the same cable used between all these systems
CTRob is offline   Reply With Quote
Old 01-22-2013, 04:15 AM   #2023
jchuillier
Registered User
 
Join Date: Dec 2012
Location: Toulouse (France)
Posts: 102
My Ride: 330CD
Easy one....the unit is in the boot right now so fully visible
jchuillier is offline   Reply With Quote
Old 01-22-2013, 04:35 AM   #2024
jchuillier
Registered User
 
Join Date: Dec 2012
Location: Toulouse (France)
Posts: 102
My Ride: 330CD






jchuillier is offline   Reply With Quote
Old 01-22-2013, 06:12 AM   #2025
CTRob
Registered User
 
Join Date: Mar 2012
Location: Dublin
Posts: 127
My Ride: Alpine white e39
Thanks jchuillier,

Here is the Dynavin sticker - looks fairly similar however I do know on the Dynavin if you plug in the black connector and look at the back of the unit, the yellow wire (battery power) would be the first wire on the top coming from the right hand side whereas on your connector it seems to be the pink wire (your first pic) so the Fakra cables may indeed be wired different..

Alos did you get right angled USB leads with the unit or did you purchase those seperately??
Attached Thumbnails
Click image for larger version

Name:	20121204_202333.jpg
Views:	51
Size:	154.9 KB
ID:	487191  

Last edited by CTRob; 01-22-2013 at 06:14 AM.
CTRob is offline   Reply With Quote
Old 01-22-2013, 06:16 AM   #2026
jchuillier
Registered User
 
Join Date: Dec 2012
Location: Toulouse (France)
Posts: 102
My Ride: 330CD
It gets more.....complicated

I had a very long chat with Charles on skype.

It turns out that he's sent the softare update to painbreak, he's finished some installation instructions for the update so that's the good news.

The bad news is the definition of "customer service".

As you know I had no sound with the unit with the long cable and when I tried with the short cable it worked, so it's definitely a cable problem, either a short circuit, a bad wiring, it can happen and I'm not willing to scream murder.

I sent a mail to Charles about this problem and got no reply, after 5 days I started a Paypal complain ang got a reply within 1 hour, now we have moved along the complain and I finally sent a message to szenco this morning through the paypal system to leave a trace saying that I had narrowed down the problem to the cable, that they shoild send me a new cable and once I have it I would immediatly cancel my complain.

the conversation with Charles was going smoothly up to the moment when he told me that I had to cancel the complain BEFORE he would send the cable, and since the ONLY way for me to get their attention and a reply was to use the paypal complain I am not ready to give up this weapon yet, I cannot imagine what would happen now if I haid paid with Western Union as Charles insisted I did upon purchase.

I tried explaining to him that :

1) I paid for the long cable
2) It was dead on arrival
3) They should have checked it before sending it

But he kept on telling me that "his boss" (whomever that might be) demanded that I cancel the complain before they send me the cable, I told him politely that it was HIS fault if the cable was dead and that since I had paid for a working system (with the cable) i would cancel my complain when I had a working system, I explained to him that I put his in writing on the paypal site so that there would be a trace of that in case i didn't cancel my complain after having received the cable.

His final reply was to tell me to send the COMPLETE unit back to China (at my expense) and that they would refund my money afterwards.

I don't want to get impolite but you can all imagine how I can feel about such business behaviour, they sent me a defective system, I find the dead component for them and yet they want me to take a $70 charge (shipping) and a $650 risk by cancelling the only weapon I have because they don't want to send me a $20 cable.

So in any case that's where we are now, the unit can be rooted thanks to everybody's efforts, I have sound but "the boss" in china is not ready to send me a $20 replacement cable.

The bottom line for me is as follows.

1) Now that it is rooted it will be a great device
2) These people can ABSOLUTELY NOT be trusted
3) Use paypal to buy and use the complain system, it is the ONLY way to get their attention

I told Charles I would explain the situation there as I feel that transparency is the most efficient way to deal with his boss and hopefully before buying anything from them people will ask the relevant questions.

I knew since the beggining that there would be no warranty on this unit but I expected at least to get a WORKING system, apparently they are not able to provide that, OK, it can happen, anybody can have a bad wiring, but their refusal to admit it and solve the problem by sending a $20 (I don't even want to speculate on how much it actually costs them) part is really annoying, I am not really confident that if the screen breaks down in 6 months during the warranty period they will fulfill their after sales obligations....

I will keep you guys informed on the follow up and we'll see what happens...for those interested I have the complete log of the skype conversation...
jchuillier is offline   Reply With Quote
Old 01-22-2013, 06:47 AM   #2027
china man
Registered User
 
Join Date: Mar 2012
Location: London
Posts: 71
My Ride: E46 M3 SMG


now what next?
china man is offline   Reply With Quote
Old 01-22-2013, 08:06 AM   #2028
PainBreak
Registered User
 
Join Date: Dec 2012
Location: Kansas City, MO
Posts: 126
My Ride: 2004 325i
Quote:
Originally Posted by jchuillier View Post
It gets more.....complicated
That's definitely the downside to this, is that customer support is extremely lacking. I think it's a combination of the language barrier, and that given the distance, extreme cost of shipping, and the chance the radio will sit in customs forever and not reach its destination, they feel like we're not empowered enough to demand service.

That said, I did receive the update.zip from Charles last night. It's about 150MB, and I will host it somewhere for the community. However, given that I now have root, and I was able to get the GetSpeed() function corrected in framework.jar on my own, I'm hesitant to apply the update at this moment.

Also, the first thing Charles did when talking on Skype was asked me to cancel the Paypal dispute. I explained to him that it's not a dispute, it was a partial refund request, and that when he declined it, it's as good as canceled. I have not elevated it to a dispute, but that option is available to me, to protect my financial investment.

At that point, he sent me the zip file.

jchuillier: I think your best bet is going to be testing that long cable, figuring out what part of it is bad, and replacing the individual wire(s) along the run. You shouldn't have to, they should send you out a new cable, but it's got to be easier than trying to leverage them into sending you a new one.
__________________
Is your car a Stu Stu Stammering Stan at 2800 RPMS? FLASH THE DME! http://forum.e46fanatics.com/showthread.php?t=966614
Enco B046 Android 4.04 Root/FAQ/Help: http://forum.e46fanatics.com/showthread.php?t=967737
PainBreak is offline   Reply With Quote
Old 01-22-2013, 08:08 AM   #2029
PainBreak
Registered User
 
Join Date: Dec 2012
Location: Kansas City, MO
Posts: 126
My Ride: 2004 325i
Quote:
Originally Posted by china man View Post


now what next?
What version of Android is that?
__________________
Is your car a Stu Stu Stammering Stan at 2800 RPMS? FLASH THE DME! http://forum.e46fanatics.com/showthread.php?t=966614
Enco B046 Android 4.04 Root/FAQ/Help: http://forum.e46fanatics.com/showthread.php?t=967737
PainBreak is offline   Reply With Quote
Old 01-22-2013, 08:14 AM   #2030
china man
Registered User
 
Join Date: Mar 2012
Location: London
Posts: 71
My Ride: E46 M3 SMG
2.2.3 I think
china man is offline   Reply With Quote
Old 01-22-2013, 08:19 AM   #2031
CTRob
Registered User
 
Join Date: Mar 2012
Location: Dublin
Posts: 127
My Ride: Alpine white e39
Quote:
Originally Posted by PainBreak View Post
given that I now have root, and I was able to get the GetSpeed() function corrected in framework.jar on my own, I'm hesitant to apply the update at this moment.
Would it not be worth a try to see if Google Nav works using their update pal?
CTRob is offline   Reply With Quote
Old 01-22-2013, 08:53 AM   #2032
PainBreak
Registered User
 
Join Date: Dec 2012
Location: Kansas City, MO
Posts: 126
My Ride: 2004 325i
Quote:
Originally Posted by CTRob View Post
Would it not be worth a try to see if Google Nav works using their update pal?
Before I blindly apply the update, I'm going to do a comparison of the files currently on the system vs the ones in the update. If it fixes the Google Navigation issues, then at least I will know what had broken it.

I REMOVED THE LINK TO THE UPDATE -- IT IS WORTHLESS.

Quote:
Originally Posted by china man View Post
2.2.3 I think
Did you root it using the method mentioned earlier in the thread? If so, that is awesome! Looking at your system, and seeing the popup on the bottom, the first thing I'd do is install Adaway.
__________________
Is your car a Stu Stu Stammering Stan at 2800 RPMS? FLASH THE DME! http://forum.e46fanatics.com/showthread.php?t=966614
Enco B046 Android 4.04 Root/FAQ/Help: http://forum.e46fanatics.com/showthread.php?t=967737

Last edited by PainBreak; 01-23-2013 at 05:26 PM.
PainBreak is offline   Reply With Quote
Old 01-22-2013, 09:00 AM   #2033
jchuillier
Registered User
 
Join Date: Dec 2012
Location: Toulouse (France)
Posts: 102
My Ride: 330CD
Given my experience with their customer service I would be super careful with that update....

Painbreak you're right and I've pulled the cable out of the car but still it's hard to recommend this product to someone who can't do some coding himself or use a multimeter for the cable...
jchuillier is offline   Reply With Quote
Old 01-22-2013, 09:13 AM   #2034
PainBreak
Registered User
 
Join Date: Dec 2012
Location: Kansas City, MO
Posts: 126
My Ride: 2004 325i
Quote:
Originally Posted by jchuillier View Post
Given my experience with their customer service I would be super careful with that update....

Painbreak you're right and I've pulled the cable out of the car but still it's hard to recommend this product to someone who can't do some coding himself or use a multimeter for the cable...
I wouldn't recommend the Enco or the Dynavin radio to someone who isn't comfortable tinkering. Neither one is going to give you a seamless, frustration-less experience. There's a level of comprehension that the user needs to have, in order to understand what's going on internally with these radios.

The Enco especially so, because we don't have Jeff to rely on. I mean, we have Charles, but... aaay, whatchagonnado, ah?
__________________
Is your car a Stu Stu Stammering Stan at 2800 RPMS? FLASH THE DME! http://forum.e46fanatics.com/showthread.php?t=966614
Enco B046 Android 4.04 Root/FAQ/Help: http://forum.e46fanatics.com/showthread.php?t=967737
PainBreak is offline   Reply With Quote
Old 01-22-2013, 10:12 AM   #2035
CTRob
Registered User
 
Join Date: Mar 2012
Location: Dublin
Posts: 127
My Ride: Alpine white e39
Quote:
Originally Posted by jchuillier View Post
Given my experience with their customer service I would be super careful with that update....

Painbreak you're right and I've pulled the cable out of the car but still it's hard to recommend this product to someone who can't do some coding himself or use a multimeter for the cable...
We've got to find a way to flash the unit though surely in the event the Android O/S gets messed up and needs to be re-flashed ?
CTRob is offline   Reply With Quote
Old 01-22-2013, 10:33 AM   #2036
china man
Registered User
 
Join Date: Mar 2012
Location: London
Posts: 71
My Ride: E46 M3 SMG
installed adaway and it say it needed rooting. so I guess it is not rooted after all.

I use the method outlined in the xda forum link.
china man is offline   Reply With Quote
Old 01-22-2013, 01:11 PM   #2037
PainBreak
Registered User
 
Join Date: Dec 2012
Location: Kansas City, MO
Posts: 126
My Ride: 2004 325i
Quote:
Originally Posted by china man View Post
installed adaway and it say it needed rooting. so I guess it is not rooted after all.

I use the method outlined in the xda forum link.
I'm not sure it will work on your radio, since it's a different Android board. But, we're obviously on to the method of updating necessary to acquire root.

Do you have SuperUser installed? What does it say?
__________________
Is your car a Stu Stu Stammering Stan at 2800 RPMS? FLASH THE DME! http://forum.e46fanatics.com/showthread.php?t=966614
Enco B046 Android 4.04 Root/FAQ/Help: http://forum.e46fanatics.com/showthread.php?t=967737
PainBreak is offline   Reply With Quote
Old 01-22-2013, 01:13 PM   #2038
china man
Registered User
 
Join Date: Mar 2012
Location: London
Posts: 71
My Ride: E46 M3 SMG
SuperUser installed

didn't install any app so there is nothing on the active list.
china man is offline   Reply With Quote
Old 01-22-2013, 01:17 PM   #2039
jchuillier
Registered User
 
Join Date: Dec 2012
Location: Toulouse (France)
Posts: 102
My Ride: 330CD
Install apps that really need root to know

Titanium backup
root app delete
rom manager (clockwork)

and then you'll know for sure
jchuillier is offline   Reply With Quote
Old 01-22-2013, 01:29 PM   #2040
PainBreak
Registered User
 
Join Date: Dec 2012
Location: Kansas City, MO
Posts: 126
My Ride: 2004 325i
Quote:
Originally Posted by china man View Post
SuperUser installed

didn't install any app so there is nothing on the active list.
What happens if you try to update su from within SuperUser? If you don't have root, it'll get stuck on "getting root-access...."

Sometimes, even without root, it says it succeeds, so update SU twice to make sure it's working.
__________________
Is your car a Stu Stu Stammering Stan at 2800 RPMS? FLASH THE DME! http://forum.e46fanatics.com/showthread.php?t=966614
Enco B046 Android 4.04 Root/FAQ/Help: http://forum.e46fanatics.com/showthread.php?t=967737
PainBreak is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use