E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 01-24-2013, 06:02 AM   #41
325xittt
Registered User
 
Join Date: Apr 2010
Location: Reading, PA
Posts: 173
My Ride: 2003, 325 XIT
OP

Hope you find your problem. Lots of good ideas from others. I look forward to hearing what solves solves your thumping problem.

By the way, as was pointed out so kindly above. I'm still looking for a TC. I've got 2 xi's, two different problems.


Peace, Out
__________________

Last edited by 325xittt; 01-24-2013 at 06:12 AM. Reason: typo
325xittt is offline   Reply With Quote
Old 01-24-2013, 07:37 AM   #42
jeepo23
Registered User
 
Join Date: Oct 2011
Location: cdn
Posts: 1,087
My Ride: 02 330
Quote:
Originally Posted by caleb6 View Post
OK. Thanks guys! TC mount buffer on the way. I'll update with results once changed out.
Yah I am changing out my TC mount here hopefully soon once the weather warms up a bit. let us know how it turns out!
jeepo23 is offline   Reply With Quote
Old 01-24-2013, 08:13 AM   #43
miweber929
Registered User
 
Join Date: Nov 2012
Location: Woodbury, MN
Posts: 91
My Ride: 02 330xi
Quote:
Originally Posted by caleb6 View Post
OK. Thanks guys! TC mount buffer on the way. I'll update with results once changed out.
Did you check to see if yours is bad before ordering? Throwing random parts at an issue without checking them first is a sure way if throwing time and money down the toilet.

This part does seem to be a source of vibration but if its not bad, why change it? Like Kubica said it takes 5 minutes to check and is fairly obvious.
miweber929 is offline   Reply With Quote
Old 01-24-2013, 10:18 AM   #44
caleb6
Registered User
 
Join Date: Jan 2012
Location: Harrisburg, PA
Posts: 390
My Ride: 2005 330XI
Quote:
Originally Posted by miweber929 View Post
Did you check to see if yours is bad before ordering? Throwing random parts at an issue without checking them first is a sure way if throwing time and money down the toilet.

This part does seem to be a source of vibration but if its not bad, why change it? Like Kubica said it takes 5 minutes to check and is fairly obvious.
Yeah dude, did you read the thread? Not only did I check it and mention the results above, I freakin' took pictures of it and posted them too. Come on!

Last edited by caleb6; 01-24-2013 at 10:32 AM.
caleb6 is offline   Reply With Quote
Old 01-24-2013, 07:00 PM   #45
miweber929
Registered User
 
Join Date: Nov 2012
Location: Woodbury, MN
Posts: 91
My Ride: 02 330xi
Quote:
Originally Posted by caleb6 View Post
Yeah dude, did you read the thread? Not only did I check it and mention the results above, I freakin' took pictures of it and posted them too. Come on!
Yeah, I did.

Completely. Couple times even.

Fyi, the pictures really don't show **** and you were confused by front vs. rear guibo for some reason. So I was asking a legit question as it appears you're fixing random things left and right. I tried to maybe offer some help since I just went through all these replacements myself with mixed results but since you insist on being an asshat, well screw you then and have fun.
miweber929 is offline   Reply With Quote
Old 01-24-2013, 07:54 PM   #46
caleb6
Registered User
 
Join Date: Jan 2012
Location: Harrisburg, PA
Posts: 390
My Ride: 2005 330XI
Quote:
Originally Posted by miweber929 View Post
Yeah, I did.

Completely. Couple times even.

Fyi, the pictures really don't show **** and you were confused by front vs. rear guibo for some reason. So I was asking a legit question as it appears you're fixing random things left and right. I tried to maybe offer some help since I just went through all these replacements myself with mixed results but since you insist on being an asshat, well screw you then and have fun.
OK, thanks. Bye bye now.

Sent from my Galaxy 10.1 Tablet on bimmer app.
__________________
RIP Bach: 11/4/2003 - 3/9/2013
caleb6 is offline   Reply With Quote
Old 01-24-2013, 08:35 PM   #47
countdown
Registered User
 
Join Date: Jan 2013
Location: Greensburg, PA
Posts: 4
My Ride: 2004 325xi
Id say it might be a torq converter.
countdown is offline   Reply With Quote
Old 01-25-2013, 03:08 PM   #48
caleb6
Registered User
 
Join Date: Jan 2012
Location: Harrisburg, PA
Posts: 390
My Ride: 2005 330XI
anyone actually replace their own TC buffer? I've been searching but can't find anything - not on here, not on google, not on bavauto tech site.

it seems like it should be fairly easy, but I'd rather not get into it without a DIY to follow here.

EDIT: I'm on to some stuff now at bimmerfest. I'll keep this thread updated for posterity.

Last edited by caleb6; 01-25-2013 at 03:18 PM.
caleb6 is offline   Reply With Quote
Old 01-25-2013, 07:30 PM   #49
e46alfonso
Registered User
 
Join Date: Aug 2011
Location: ct
Posts: 479
My Ride: 330xi, focus st
The TC is not repairable. What fluid are you using?

I must have dumped the clutch more than 50 times at around 3-4k rpm and my awd system is perfectly smooth. Doubt its the TC.

Vibrations during heavy acceleration sounds like axles. Are they original, OEM GNK, or another brand?
e46alfonso is offline   Reply With Quote
Old 01-26-2013, 05:00 AM   #50
caleb6
Registered User
 
Join Date: Jan 2012
Location: Harrisburg, PA
Posts: 390
My Ride: 2005 330XI
Quote:
Originally Posted by e46alfonso View Post
The TC is not repairable. What fluid are you using?

I must have dumped the clutch more than 50 times at around 3-4k rpm and my awd system is perfectly smooth. Doubt its the TC.

Vibrations during heavy acceleration sounds like axles. Are they original, OEM GNK, or another brand?

I'm sorry man, but I don't understand your point? I'm not contemplating repairing the TC, just replacing the TC mount rubber buffer.

FWIW, I used RedLine MTL in the TC, following Mike Miller's advice. TC runs smooth as silk, as does the rest of the transmission. I just have a vibration at very specific RPM range.

Regarding the axles - I assume OE. I haven't replaced them, they look OE (although I haven't looked that hard), and I have no history on the car prior to my purchase.
caleb6 is offline   Reply With Quote
Old 01-26-2013, 10:36 AM   #51
jeepo23
Registered User
 
Join Date: Oct 2011
Location: cdn
Posts: 1,087
My Ride: 02 330
Here is what one member did to replace the TC bushing. This is what I plan on doing within the next month. Couple of plates, a rod, some washers. Use a reciprocating saw to cut the other sleeve of the old bushing to get it out.

jeepo23 is offline   Reply With Quote
Old 02-17-2013, 06:33 PM   #52
caleb6
Registered User
 
Join Date: Jan 2012
Location: Harrisburg, PA
Posts: 390
My Ride: 2005 330XI
So to update this situation - after being sidetracked by my fuel pump going out and having to replace it, the fuel filter, and the fp relay, I'm back to trying to figure out this vibration thing.

I ordered, and received, the new TC mount bushing - haven't installed it yet. Today went for a 120 mile round trip with the wife and both kids. Noticed that the vibration is getting worse, and now showing up when downshifting or 'coasting' in gear - basically when not under load.

I guess I'll get the TC mount bushing replacement job complete and go from there.

Hope that's all it is.
caleb6 is offline   Reply With Quote
Old 02-24-2013, 07:31 AM   #53
nosnooz
Registered User
 
Join Date: Feb 2013
Location: Lowell, MI
Posts: 7
My Ride: 2002 325xit
I had the thumping sound on acceleration from a stop and it was the csb. The rubber had torn that holds the bearing to the csb mount. The driveshaft was free to flop around a bit.
nosnooz is offline   Reply With Quote
Old 03-25-2013, 08:05 PM   #54
325xittt
Registered User
 
Join Date: Apr 2010
Location: Reading, PA
Posts: 173
My Ride: 2003, 325 XIT
any updates

Hey caleb6 did the TC mount solve your problem?
__________________
325xittt is offline   Reply With Quote
Old 03-26-2013, 04:13 AM   #55
caleb6
Registered User
 
Join Date: Jan 2012
Location: Harrisburg, PA
Posts: 390
My Ride: 2005 330XI
Quote:
Originally Posted by 325xittt View Post
Hey caleb6 did the TC mount solve your problem?
Hey! I didn't even get to it yet - had some other issues get in the way, like a failed fuel pump and filter replacement. I have the mount still, just haven't gotten around to replacing it yet.
__________________
RIP Bach: 11/4/2003 - 3/9/2013
caleb6 is offline   Reply With Quote
Old 03-26-2013, 08:54 PM   #56
325xittt
Registered User
 
Join Date: Apr 2010
Location: Reading, PA
Posts: 173
My Ride: 2003, 325 XIT
Yeah I know the feeling. I got a set of replacement shocks from Bilstien sitting in a box. Life gets in the way. Let us know what you find out
Thanks
__________________
325xittt is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use