E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 01-26-2013, 09:56 AM   #1
LandCruzer94
Registered User
 
Join Date: Mar 2012
Location: Carmel, Indiana
Posts: 5
My Ride: 1988 535is 5-Spd
Odd issue on the highway, frozen brakes?

I decided to drive my wife's Xi to work yesterday since it was snowing, and after a 45 or so minute commute to work the car sat in a parking lot for almost four hours. Once I got back on the highway I went to brake and the brakes were non-responsive and I got a hard pedal.

Odd...

As I continued the drive, my issue changed into veering hard to the left on braking (the harder I pushed, the harder it dove to the left)

Now this is getting real weird...

I dragged the brakes with my left foot to see if there was something stuck in there and heat them up. No change. I finally got off the freeway and came to a stop and made my right turn onto a surface street.

Problem solved.

I'm glad I was in the car rather than my wife, because I know she would've freaked out and had an accident, but now I need to figure out what happened. We've owned the car for almost a year and I doubt the brakes have ever been bled, can that water in there actually freeze leaving me with temporarily dead calipers? I'll add that this has NEVER been an issue in the past.

Thanks guys.
LandCruzer94 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use