E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 55 votes, 4.98 average. Display Modes
Old 01-13-2013, 05:48 AM   #601
arts99
Registered User
 
Join Date: Oct 2008
Location: Surrey, UK
Posts: 1
My Ride: 318i (2000)
guidance/clarification

hi,

i hope someone can help/guide me.

my driver side front and rear window regulator cables broke and i bought new regulators from ebay; instead of fixing them myself took them to a local garage as didnít have the tools and was not very confident doing it myself.

the garage installed both the regulators but they do not seem to be working perfectly, the front one seems to make squeaking noise when windows is rolled up or down, some times its more sometimes less. Upon careful further inspection I saw that both the windows whose regulators have been changed and not fully rolling down and stay a about a inch outwards, please see the pictures attached.





Took the car back to the garage and they said that this might be happening due to the windows regulators not being original BMW, they said there are no adjustments that can be done so if they hadnít installed it properly it wonít be working.

I then contacted the supplier and he confirmed that they sell hundreds of these every year and never had any problems, they said it must be occurring due to the glass runners not being greased properly and as a result the glass is making squeaking noise and not going fully down. They said they even include a note with the regulators to instruct the fitters that they must grease properly and I did check that note was indeed there. I also checked supplier reviews on ebay has indeed sold many of these regulators and havent got a single negative review about their suitability.

So went back to the garage and now they are saying that they can open the whole door again, clean everything and then put back again but no guarantee; they also want to charge another £30 for doing so even though they charged £110 initially.

I am not sure who is right, can anyone guide me on this. Do you think itís a fitting/greasing issue? What shall I do?

Thank you very much for your help!
Attached Thumbnails
Click image for larger version

Name:	IMG-20130111-00132.jpg
Views:	86
Size:	111.7 KB
ID:	485830   Click image for larger version

Name:	IMG-20130111-00133.jpg
Views:	88
Size:	119.0 KB
ID:	485831  
arts99 is offline   Reply With Quote
Old 01-13-2013, 06:26 AM   #602
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,827
My Ride: '99 328i 1.04646 mu
Start by spraying silicone spray into the track the window slides in.

What the shop said about alignment is almost true...there isn't a way to align the front regulator, although there is in the back. But, there is slight play in how the regulators are mounted. I usually suggest that diyers use the 'shadows' from old regulator nuts to align the new one.

It's very easy opening up the door...just have some extra door clips around...and make sure the Vapor Barrier is sealed up tight.

There are many diys on this, and honestly, the silicone spray lubricant might help. If not, you can be confident enough on this that you won't mess up things too badly!

You need some basic tools...I think T-25 bit...and to remember to disconnect the battery 5 mins before if you're removing the air bag. Not sure you need to do that now to just, maybe, realign things...if you do get into the door yourself. (A plastic pry bar is nice to get the door panel off too--aka trim tools)
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set

dmax on the radio every Wednesday 7-9 p.m. NYC time. Call in! (661) 449-9340 watsonnwatson.com
dmax is offline   Reply With Quote
Old 01-13-2013, 06:37 AM   #603
impee
Registered User
 
Join Date: Oct 2005
Location: London (UK)
Posts: 130
My Ride: BMW 2002 318i SE
Yep, I think dmax is spot on...removing the panel is easy and try some silicone / grease. I think that will at least get rid of the squeaking. I am not sure about the window not rolling fully down though. Once you have the vapor barrier off, you could have a look and see if any thing seems to be fitted slightly off.

Good luck!
__________________

For e46 DIYs visit - www.impee.co.uk
impee is offline   Reply With Quote
Old 01-28-2013, 09:21 AM   #604
atrain76
Registered User
 
Join Date: Jun 2008
Location: Texas
Posts: 38
My Ride: 2001 325i
Awesome! I did the drivers side yesterday. Took me 2.5 hours, and that is at my slow pace. The zip ties worked for me, making it a virtually free fix. As one recent poster noted my window doesn't quite go all the way down. Most likely an alignment issue. If I get ambitious I will go back and get it perfect.
atrain76 is offline   Reply With Quote
Old 01-28-2013, 04:48 PM   #605
chilone
Registered User
 
Join Date: Nov 2012
Location: Colorado
Posts: 138
My Ride: 04 330xi, 97 Miata
Just did my front drivers side yesterday with a Dorman regulator/motor combination. To me, the combo is the way to go as it's very easy swapping the whole thing plus they can be had for about $80.00 and up (I work in auto parts and got mine for free :o]). Here's my two cents about Dorman or other aftermarket vs. OEM: The OEMs are obviously problematic and AT LEAST twice the money. The Dorman unit that I got is made in Taiwan and these days, Taiwan's quality is generally pretty good. Personally I don't think they'll be worse than the originals and for the price, it's worth trying them.

So anyway everything went well except now the door locks don't work and the auto up/down only works going down i.e. I have to hold the button 'till the window is all the way up.

I would think the auto up/down issue is a switch problem but I'm stymied by the lock problem as I didn't disconnet them. I do't really wanna take it apart again Ideas?

Last edited by chilone; 01-28-2013 at 04:49 PM.
chilone is offline   Reply With Quote
Old 01-29-2013, 09:40 PM   #606
BimmersGarage
Registered User
 
Join Date: Mar 2010
Location: Dallas, TX (USA)
Posts: 2,189
My Ride: E46 330i
Send a message via Skype™ to BimmersGarage
Quote:
Originally Posted by chilone View Post
Just did my front drivers side yesterday with a Dorman regulator/motor combination. To me, the combo is the way to go as it's very easy swapping the whole thing plus they can be had for about $80.00 and up (I work in auto parts and got mine for free :o]). Here's my two cents about Dorman or other aftermarket vs. OEM: The OEMs are obviously problematic and AT LEAST twice the money. The Dorman unit that I got is made in Taiwan and these days, Taiwan's quality is generally pretty good. Personally I don't think they'll be worse than the originals and for the price, it's worth trying them.

So anyway everything went well except now the door locks don't work and the auto up/down only works going down i.e. I have to hold the button 'till the window is all the way up.

I would think the auto up/down issue is a switch problem but I'm stymied by the lock problem as I didn't disconnet them. I do't really wanna take it apart again Ideas?
5 finger discount...?

Did you remember to disconnect the battery while working on the front doors?
BimmersGarage is offline   Reply With Quote
Old 01-30-2013, 07:46 AM   #607
chilone
Registered User
 
Join Date: Nov 2012
Location: Colorado
Posts: 138
My Ride: 04 330xi, 97 Miata
Quote:
Originally Posted by BimmersGarage View Post
5 finger discount...?

Did you remember to disconnect the battery while working on the front doors?
Absolutely NOT!! I work for some very kind, generous people Yes, I did disconnect the bat-tree..
chilone is offline   Reply With Quote
Old 02-21-2013, 06:45 AM   #608
CaCarter126
Registered User
 
Join Date: Mar 2012
Location: Del Rio, TX
Posts: 11
My Ride: 04' 330i ZHP
Hey guys, so I used this DIY to do the zip tie fix on my regulator and it worked like a charm....however, now my door will unlock but not lock. The actuator sounds fine, it's as if I somehow disconnected it or something? Maybe when I pulled the door panel out I pulled out on the lock too much?

Any idea what might be going on here?
CaCarter126 is offline   Reply With Quote
Old 02-21-2013, 08:40 AM   #609
omodos
Registered User
 
Join Date: Nov 2011
Location: cyprus
Posts: 88
My Ride: 318 auto n42
CAcarter 2 things the zip tie thing worked for me on all doors for a while and then they came off alas, and instead of getting the whole guide mechanism I bought the replacement plastic sliders one side fine on the other not a good fit and have issues again, so bought meyle replacement guides and mechanisms and waiting to pluck up courage to strip trim off for the 4th time! dunno why bmw use the most useless of plastics to make these parts.....

best bet for the door not locking issue it take of trip and see if all looks ok again
omodos is offline   Reply With Quote
Old 02-21-2013, 09:13 AM   #610
CaCarter126
Registered User
 
Join Date: Mar 2012
Location: Del Rio, TX
Posts: 11
My Ride: 04' 330i ZHP
Thanks man, so the zip ties failed on u?

I took the door panel back off and put it back on and the lock works fine again, I think it was somehow rubbing on the door panel.
CaCarter126 is offline   Reply With Quote
Old 02-21-2013, 09:38 AM   #611
omodos
Registered User
 
Join Date: Nov 2011
Location: cyprus
Posts: 88
My Ride: 318 auto n42
glad it worked out for ya, Initially zip ties worked fine, I thought great, then they gave way after a few months and back to square one, so instead of using plastic ties i used wire! again clips broke even more, so as i mentioned there are replacement 'clips' that are all plastic which means not having got get the whole rail with the original metal and plastic parts OEM, BUT not too sure about them either so will do 'upgrade' come early summer....having said that about the zip ties they may last longer for you...in the meantime do a scan for the parts online I am sure they are cheaper in the u.s , until i put in the meyle ones cant be too sure how good they are as a fit or how long they will last ...for the record they cost me last summer about £40.00 each side
omodos is offline   Reply With Quote
Old 02-21-2013, 09:43 AM   #612
CaCarter126
Registered User
 
Join Date: Mar 2012
Location: Del Rio, TX
Posts: 11
My Ride: 04' 330i ZHP
Yeah, I'll definitely keep an eye out. Thanks a lot man, appreciate the advice.
CaCarter126 is offline   Reply With Quote
Old 02-21-2013, 09:51 AM   #613
omodos
Registered User
 
Join Date: Nov 2011
Location: cyprus
Posts: 88
My Ride: 318 auto n42
no problem, only question i had was were to find the black rubbery sealant that seals the weatherseal cover onto the inside of the door, cut it off fine but then it lost its tackiness a bit as i tried to stretch it out and re-use it on door, anyway we don't get much rain out here but i would have been happier if i had new sealant on
omodos is offline   Reply With Quote
Old 02-21-2013, 10:03 AM   #614
CaCarter126
Registered User
 
Join Date: Mar 2012
Location: Del Rio, TX
Posts: 11
My Ride: 04' 330i ZHP
Hmm, not sure man, mine was certainly still tacky enough. I def wouldn't put any kind of glue or anything in case you have to take it off again. Maybe a piece or two of double sided tape just to keep the vapor barrier on. The thing isn't air tight or anything. I wouldn't worry too much about it.
CaCarter126 is offline   Reply With Quote
Old 02-21-2013, 06:04 PM   #615
John in VA
Registered User
 
Join Date: Oct 2007
Location: Leesburg, VA
Posts: 601
My Ride: '00 FarngrŁn 328i
Quote:
Originally Posted by omodos View Post
no problem, only question i had was were to find the black rubbery sealant that seals the weatherseal cover onto the inside of the door, cut it off fine but then it lost its tackiness a bit as i tried to stretch it out and re-use it on door...
Look for butyl caulk at the autobody supply shop, a local friendly body shop, or even a home center or Amazon.
__________________
John in VA
'03 530i
'00 328i
'86 535i
'85 535i
'85 325e - RIP
'74 2002tii
John in VA is online now   Reply With Quote
Old 02-24-2013, 01:13 AM   #616
Dawiev
Registered User
 
Join Date: Feb 2013
Location: Bahrain
Posts: 1
My Ride: 325
Another zip tie saves the day !!

Thank you to all those for the time and effort to share this type of info.
Dawiev is offline   Reply With Quote
Old 03-19-2013, 12:25 AM   #617
Linx
Registered User
 
Join Date: Mar 2012
Location: Los Angeles
Posts: 252
My Ride: '02 BMW 325iT
So I did this fix on my driver side about 6 months ago with steel wire instead of zip ties. Its worked fine but did have the issue of rolling up a bit slower and very minor sounds. Today it gave out. It rols down fine but when it got half way unit struggled really bad and stopped. I kept playing with it until I got it all the way up but its not all the way sealed cuz I hear wind while driving. About to order a new regulator but do you guys think it might be the motor? Rolls down smoothly but like I said, it struggles really bad going up to the point that it stops about 1/2 to 3/4 ways up.
Linx is offline   Reply With Quote
Old 03-25-2013, 09:36 AM   #618
newnoise
Registered User
 
Join Date: Mar 2007
Location: Richmond, VA
Posts: 15
My Ride: 2000 BMW 323i E46.
I'm about to replace my fifth (!!!) window regulator on my 2000 323i today. This is extremely frustrating. The first two replacements were OEM, and since those broke, I purchased the last two cheap ones from ebay (so I'd have a spare since I knew this would happen again). The OEMs held longer, but still broke, so I figured why not save the money if it's going to break anyway. The zip tie method worked for me the first time, but it only held for a couple days. What I can't figure out is why someone just doesn't sell a fully molded steel/metal clip with no plastic as that damn thing breaks fairly often from the look of things. When I get the old regulator out, I'm going to take a look at the clips.
newnoise is offline   Reply With Quote
Old 03-25-2013, 11:32 AM   #619
newnoise
Registered User
 
Join Date: Mar 2007
Location: Richmond, VA
Posts: 15
My Ride: 2000 BMW 323i E46.
Somehow got cutoff there. I'm going to look at the clips and see If I can just fashion one out of steel instead. If I'm successful, I might start making them for others if anyone is interested.
newnoise is offline   Reply With Quote
Old 03-27-2013, 12:49 PM   #620
sj408
Registered User
 
Join Date: Feb 2012
Location: BayArea
Posts: 53
My Ride: E46
I put in a new regulator on my front passenger and it worked fine for about a week then it stopped working again. I opened the door up and no breaks of any sort but i think the teeth on the motor might not be catching the teeth of regulator. =(
sj408 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use