E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-10-2013, 06:27 AM   #1
scott_karana
Registered User
 
Join Date: Aug 2011
Location: Canada
Posts: 7
My Ride: E46 325i Sport
Unhappy Factory headunit broken after removing to check what kind of pins it has?!

Hey guys;

Just like the title says. Planning on getting an aftermarket deck, so I pulled my factory headunit (CD53?) to see whether it had the flat or round pins.
When I next ran the car, I couldn't get anything out of the radio:
  • No clock, or anything else on the display
  • No audio
  • No anti-theft light

The only indication that I even plugged the connector back in is that I can see the faceplate light up when my headlights are on.
I tried pulling it again, checked the connector and the built-in fuse above it, and everything looks good...

Any ideas? Was it just that I forgot to unhook the battery before pulling it the first time?
Happy to pull it again if part numbers or photos help.


Also, possibly related is the fact that I removed my glove compartment to test out of my fuel pump relay, and removed the GM5 to get a better reach. However, central locking and fuel are working fine afterwards; the car is in complete running order except for the damn radio.
Is there even anything in that area that I could have forgotten which would make it stop working? I wouldn't know.

Last edited by scott_karana; 02-10-2013 at 06:31 AM. Reason: dashboard -> glove compartment
scott_karana is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-11-2013, 03:12 PM   #2
scott_karana
Registered User
 
Join Date: Aug 2011
Location: Canada
Posts: 7
My Ride: E46 325i Sport
Nobody has any ideas at all?
scott_karana is offline   Reply With Quote
Old 02-11-2013, 03:19 PM   #3
linom3
Registered User
 
Join Date: Dec 2012
Location: NJ
Posts: 168
My Ride: M3
fuse blown maybe?
linom3 is offline   Reply With Quote
Old 02-11-2013, 03:19 PM   #4
linom3
Registered User
 
Join Date: Dec 2012
Location: NJ
Posts: 168
My Ride: M3
radio conector no plug in all the way?
linom3 is offline   Reply With Quote
Old 02-11-2013, 07:26 PM   #5
mrbamathews
Registered User
 
Join Date: May 2012
Location: California
Posts: 6
My Ride: 02 BMW 325i
Follow a simple diag tree here

1. check all fuses
2. remove radio & make sure pins on the back of the radio are not bent/ damaged
3. make sure wiring connector is/ was fully seated & clipped into place
mrbamathews is offline   Reply With Quote
Old 02-12-2013, 07:14 PM   #6
scott_karana
Registered User
 
Join Date: Aug 2011
Location: Canada
Posts: 7
My Ride: E46 325i Sport
Yup, turned out to be a mis-positioned fuse in the main box.
Thanks All!
scott_karana is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use