E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > ///M3 Forum

///M3 Forum
The BMW E46 ///M3 is the M version E46 and puts out an amazing 333 HP and 262 lb-ft of torque at stock specs! There are an amazing amount of modifications for both the coupe and convertible models so read up and get started modifying your cars today!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-13-2013, 04:50 PM   #1
Yoshim3e46
Registered User
 
Join Date: Feb 2013
Location: Peru
Posts: 3
My Ride: e46 m3, Spec C typRA
Loss of power on m3 help please!

Hi, im from Peru and i own a 2001 manual e46 m3 with 42k miles on it.
My car was running at 80% cause i had it scanned and dealer told me i had to change the camshaft sensor (exhaust), it was running fine but lacking a lil power cause of it.

When i finally changed it ( 2 days ago ) and after deleting all the error codes and memory my m3 was lacking like 50% power ! after a scan it showed it was running lean so i changed the MAF...after changing it it was still the same. Ive checked the fuel pump and it seems OK, ive allready changed the spark plugs, filters etc.

The wierd part is that scan shows NO error codes now but it still lacks lots of power.
I had to leave my car at the dealer and he has no idea whats wrong with it....he told me that i have to use the car so that the ecu learns...and after a couple hundred miles it should b OK.......dunno how true this can be.

Any ideas on what can be wrong with it ?? any help would be apreciated ..THANKS !!
Yoshim3e46 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-13-2013, 06:10 PM   #2
lsbmatt
Registered User
 
Join Date: Jun 2012
Location: bay area
Posts: 113
My Ride: 2002 vert m3 lsb smg
Were you able to write down the codes?

If so, post them.
lsbmatt is offline   Reply With Quote
Old 02-13-2013, 06:28 PM   #3
Yoshim3e46
Registered User
 
Join Date: Feb 2013
Location: Peru
Posts: 3
My Ride: e46 m3, Spec C typRA
it shows NO codes now...just the oil temp sensor wich i have to change.
what was showing is the additive and multiplicative % of the AFR was at +25%, i think it means the ecu was sending +25% more fuel to compensate it.....dunno at what % it should be working.
Yoshim3e46 is offline   Reply With Quote
Old 02-13-2013, 11:16 PM   #4
$ilent ///M
Registered User
 
Join Date: Jan 2010
Location: So.Cal
Posts: 233
My Ride: 03.5 M3 smg lsb
if the ecu is trying to add more fuel you could have a clogged fuel filter. how many miles do you have and when was the last time you changed the fuel filter also check for air leaks
$ilent ///M is offline   Reply With Quote
Old 02-14-2013, 02:34 AM   #5
Yoshim3e46
Registered User
 
Join Date: Feb 2013
Location: Peru
Posts: 3
My Ride: e46 m3, Spec C typRA
the fuel filter was changed 1000 miles ago....allready checked for air leaks...
this is driving me crazy
Yoshim3e46 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use