E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-03-2013, 06:33 PM   #21
WDE46
Registered User
 
Join Date: Sep 2012
Location: Virgo Supercluster
Posts: 8,005
My Ride: 2004 330Ci OBM
Quote:
Originally Posted by 05_325xi View Post
Thanks for your info but how can i check the MAF
Find someone with a 325 and swap them. I think there are two versions of the MAF sensor though. One has a built in intake air temp sensor and the other doesn't. You'll need someone with the same version. You can tell by the number of wires on the connector.
__________________
fa·nat·ic
Noun
A person filled with excessive and single-minded zeal

BMW VIN Decoder

Last edited by WDE46; 02-03-2013 at 06:34 PM.
WDE46 is offline   Reply With Quote
Old 02-04-2013, 11:12 AM   #22
ddpp
Registered User
 
Join Date: Feb 2013
Location: Providence, Rhode Island
Posts: 5
My Ride: E46, 328i 99
I have had this happen for a month, At first I thought it was the tranny going out, but guess what? All that puppy needed was some atf fluid! After putting in 6 quarts of castrol high mileage atf car has, shifted, ran, and is much faster now after 2 months. No more limp mode, but for some reason you say its the maf, but I dunno.
ddpp is offline   Reply With Quote
Old 02-04-2013, 11:17 AM   #23
ryannel2003
Registered User
 
Join Date: Apr 2012
Location: New Bern, NC
Posts: 973
My Ride: '04 Cadillac Deville
Quote:
Originally Posted by WDE46 View Post
Too much misinformation here to debunk individually.

If the car runs fine with the MAF disconnected that does not mean the MAF is the problem. Doing this just makes the car run open loop using none of it's sensors. If it runs better without the MAF sensor, that only means that it's not some major engine component and may just be another sensor.

Anyway, I doubt your transmission light is related to the MAF. I have never heard of that. It wouldn't make sense for that to be the case anyway.
First week I had my E46 I started having error messages related to a dirty throttle body sending the car into safe mode. After a long day of cleaning the tb and putting everything back together I hooked the MAF back up and started the car an was greeted with a (!) light by my transmission gear in the dash and the car shifted terrible. After some research I disconnected it and reconnected it and the car ran fine. Strange? Yes. Annoying? Very. Why? Hell if I know.
__________________
ryannel2003 is offline   Reply With Quote
Old 02-04-2013, 11:35 AM   #24
DHK
Registered User
 
Join Date: Mar 2012
Location: Estonia
Posts: 681
My Ride: 2002 BMW 325Ci
Transmission light == Limp mode.

Any variety of things can send your car into limp mode. Most of them have exactly nothing to do with the transmission.
As far how you check the MAF youve already got your answer, get codes read.
DHK is offline   Reply With Quote
Old 02-04-2013, 11:44 AM   #25
WDE46
Registered User
 
Join Date: Sep 2012
Location: Virgo Supercluster
Posts: 8,005
My Ride: 2004 330Ci OBM
Quote:
Originally Posted by ryannel2003 View Post
First week I had my E46 I started having error messages related to a dirty throttle body sending the car into safe mode. After a long day of cleaning the tb and putting everything back together I hooked the MAF back up and started the car an was greeted with a (!) light by my transmission gear in the dash and the car shifted terrible. After some research I disconnected it and reconnected it and the car ran fine. Strange? Yes. Annoying? Very. Why? Hell if I know.
That's quite strange. And that's really all I can say there hahaha. Maybe OP has the same problem.
WDE46 is offline   Reply With Quote
Old 02-04-2013, 11:50 AM   #26
RayPooley
Registered User
 
Join Date: Jul 2012
Location: Liverpool
Posts: 1,378
My Ride: 320i SE Coupe
Quote:
Originally Posted by 05_325xi View Post
I've been having problems for the past week with my car i have the trans light on and i been jumping from the dealer to different shops and everyone tells me oh is this oh is that i just think its my MAF sensor do you guys know if the MAF sensor makes thie trans light come on and puts the car on safety mode
Post a pic of your trans light. See attached image.
Attached Thumbnails
Click image for larger version

Name:	AutoTransmissionFault.jpg
Views:	42
Size:	119.6 KB
ID:	489292  
RayPooley is offline   Reply With Quote
Old 02-04-2013, 11:52 AM   #27
05_325xi
Registered User
 
Join Date: Jan 2013
Location: North Jersey NJ
Posts: 239
My Ride: 2005 BMW 325xi
My luck i just picked up a 2001 325i which was rear ended so im taking the MAF because the car is being crushed so ill try plugging this one up n tak a ride i hope thats the problem n the reason why i think thats my problem because the code i keep getting when i scan the car
__________________
05_325xi is offline   Reply With Quote
Old 02-04-2013, 11:53 AM   #28
BMWCaptain
Registered User
 
Join Date: Sep 2011
Location: TEXAS - Where I give Real World advice and don't just criticize others. People here need to RESPECT other's opinions!
Posts: 1,586
My Ride: 03 325iT SportWagon
You need someone with pa scanner 1.4 or other BMW code scanner who can read your BMW codes to tell you what your transmission errors are. This is the only way to debug it. Maf error may be something else.

Put a post for someone in Jersey who might be able read it for you.

Last edited by BMWCaptain; 02-04-2013 at 11:55 AM.
BMWCaptain is offline   Reply With Quote
Old 02-04-2013, 04:26 PM   #29
2003silver330i
Registered User
 
Join Date: Feb 2012
Location: N. Las Vegas, NV
Posts: 1,533
My Ride: 03 BMW 330i
Quote:
Originally Posted by 05_325xi View Post
Sucks to hear but yea the truth is thats how those guys make their money
but what kind of problems are you having
Within the first few months of ownership the following has been replaced:
Ex CPS
EDK Throttle Body
Spark Plugs
Valve Cover
VCG
LCAB
Steering Guibo

And losses coolant on a daily basis. Leads me to believe a head problem.

EDIT: Forgot to add that I replaced the PS pump which was leaking like a MOFO

Last edited by 2003silver330i; 02-04-2013 at 04:30 PM.
2003silver330i is offline   Reply With Quote
Old 02-04-2013, 07:33 PM   #30
djray
Registered User
 
djray's Avatar
 
Join Date: Nov 2004
Location: LA
Posts: 421
My Ride: 01 BMW325CI
When my car went into Limp Mode it was because i washed the under body of the car around the transmission area. So I ended up letting it dry out for a few days and then it went away and never came back. This could be something to look into as well.

Last edited by djray; 02-04-2013 at 07:34 PM.
djray is offline   Reply With Quote
Old 02-04-2013, 10:19 PM   #31
SHOoff11
Registered User
 
Join Date: Apr 2011
Location: Mobile, AL
Posts: 260
My Ride: 2006 Honda Civic Si
FYI I unplugged my MAF the other day while the car was running and it tripped the transmission light, I reset it and all has been good since.
__________________
Quote:
Originally Posted by SPDSKTR
You drive a BMW. That means you make $600,000 a year and date supermodels without pointy elbows or hairy arms. Need I say more?

2006 Honda Civic Si Coupe Nighthawk Black Pearl/Black


1995 Silver Frost/Gray Taurus SHO (sold)

1999 BMW 328i Sedan Alpine White/Sand (sold)
SHOoff11 is offline   Reply With Quote
Old 02-17-2013, 02:20 PM   #32
05_325xi
Registered User
 
Join Date: Jan 2013
Location: North Jersey NJ
Posts: 239
My Ride: 2005 BMW 325xi
So i just got back from a shop i found online yesterday and i left my car at yesterday and the dude found why my trans light was on and all this stress was just a stupid brake pedal switch my light is now gone
__________________
05_325xi is offline   Reply With Quote
Old 02-17-2013, 04:00 PM   #33
chillinhardinanE46
Registered User
 
Join Date: Dec 2012
Location: CALI
Posts: 79
My Ride: 2003 325i
brake pedal switch? can you elaborate?
chillinhardinanE46 is offline   Reply With Quote
Old 02-17-2013, 04:02 PM   #34
Broach><330
Registered User
 
Join Date: Feb 2010
Location: Clemson, SC
Posts: 731
My Ride: 330CI -E30 325 (S52)
Go to you tube, look at my videos. Bimmian89 I have about 4 videos on there of what MAF failures sound like. Try to disconnect it and see what happens.
__________________


High-line catback
Kosei K1's
Headers
3.15 Differential
Koni FSD, eibach sports
AA software
205k (9/16/13)

E30 S52B32 100,xxx
5spd ZF, JB LW fly, Megan Coils, OBD1 conv. Mishimoto with low temp stat, TRM 15x8, Black vinyl sport seats, MOMO mod 08, 2:93 LSD, Custom single 2.5" exhaust, SS headers, M3 rack, basically new everything on driveline.
Broach><330 is offline   Reply With Quote
Old 02-17-2013, 04:04 PM   #35
05_325xi
Registered User
 
Join Date: Jan 2013
Location: North Jersey NJ
Posts: 239
My Ride: 2005 BMW 325xi
Guys i found the problem it was the brake pedal sensor my trans light is now gone
__________________
05_325xi is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use