E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-08-2013, 08:00 PM   #1
nhat179
Registered User
 
Join Date: Aug 2009
Location: Grand Rapids, MI
Posts: 44
My Ride: E46 323i Sedan 5 spd
Engine misfire cylinder 1, 2, 3

I had 5 codes last week:
Cylinder 1 misfire
Cylinder 2 misfire
Cylinder 3 misfire
O2 control deviation bank 1
O2 control deviation bank 2

I changed 2 O2 sensors before CAT. 2 O2 sensor codes are gone, but still misfire. I did a search but I don't know where to start. Any help guys? Thanks a lot for your time
nhat179 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-08-2013, 08:09 PM   #2
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,384
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
Can we get PO number please..
TrippinBimmer is offline   Reply With Quote
Old 02-08-2013, 10:45 PM   #3
nhat179
Registered User
 
Join Date: Aug 2009
Location: Grand Rapids, MI
Posts: 44
My Ride: E46 323i Sedan 5 spd
you mean the code number anthony?
nhat179 is offline   Reply With Quote
Old 02-08-2013, 11:04 PM   #4
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,384
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
Yes...
TrippinBimmer is offline   Reply With Quote
Old 02-08-2013, 11:36 PM   #5
NFSx328ci
Registered User
 
Join Date: Oct 2008
Location: Pawcatuck, CT.
Posts: 612
My Ride: TiAg E46
Check your dip stick to make sure that its all the way in. This happened to me once. You can also check your rubber elbow that hooks up to your intake my old old one was pretty...well old. And it had a tear on it. That caused me to have misfire errors aswell until I replaced it.
__________________


My babies; Supercharged 328ci, 99 GSX boosted to 625awhp, 2011 Grand Cherokee. Newest addition: 2009 Alpine White 135i
NFSx328ci is offline   Reply With Quote
Old 02-09-2013, 02:22 PM   #6
nhat179
Registered User
 
Join Date: Aug 2009
Location: Grand Rapids, MI
Posts: 44
My Ride: E46 323i Sedan 5 spd
Will give it a try buddy.
To Anthony: i will plug the scanner back on and let u know. Thanks guys
nhat179 is offline   Reply With Quote
Old 02-11-2013, 09:57 PM   #7
nhat179
Registered User
 
Join Date: Aug 2009
Location: Grand Rapids, MI
Posts: 44
My Ride: E46 323i Sedan 5 spd
I changed the intake boot and the misfire gone. But my 2 codes for O2 sensor came back up.
227: O2 bank 1 control deviation
228: O2 bank 2 control deviation
I changed new O2 sensor already.
nhat179 is offline   Reply With Quote
Old 02-12-2013, 02:21 PM   #8
nhat179
Registered User
 
Join Date: Aug 2009
Location: Grand Rapids, MI
Posts: 44
My Ride: E46 323i Sedan 5 spd
Any suggestion for me guys?
nhat179 is offline   Reply With Quote
Old 02-23-2013, 11:07 PM   #9
nhat179
Registered User
 
Join Date: Aug 2009
Location: Grand Rapids, MI
Posts: 44
My Ride: E46 323i Sedan 5 spd
Bump
nhat179 is offline   Reply With Quote
Old 02-23-2013, 11:27 PM   #10
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,384
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
What brand o2's and post or pre?
TrippinBimmer is offline   Reply With Quote
Old 02-24-2013, 08:59 PM   #11
Bino5150
Registered User
 
Join Date: Feb 2013
Location: Houston, TX
Posts: 176
My Ride: 99 323i
I'm having this exact same problem, but mine is cyl 4,5, & 6. I also had a 6th code for multiple/random cyl misfire.
Bino5150 is offline   Reply With Quote
Old 02-24-2013, 09:21 PM   #12
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,384
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
All these issues could been avoid with proper maintinece...
TrippinBimmer is offline   Reply With Quote
Old 02-24-2013, 09:42 PM   #13
Bino5150
Registered User
 
Join Date: Feb 2013
Location: Houston, TX
Posts: 176
My Ride: 99 323i
Quote:
Originally Posted by TrippinBimmer View Post
All these issues could been avoid with proper maintinece...
I'm exempt! I've only had this car like 2 weeks, and it's spent 2/3 of that time sitting in the driveway pissing me off...
Bino5150 is offline   Reply With Quote
Old 02-24-2013, 09:48 PM   #14
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,384
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
Quote:
Originally Posted by Bino5150 View Post
I'm exempt! I've only had this car like 2 weeks, and it's spent 2/3 of that time sitting in the driveway pissing me off...
Sounds like my car ATM. Lol hit u up tomorrow if/when I'm free to help.
TrippinBimmer is offline   Reply With Quote
Old 02-24-2013, 09:57 PM   #15
Bino5150
Registered User
 
Join Date: Feb 2013
Location: Houston, TX
Posts: 176
My Ride: 99 323i
no problem. I've got a thread posted too here:
http://forum.e46fanatics.com/showthread.php?t=972345

maybe we can chase down the gremlins in my machine.
Bino5150 is offline   Reply With Quote
Old 03-04-2013, 08:09 PM   #16
nhat179
Registered User
 
Join Date: Aug 2009
Location: Grand Rapids, MI
Posts: 44
My Ride: E46 323i Sedan 5 spd
thanks a lot guys for your help. Anthony, did you change your AIM? I never seen you online bro
nhat179 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 01:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use