E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Forced Induction Forum Sponsored by Active Autowerke

Forced Induction Forum Sponsored by Active Autowerke
Discuss supercharging, turbocharging and even nitrous and water injection here.
Sponsored by Active Autowerke

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-09-2013, 04:16 PM   #1
R0B
Registered User
 
Join Date: Jul 2009
Location: Northern Virginia
Posts: 729
My Ride: zhp sedan
Shutter/EML 2004 330 zhp

I have two issues. One is the shutter at start up, another is an EML issue.

The shutter occurs when I start the car, and lasts for about 5 seconds. Idle drops, then slowly rises to correct idle. Doesn't matter if it is cold/warm.

The EML issue arises when I try to accelerate, typically from below 3k rpm. Sometimes it happens above 3k rpm. Wide open throttle decreases the chances of the EML being triggered. At times, it doesn't pull smoothly through the rpm band. Once the EML is triggered, the engine has an erratic idle, bouncing between ~800-1200 rpm. I do not have control of the throttle when the engine/computers are in this state. I must reset the key to restart everything. I also noticed that I get a power surge if I hold the gas peddle in a position to slowly accelerate. This is not the famous surge or bump around 2400 rpm as result from the DESA.

No boost leaks, blower is making 12lbs.


EDIT: Just checked the fuel pressure. Primes to 46psi, idles at 38psi. Not sure if this is ok.
Thinking it may be the DISA valve, bottom bolt broke off. D:

Thanks in advance!
__________________
Merhaba

:Headers: :Header-back Magnaflow Exhuast: :UUC clutch/lightweight flywheel: :AA stage 1 supercharger: :VMR V710:
For sale: 3.46 differential, 18x8.0 style 135/18x8.5 style 135/ 19x8.5 varrstoen 1.1.2

Last edited by R0B; 01-10-2013 at 10:04 PM.
R0B is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-26-2013, 12:02 PM   #2
xbass
Registered User
 
Join Date: Dec 2012
Location: beijing,china
Posts: 11
My Ride: E46 M3 HPF stage 2.5
change throttle valve sensors
xbass is offline   Reply With Quote
Old 02-27-2013, 04:39 AM   #3
SweTurbo
Big Pimpin'
 
Join Date: Nov 2008
Location: Europe
Posts: 2,899
My Ride: 323i -98
Yeah , EML lights are 90% of the time related to the throttle signals.
SweTurbo is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use