E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-04-2013, 11:56 AM   #1
Redryan98
Registered User
 
Join Date: Jun 2010
Location: CT
Posts: 242
My Ride: 07 Legacy GT 5MT
Trac and Brake Lights after Steering Coupler/Guibo

Hi All

I replaced by steering guibo yesterday in hopes of finding tighter/quicker steering. It was a bit of a struggle but I did get the new one in. Hopped in the car to take a spin and I'm greated with the traction control and brake lights on.

I understand most likely cuprit is steering angle sensor, which I guess makes sense since I was working with the steering column and it looks like I'll need calibration. I'm not really sure why I'd get errors though. I've read plenty steering coupler DIYs and noone mentioned any issues with it.

Do you think I have any hope in hell of the system recalibrating itself given some time? I'm sure its just wishful thinking but hey you never know. I'll be ordering PA Soft 1.4 shortly but who knows how long it will take to arrive. Any other advise short of "go to dealer/indy to get it checked?"

Last edited by Redryan98; 03-04-2013 at 11:57 AM.
Redryan98 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-04-2013, 04:23 PM   #2
Dave1027
Registered User
 
Join Date: Jan 2013
Location: California
Posts: 875
My Ride: '06 IR 330ci zhp
Might clear by itself. If not, try disconnecting the battery.
Dave1027 is offline   Reply With Quote
Old 03-04-2013, 06:47 PM   #3
Redryan98
Registered User
 
Join Date: Jun 2010
Location: CT
Posts: 242
My Ride: 07 Legacy GT 5MT
Quote:
Originally Posted by Dave1027 View Post
Might clear by itself. If not, try disconnecting the battery.
It actually did on the way home tonight! I'm very relieved.
Redryan98 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use