E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 03-07-2013, 04:24 PM   #1
clio
Registered User
 
Join Date: Mar 2013
Posts: 12
Engine Management Light does not come on

I donít know if this has already been discussed here, but I bought my car in December 316i 1999 model, and up until Friday I realised that the carís engine management light does not come on at all, I tried to disconnect a few sensors from the engine bay including the MAF Sensor and still the light didnít come on, though the engine was so shaky after disconnecting the sensors. I have removed the Instrument Cluster to check for bulbs only to find that thereís LEDís instead of bulbsÖ.
Why I was looking for management light is because since I bought the car, the car has never run smooth, it feels like itís a bit shaky or judders sometimesÖI really donít know.
Has this happened to anyone before (the light not coming on I mean)? I have other cars too and the light comes on every time I turn the ignition to on, start the car and the light goes off.
__________________
1999 BMW 316i - Other Run around
2008 Mercedes Benz GL420 - Sold
1988 Mercedes Bens 420SL - My Weekend Toy
2005 Alfa Romeo 156 Selespeed - Other Run around
2006 Volvo XC90 - Sold
2004 Volvo XC90 - Winter Car
clio is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use