E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-20-2013, 10:07 PM   #1
Dtmnuka
Registered User
 
Join Date: Feb 2013
Location: Milwaukie
Posts: 50
My Ride: 2004 325i
o2 sensor CEL?

Since I've had my 04 325i ive been getting 13-14mpg!! Ive done spark plugs and everything I read tells me to replace my o2 sensors before the cat but if they were bad wouldnt my check engine light be on? I just dont want to replace them and continue to get this awful gas mileage.
Dtmnuka is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-20-2013, 10:36 PM   #2
HakenTT
OEM ///Member
 
Join Date: Aug 2009
Location: gross deutsches reich USA
Posts: 544
My Ride: 323i with S54
Quote:
Originally Posted by Dtmnuka View Post
Since I've had my 04 325i ive been getting 13-14mpg!! Ive done spark plugs and everything I read tells me to replace my o2 sensors before the cat but if they were bad wouldnt my check engine light be on? I just dont want to replace them and continue to get this awful gas mileage.
If the 02 sensors were bad I am positive you would have check engine light for them.

If your MPG is poor and you have no fault codes. then it may be posible that thermostat is stuck open and it takes long time for the engine to get into operating temperature
HakenTT is offline   Reply With Quote
Old 03-21-2013, 03:43 AM   #3
Dtmnuka
Registered User
 
Join Date: Feb 2013
Location: Milwaukie
Posts: 50
My Ride: 2004 325i
Quote:
Originally Posted by HakenTT View Post
If the 02 sensors were bad I am positive you would have check engine light for them.

If your MPG is poor and you have no fault codes. then it may be posible that thermostat is stuck open and it takes long time for the engine to get into operating temperature
Okay ill check that asap. It being stuck open can effect the mileage that severely huh? I had no idea. Thanks for the suggestions.
Dtmnuka is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 03:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use