E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Suspension & Braking

Suspension & Braking
Have some questions about suspension or brake setups for your E46 BMW? Get all your answers here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-21-2013, 02:50 PM   #1
Hollywood516
Registered User
 
Join Date: Apr 2011
Location: Long Island, NY
Posts: 1,669
My Ride: 02 330i
Upper strut mounts or Lower control arm?

As some of you know, the past month I have had some pothole troubles.. Without getting into a whole story , basically I wanna know if there is a sure way to check if my upper strut mounts are shot. I jacked the car up and wiggled the front tire 12-6 and 3-9 positions. There is no movement up-down and minimal movement 3-9 position . The thing is ,when I go 3-9 position it looks like the strut moves a little bit. When I go over a bumpy road there is a clunking noise that I cant re-create with the car jacked up . I know it didn't make that noise prior to hitting the pothole.I already ordered new Meyle Lower Control Arm.. Thx, for your help guys..
__________________
Hollywood516 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-21-2013, 02:54 PM   #2
Mango
A full five stars, son
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 22,631
My Ride: M54B30
If they are original, they should be replaced. Don't cheap out on it.
__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is offline   Reply With Quote
Old 03-21-2013, 03:10 PM   #3
tock172
Beachtown Bill Collector
 
tock172's Avatar
 
Join Date: Jan 2011
Location: San Diego
Posts: 2,892
My Ride: '99 Techno Violet M3
When I first refreshed my suspension, I reused my original front strut mounts. This was a mistake. I was already tramlining beforehand and it got worse as time went on. When I swapped springs, I had a set of Meyle front strut mounts installed. Problem solved. My original components were visibly worn.
__________________


1999 Techno Violet Metallic BMW M3
2005 Audi B6 S4 quattro 6MT
2004 BMW 330i
1986 BMW 535i

tock172 is offline   Reply With Quote
Old 03-21-2013, 03:35 PM   #4
Hollywood516
Registered User
 
Join Date: Apr 2011
Location: Long Island, NY
Posts: 1,669
My Ride: 02 330i
When I installed my suspension set up 2 years ago (Koni sports/H&R) I did new front rear mounts. I think the pothole screwed them up.anybidy prefer one brand over another?
__________________
Hollywood516 is offline   Reply With Quote
Old 03-22-2013, 10:55 AM   #5
hummer
Registered User
 
Join Date: Apr 2003
Location: Haverhill, MA
Posts: 3,323
My Ride: 2001 330CI
It could also be that the strut itself is gone. Could be loose or bent. A pot hole blew my Bilstein PSS9 strut, mount bearing, mushroomed the fender, bent two wheels and broke the lower outer ball joint socket! Powerflex CAB survived! There was water on the road and I never saw the F'n hole! I'll bet the strut piston is wobbly where it enters the strut housing.
hummer is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use