E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Suspension & Braking

Suspension & Braking
Have some questions about suspension or brake setups for your E46 BMW? Get all your answers here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-09-2010, 01:26 AM   #1
infantrytroop22
Registered User
 
Join Date: Mar 2009
Location: SoCal
Posts: 114
My Ride: M3
Can RTAB limiters cause creaking?

I just had new OEM RTABs and limiters (not sure what brand) installed on my '05 M3 and the rear end of my car now creaks when I pull in and out of driveways. Could this be from the Limiters? FYI, I'm on coilovers.
infantrytroop22 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-09-2010, 01:27 AM   #2
SpeedDemon
Registered User
 
Join Date: Jul 2003
Location: Seattle
Posts: 1,939
My Ride: 08 M3/05 ZHP/08 R32
Probably not... what make limiters are they?

It's probably something else. Strut seals that aren't lubed properly, RTABs, RSMs, etc...
SpeedDemon is offline   Reply With Quote
Old 03-09-2010, 02:04 AM   #3
infantrytroop22
Registered User
 
Join Date: Mar 2009
Location: SoCal
Posts: 114
My Ride: M3
I forget what make the limiters are. The RTABs are new and OEM, so I can't imagine they would be causing the issue, unless they need to be broken in or something. My mechanic claims the creaking is caused by the limiters and that it is normal. I trust his opinion, but I kind of want some verification and other thoughts.
infantrytroop22 is offline   Reply With Quote
Old 03-09-2010, 07:32 AM   #4
TxZHP04
Registered User
 
Join Date: Feb 2006
Location: DFW
Posts: 5,728
My Ride: ESS TS2+ ZHP
I've never experienced any creaking with my Vorshlag limiters and have never heard any reports of creaking but I suppose it's possible depending on the material your limiters are made of.
__________________
04 IR 330i ZHP | ESS TS2+ SC | MagnaFlow "headers" | KMS 3.64 LSD | AST 4100 550/650| APEX ARC-8 18x9 | H&R front sway bar | Vorshlag camber plates, RTAB limiters | TMS subframe & swaybar reinforcements | UUC SSK & DSSR | UUC TM & TME | BW motor mounts | Dinan strut & shock tower bars | vaio 4-bolt oil pump
TxZHP04 is offline   Reply With Quote
Old 03-09-2010, 06:28 PM   #5
Whammy
Registered User
 
Join Date: Apr 2006
Location: WI -> CO
Posts: 20,106
My Ride: ZHP
Quote:
Originally Posted by infantrytroop22 View Post
I just had new OEM RTABs and limiters (not sure what brand) installed on my '05 M3 and the rear end of my car now creaks when I pull in and out of driveways. Could this be from the Limiters? FYI, I'm on coilovers.
When was the last time you had an alignment? Have you checked your suspension? Is anything cracked (subframe, swaybar) or loose (endlinks)?
Whammy is offline   Reply With Quote
Old 03-09-2010, 07:13 PM   #6
infantrytroop22
Registered User
 
Join Date: Mar 2009
Location: SoCal
Posts: 114
My Ride: M3
I just had an alignment when the RTABs and limiters were installed. Everything was checked over, and nothing is damaged. The sound is coming from both sides, meaning I can hear each side creaking independently. That is why I figured it was related to the limiters.
infantrytroop22 is offline   Reply With Quote
Old 03-09-2010, 07:19 PM   #7
infantrytroop22
Registered User
 
Join Date: Mar 2009
Location: SoCal
Posts: 114
My Ride: M3
I guess the material is a urethane rubber, and the brand is ireland, or something like that.
infantrytroop22 is offline   Reply With Quote
Old 03-09-2010, 08:55 PM   #8
Whammy
Registered User
 
Join Date: Apr 2006
Location: WI -> CO
Posts: 20,106
My Ride: ZHP
I have the Vorshlag limiters and I do not have the same issue you are describing. I did notice a little creaking over winter, but I think the alignment and lowering of my suspension (PSS System) helped.
Whammy is offline   Reply With Quote
Old 03-09-2010, 09:05 PM   #9
infantrytroop22
Registered User
 
Join Date: Mar 2009
Location: SoCal
Posts: 114
My Ride: M3
It only creaks when there is torque on the chassis, like when I pull in or out of a driveway. There really isn't much noise when going over speed bumps, etc. I think I am going to drive it for another week or so, and then if it is still really loud I am going to take it back to my mechanic and have him check it out.
infantrytroop22 is offline   Reply With Quote
Old 08-14-2012, 01:05 PM   #10
mpower3330
Registered User
 
Join Date: Oct 2007
Location: san jose
Posts: 12
My Ride: E46 M3
Back from the dead.. Did you ever find out what was causing this? I had my RTABs replaced with OEM ones and OEM limiters and have had the exact same creaking problem since they were put on.
mpower3330 is offline   Reply With Quote
Old 03-21-2013, 12:59 AM   #11
thecarguy
Registered User
 
Join Date: Nov 2006
Location: San Diego, CA
Posts: 118
My Ride: ZHP Sedan
Quote:
Originally Posted by mpower3330 View Post
Back from the dead.. Did you ever find out what was causing this? I had my RTABs replaced with OEM ones and OEM limiters and have had the exact same creaking problem since they were put on.
Yet back again from the dead. Same here!

Last edited by thecarguy; 03-21-2013 at 01:00 AM.
thecarguy is offline   Reply With Quote
Old 03-21-2013, 11:46 AM   #12
thecarguy
Registered User
 
Join Date: Nov 2006
Location: San Diego, CA
Posts: 118
My Ride: ZHP Sedan
Here is what I posted in my own post yesterday which has had no response yet. So just in case this is the one that gets traction, here is my story...

So, this past weekend I installed Meyle HD rtabs and poly limiters...
http://store.bimmerworld.com/e36e46z...px?Thread=True

I researched a lot, printed DIYs and spent the better part of the day doing it. Won't get into that. Anyways, I did the following to a T....

Pressed in bushings with exact equal distance out on both sides (even).
Put poly limiters in the correct way (only way) with beveled sides out.
Pre-aligned bracket "pre loaded" with axel...by the book.
Torqued down to 87ft/lb
Matched up bracket in body to spray marks and torqued down the 3 bolts on each side. Forgot spec but to spec.

On movement of suspension -especially when cold, I get noise from what has to be the poly bushings rotating against the smooth clean metal rtab bracket.

It blew me away that no lithium lube was called out for that mating surface.

Anyways, it turns out I am the only one on the planet that has had this problem according to them. It just does not make sense.

So, I don't think I did anything wrong so should I just spray a bit of lithium lube in between the bracket and limiters?

Anyone else have this issue???
thecarguy is offline   Reply With Quote
Old 03-21-2013, 07:07 PM   #13
thecarguy
Registered User
 
Join Date: Nov 2006
Location: San Diego, CA
Posts: 118
My Ride: ZHP Sedan
Has to be someone to chime in?
thecarguy is offline   Reply With Quote
Old 03-22-2013, 09:30 AM   #14
thecarguy
Registered User
 
Join Date: Nov 2006
Location: San Diego, CA
Posts: 118
My Ride: ZHP Sedan
It's exciting to know I'm not the only one, now I can't believe it's been 36 hours with no reply.
thecarguy is offline   Reply With Quote
Old 03-23-2013, 12:08 PM   #15
thecarguy
Registered User
 
Join Date: Nov 2006
Location: San Diego, CA
Posts: 118
My Ride: ZHP Sedan
Just need to know the best spray lubricant for in between the limiters and metal bracket that is friendly to the rubber Meyle HD rtabs. I would really like to take care of this today.

Feeling desperate....please help.
thecarguy is offline   Reply With Quote
Old 03-24-2013, 11:47 PM   #16
thecarguy
Registered User
 
Join Date: Nov 2006
Location: San Diego, CA
Posts: 118
My Ride: ZHP Sedan
Checking in.
thecarguy is offline   Reply With Quote
Old 10-28-2013, 01:40 PM   #17
muscal48
Registered User
 
Join Date: Sep 2005
Location: San Francisco
Posts: 1
My Ride: BMW 1999 328i
I too am getting terrible creaking problems. I installed Turner Motorsports limiters and it was tolerable at first, but has been getting increasingly worse (and a lot louder). My 328i sounds like a pirate ship. Has anyone had any luck resolving this issue yet? Thanks!
muscal48 is offline   Reply With Quote
Old 10-28-2013, 07:55 PM   #18
SoloII///M
Registered User
 
Join Date: Mar 2005
Location: Columbia, MD
Posts: 458
My Ride: Many
Can RTAB limiters cause creaking?

They creak. Lube will make it go away for a bit but not forever.


Sent from BimmerApp mobile app
__________________
John V
'03 330i ZHP - Stock-ish
'02 330Ci - Megasquirt 3, M50 manifold, Kromer Kraft headers, Motons, widebody, etc.
SoloII///M is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use