E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-30-2013, 05:14 PM   #1
Vince_B
Registered User
 
Join Date: Mar 2013
Location: Virginia
Posts: 16
My Ride: ZHP
Completely Disabling DSC on a ZHP

First I should say that I have read the previous threads on this topic and they are consistent with the 330 CI manual, and the advice of a BMW shop foreman. Unfortunately, it doesn't work on my ZHP. We had a BMW autocross today and by holding in the DSC (or equivalent) button long enough, we could completely disable all of the DSC on all E46s but mine. I don't know it there is something unique to the ZHP or if there is something wrong with my particular car.

What should happen is, after a brief press of the button, the CBC is disabled, but the DTC is still enabled. If instead, one holds the button in longer, like 5 to 10 seconds, both controls are disabled. What happens on my car is, a brief tap causes the DSC warning line to come on and DTC is definitely disabled, but the CBC is definitely still enabled. Pressing it longer (about 10 seconds) only causes the warning line to go out and the DSC to completely re-enable.

I really want to solve this some way (including removing a fuse, etc.) that does not disable the ABS. Although I normally autocross an Integra Type-R, I brought out my dead stock daily driver ZHP and it was much faster than I expected--even though the CBC interfered significantly. Any help would be much appreciated.
Vince_B is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-30-2013, 05:54 PM   #2
TerraPhantm
Registered User
 
Join Date: Feb 2008
Location: Mountain Top
Posts: 5,903
My Ride: 2005 M3 Coupe
On my own ZHP the press and hold worked fine.
TerraPhantm is offline   Reply With Quote
Old 03-30-2013, 06:24 PM   #3
Vince_B
Registered User
 
Join Date: Mar 2013
Location: Virginia
Posts: 16
My Ride: ZHP
Quote:
Originally Posted by TerraPhantm View Post
On my own ZHP the press and hold worked fine.
@TerraPhantm, that's good to know. If that's true, then there is something wrong with mine. When you pressed and held, what lights or indicators did you see? Also, about how long did you have to press and hold?
Vince_B is offline   Reply With Quote
Old 03-30-2013, 06:32 PM   #4
|2eckLesS
Registered User
 
Join Date: Jun 2012
Location: Charleston, SC
Posts: 184
My Ride: 2004 330ci
works fine on my ZHP. Rarely ever done, but still works. 04 ZHP 82k.
|2eckLesS is offline   Reply With Quote
Old 03-30-2013, 06:54 PM   #5
silyb0y
Registered User
 
Join Date: Jul 2011
Location: Southpark
Posts: 53
My Ride: E46 330
Im not sure if I read it on this forum but I did read about a guy who had trouble turning his DSC off. He wrote he needed to do so to dyno his car. As it turned out - his button was faulty.
silyb0y is offline   Reply With Quote
Old 03-30-2013, 07:09 PM   #6
Vince_B
Registered User
 
Join Date: Mar 2013
Location: Virginia
Posts: 16
My Ride: ZHP
@I2eckLesS, I have the same questions for you as I had for TerraPhantm. When you pressed and held, what lights or indicators did you see? Also, about how long did you have to press and hold?
Vince_B is offline   Reply With Quote
Old 03-30-2013, 07:12 PM   #7
TerraPhantm
Registered User
 
Join Date: Feb 2008
Location: Mountain Top
Posts: 5,903
My Ride: 2005 M3 Coupe
Press and hold would cause the DSC and brake light to light up amber. Had to hold it for maybe 3 seconds.
TerraPhantm is offline   Reply With Quote
Old 03-30-2013, 07:24 PM   #8
Vince_B
Registered User
 
Join Date: Mar 2013
Location: Virginia
Posts: 16
My Ride: ZHP
@TerraPhantm, Thanks for the info. It appears that mine is broken. Hopefully, it's something simple like a faulty button as SilybOy suggested.
Vince_B is offline   Reply With Quote
Old 03-30-2013, 08:16 PM   #9
Grande D
Registered User
 
Join Date: Dec 2006
Location: PA
Posts: 3,313
My Ride: E90 M-Sport
Mine goes all the way off. Nothing is different about the DSC in the ZHP compared to any other non-M with DSC.
__________________
Quote:
Originally Posted by Jaymalls View Post
dont listen to these fuQ faces... just go to a junk yard and get a used complete left rear end. i cracked my left rear control arm on the highway because i was driving w/o shocks... lol! ***Was too busy caking on these bitches instead of taking care my car!***
Grande D is offline   Reply With Quote
Old 03-31-2013, 12:36 AM   #10
TerraPhantm
Registered User
 
Join Date: Feb 2008
Location: Mountain Top
Posts: 5,903
My Ride: 2005 M3 Coupe
Quote:
Originally Posted by Grande D View Post
Mine goes all the way off. Nothing is different about the DSC in the ZHP compared to any other non-M with DSC.
Actually it is a different module compared to most non-Ms. For some reason, the ZHP got the RPA DSC module regardless of whether or not it was equipped with the RPA system.
TerraPhantm is offline   Reply With Quote
Old 03-31-2013, 01:11 AM   #11
katu
Registered User
 
Join Date: Jan 2011
Location: Santa Rosa, CA
Posts: 574
My Ride: '04 330ci ZHP
Quote:
Originally Posted by TerraPhantm View Post
On my own ZHP the press and hold worked fine.
Same here. I do it for autox.
__________________
katu is offline   Reply With Quote
Old 03-31-2013, 01:19 AM   #12
cvx5832
Registered User
 
Join Date: Mar 2009
Location: Walnut Creek, CA
Posts: 2,051
My Ride: 325Ci, 325Cic, C300
Any chance you got the codes read? Maybe there's a fault in the system that's preventing it to fully disengage?
__________________


cvx5832 is offline   Reply With Quote
Old 03-31-2013, 02:38 AM   #13
Vince_B
Registered User
 
Join Date: Mar 2013
Location: Virginia
Posts: 16
My Ride: ZHP
@cvx5832, that's a very interesting idea. I'll definitely check the codes, it can't hurt and might be the answer.
Vince_B is offline   Reply With Quote
Old 03-31-2013, 06:40 AM   #14
|2eckLesS
Registered User
 
Join Date: Jun 2012
Location: Charleston, SC
Posts: 184
My Ride: 2004 330ci
Pressing and holding DSC - First yellow DSC light comes on immediately, still holding for 5 seconds and the emergency brake light turns on and says "Brake" in yellow. If you have the emergency brake on the "Brake" light will illuminate red but as soon as it is relased, the "Brake" light turns yellow. Are you auto or manual? MT here.
|2eckLesS is offline   Reply With Quote
Old 04-01-2013, 09:25 AM   #15
Vince_B
Registered User
 
Join Date: Mar 2013
Location: Virginia
Posts: 16
My Ride: ZHP
@I2eckLesS, thanks for your input. What you say is consistent with the manual and what others have described. I wish mine would do that. It's a 6-speed MT.

Once I get it fixed, I'll report here what the issue was. Hopefully, that will be sooner rather than later.
Vince_B is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use