E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > New Member Introductions

New Member Introductions
New members check-in, introduce yourselves, and post a picture of your BMW here!

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-08-2013, 10:46 PM   #1
t3kn0
Registered User
 
Join Date: Mar 2013
Location: reno,nv
Posts: 21
My Ride: 03 325xi
Hi everybody!

Hey guys,
Got this issue with the headlight washer nozzle.Bought one on ebay and also bought the plastic cover that broke( of course ) when i removed the nozzle.My problem is that the pump itself somehow got loose and wiggles in there...I can reach it with my hand without taking filter housing or anything else off(talking about driver side), but i cant figure it out how is supposed to mount in there.Since I dont wanna take everything apart I was wondering if somebody can explain to me how the pump stays in there...Is it twist on or push in or maybe something broke on mine and thats why it came loose....
Thank you
t3kn0 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-09-2013, 09:50 PM   #2
lszlszx
Registered User
 
Join Date: Jan 2013
Location: Venice, CA
Posts: 3,803
My Ride: 328i, XC70
Welcome to the forum! I think you have the best chance to get that answered in the xi sub-forum.
lszlszx is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use