E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-15-2013, 08:52 PM   #1
412bmw
Registered User
 
Join Date: Jan 2010
Location: pittsburgh
Posts: 31
My Ride: 01' 330i 03' M3 alpw
Helppp!!Alternator not charging

I bought a refurbished alternator few weeks back all the sudden it won't charge the battery. I checked the amps on it my meter was reading 12 and should be 14-16amps, also I had it bench tested and it checked out ok
Any thoughts on the situation?
412bmw is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-15-2013, 09:06 PM   #2
lszlszx
Registered User
 
Join Date: Jan 2013
Location: Venice, CA
Posts: 3,813
My Ride: 328i, XC70
Check for battery voltage at the alternator.
At the big connector there should be voltage at all times.
Pull the electrical plug off the alternator and test for
battery voltage with the ignition on.
If there isn't there is a connection, or wiring issue.
This could've been the problem to begin with, did you
test the old alternator, are you sure it was bad?

Last edited by lszlszx; 04-15-2013 at 09:17 PM.
lszlszx is offline   Reply With Quote
Old 04-16-2013, 06:19 AM   #3
412bmw
Registered User
 
Join Date: Jan 2010
Location: pittsburgh
Posts: 31
My Ride: 01' 330i 03' M3 alpw
I did not test the old one but when I put the new one on it was working fine till yesterday. I'll check the voltage later today and get back to you .
412bmw is offline   Reply With Quote
Old 04-16-2013, 06:57 AM   #4
BMWCaptain
Registered User
 
Join Date: Sep 2011
Location: TEXAS - Where I give Real World advice and don't just criticize others. People here need to RESPECT other's opinions!
Posts: 1,586
My Ride: 03 325iT SportWagon
Quote:
Originally Posted by 412bmw View Post
I bought a refurbished alternator few weeks back all the sudden it won't charge the battery. I checked the amps on it my meter was reading 12 and should be 14-16amps, also I had it bench tested and it checked out ok
Any thoughts on the situation?
I think you mean volts instead of amps. BMW can put out 120amps at 12volts.
__________________
Founding Member of the Club of Dangerous Fanatics

Engine swap, HG, tranny swap, GM & ZF tranny rebuilds, shocks, struts, brakes, WPs, Thermostats, belts, tensioners, fuel pumps, radiators, window regs, hoses, PS pump, Spark Plugs, VCGs, coils, fuel filters, CVVs, VANOS seals, rack, LCABs, Exp. Tanks, OFHGs, RCABs, OP, boots, ABS, GUIDOs, starter, A/C, DISA, Diff, SAP

Ultra Premium Grand 10 Star+ Super Duper BMW-pedic Sport Plus +++
BMWCaptain is offline   Reply With Quote
Old 04-16-2013, 05:46 PM   #5
412bmw
Registered User
 
Join Date: Jan 2010
Location: pittsburgh
Posts: 31
My Ride: 01' 330i 03' M3 alpw
I do don't no why I said amps
412bmw is offline   Reply With Quote
Old 04-16-2013, 06:40 PM   #6
412bmw
Registered User
 
Join Date: Jan 2010
Location: pittsburgh
Posts: 31
My Ride: 01' 330i 03' M3 alpw
I am still getting around 11 volts at the alternator with ignition on or off anything else I can check
412bmw is offline   Reply With Quote
Old 04-16-2013, 06:41 PM   #7
412bmw
Registered User
 
Join Date: Jan 2010
Location: pittsburgh
Posts: 31
My Ride: 01' 330i 03' M3 alpw
I cleaned all connections and still getting no charge
412bmw is offline   Reply With Quote
Old 04-16-2013, 07:46 PM   #8
BMWCaptain
Registered User
 
Join Date: Sep 2011
Location: TEXAS - Where I give Real World advice and don't just criticize others. People here need to RESPECT other's opinions!
Posts: 1,586
My Ride: 03 325iT SportWagon
You will get battery voltage at the terminal if the car is not running. You should get 13.5-14.5v with the engine running. If you are only getting 11v when running then your new alternator is bad.
__________________
Founding Member of the Club of Dangerous Fanatics

Engine swap, HG, tranny swap, GM & ZF tranny rebuilds, shocks, struts, brakes, WPs, Thermostats, belts, tensioners, fuel pumps, radiators, window regs, hoses, PS pump, Spark Plugs, VCGs, coils, fuel filters, CVVs, VANOS seals, rack, LCABs, Exp. Tanks, OFHGs, RCABs, OP, boots, ABS, GUIDOs, starter, A/C, DISA, Diff, SAP

Ultra Premium Grand 10 Star+ Super Duper BMW-pedic Sport Plus +++
BMWCaptain is offline   Reply With Quote
Old 04-16-2013, 08:01 PM   #9
412bmw
Registered User
 
Join Date: Jan 2010
Location: pittsburgh
Posts: 31
My Ride: 01' 330i 03' M3 alpw
Ok I'm feeling the same way . The refurbished alternator has to bad either the voltage regulator is bad or the whole alternator. When the car is on and I test the the battery it only ready 11 volts and it declines.
412bmw is offline   Reply With Quote
Old 04-16-2013, 09:32 PM   #10
lcoleman
Registered User
 
Join Date: Mar 2007
Location: the barnyard
Posts: 2,446
My Ride: '79 Massey Ferguson
Quote:
Originally Posted by 412bmw View Post
...refurbished alternator...
Good odds this is the problem. Buy a new, not remanufactured one if you can.

Edit: Does the battery light come on the dash? Seems like there's some exciter circuit or something that needs to be closed for the alternator to come on. The problem may also not have been the alternator to begin with.
__________________

Last edited by lcoleman; 04-16-2013 at 09:33 PM.
lcoleman is offline   Reply With Quote
Old 04-17-2013, 07:11 AM   #11
412bmw
Registered User
 
Join Date: Jan 2010
Location: pittsburgh
Posts: 31
My Ride: 01' 330i 03' M3 alpw
Yes the battery light does come on
412bmw is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 04:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use