E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Suspension & Braking

Suspension & Braking
Have some questions about suspension or brake setups for your E46 BMW? Get all your answers here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-18-2013, 02:43 PM   #1
BMWSauberF1.09
Registered User
 
Join Date: Apr 2009
Location: Montreal
Posts: 55
My Ride: 2002 325i Sedan
Question Weird noises when turning left/right

For the past two weeks I have had a weird clicking noise coming from the front when I turn the steering wheel left and right. This happens when stopped and while driving at low speeds. There is also the same noise that happens when reversing. During full lock in either direction there is a loud grinding noise as if scraping the chassis on a speed bump. Once in a while there is a loud POP when I'm at full lock. I am on KW V1 coilovers and Cosmo racing camber plates. (both professionally installed). I have also checked the power steering fluid and it is at the required amount.

I have searched the forum and could not find a situation like mine. If there is one please link it to avoid wasting everyones time!

Thank you in advance!

Last edited by BMWSauberF1.09; 04-18-2013 at 03:07 PM.
BMWSauberF1.09 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-19-2013, 08:30 AM   #2
BMWSauberF1.09
Registered User
 
Join Date: Apr 2009
Location: Montreal
Posts: 55
My Ride: 2002 325i Sedan
bump
BMWSauberF1.09 is offline   Reply With Quote
Old 04-19-2013, 09:15 AM   #3
GSherbs
Registered User
 
Join Date: Jun 2012
Location: Chicago
Posts: 400
My Ride: 2002 330 xi
You searched and can't find anything about clicking noises coming from the front while turning?

Really?

Maybe I'm missing something in your explanation but it sounds like any of a number of things that come up in the forum all the time. Wheel bearings, CVs, FCABs, sway bar links - have you eliminated any of these already?
GSherbs is offline   Reply With Quote
Old 04-19-2013, 09:17 AM   #4
03BIMMERM3
Registered User
 
Join Date: Feb 2013
Location: West Palm Beach
Posts: 138
My Ride: 2003 BMW M3
Are you sure your not rubbing, depending on how low your are...Have you replaced your FCABs recently?

Sent from my myTouch_4G_Slide using Bimmer App

Last edited by 03BIMMERM3; 04-19-2013 at 09:19 AM.
03BIMMERM3 is offline   Reply With Quote
Old 04-19-2013, 12:32 PM   #5
BMWSauberF1.09
Registered User
 
Join Date: Apr 2009
Location: Montreal
Posts: 55
My Ride: 2002 325i Sedan
Quote:
Originally Posted by GSherbs View Post
You searched and can't find anything about clicking noises coming from the front while turning?

Really?

Maybe I'm missing something in your explanation but it sounds like any of a number of things that come up in the forum all the time. Wheel bearings, CVs, FCABs, sway bar links - have you eliminated any of these already?

Quote:
Originally Posted by 03BIMMERM3 View Post
Are you sure your not rubbing, depending on how low your are...Have you replaced your FCABs recently?

Sent from my myTouch_4G_Slide using Bimmer App
I have replaced the FCAB approximately 15k km ago, the sway bar links are brand new approx ~100 km. The wheel bearing looks good.

I raised the car to almost stock height to see if it was rubbing that was causing the noise and even at that height it was still making the same noises.
Also when I make turns the steering wheel does not have the same response and kick back as it did before. Its almost as if there is no power steering.

Last edited by BMWSauberF1.09; 04-19-2013 at 12:35 PM.
BMWSauberF1.09 is offline   Reply With Quote
Old 04-19-2013, 06:24 PM   #6
03BIMMERM3
Registered User
 
Join Date: Feb 2013
Location: West Palm Beach
Posts: 138
My Ride: 2003 BMW M3
Id check out the tie rods, as for the steering wheel, id check your power steering fluid level again..make sure theres no leaks

Sent from my myTouch_4G_Slide using Bimmer App

Last edited by 03BIMMERM3; 04-19-2013 at 06:25 PM.
03BIMMERM3 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use