E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 04-28-2013, 10:35 AM   #1
epistaxis2008
Registered User
 
Join Date: Sep 2010
Location: USA
Posts: 445
My Ride: 2002 330ci
***Warning, this is not a DIY! *** both cam sensors replaced.

I am not a mechanic nor have I ever been. I have worked on cars my whole life for fun and for the savings.

Anything you do to your car before or after reading and viewing this post is solely up to you and I can not guarantee any results for you or your car.

Please heed all caution before all repairs. The car does not need to be jacked up for any reason to change the intake and exhaust camshaft sensors on my 2002 330ci.

There maybe me differences on your car.

This may not be accurate, so please refer to the proper repair manual or professional before working on your own car.

So my 2002 330ci has been randomly stalling for over a year. Sometimes while driving sometimes at idle and sometimes while clutching, very weird. Seemingly no pattern or cause, it was whenever it felt like it. It was not often and it would be for a day or two when it happened then would not happen again for a week or even a month later. But these last couple months it had been stalling more often. And it was beginning to have long starts, it felt like about 2-3 seconds longer than normal.

Now 2 weeks ago I finally got a service engine soon light. Got the code checked and it was P0340, intake camshaft sensor. I tried doing some research but I did not do a good job and went to AutoZone and got the exhaust sensor. On their website and on their in store ordering computer system it showed the exhaust sensor as the intake. So I bought the exhaust sensor thinking it was intake.

Click image for larger version

Name:	uploadfromtaptalk1367161207615.jpg
Views:	246
Size:	74.4 KB
ID:	502798

Anyway above is the exhaust sensor. The old and new one.

My service engine light went out last weekend when I changed this sensor. I thought I was golden but then found out it went out by coincidence when the light came back on the next day.

Fast forward to this weekend and my box of yee haaa came in from FCP with a new intake sensor, a new exhaust sensor, new o-rings for each, new bolts for each, a new steering reservoir o-ring, and a new fuel filter both unrelated to my original mission but I also needed them.

Click image for larger version

Name:	uploadfromtaptalk1367161532526.jpg
Views:	216
Size:	127.3 KB
ID:	502799

Above is the 3 tools I needed. The torx 25 is for the bolt holding the fan in, the 5 Allen is for the sensor bolts, and the torx 40 is also unreleated. It was for my disa bolt.

Click image for larger version

Name:	uploadfromtaptalk1367161703512.jpg
Views:	181
Size:	31.9 KB
ID:	502800
Click image for larger version

Name:	uploadfromtaptalk1367161736314.jpg
Views:	174
Size:	44.3 KB
ID:	502801

Above are the sensor bolts I got.

So for the exhaust sensor it is easier to get at and remove by removing the fan.

Click image for larger version

Name:	uploadfromtaptalk1367161908484.jpg
Views:	247
Size:	82.6 KB
ID:	502802
Above shows the fan in. Some other items are already removed and I will explain that for the intak sensor later.

Click image for larger version

Name:	uploadfromtaptalk1367161999825.jpg
Views:	174
Size:	93.3 KB
ID:	502803Click image for larger version

Name:	uploadfromtaptalk1367162016607.jpg
Views:	184
Size:	144.9 KB
ID:	502804
Above shows the t25 screw holding the left side of the fan in and then a plastic pop rivet that holds the right side of the fan. This pic does not show the actual fan rivet because mine was broken. This one is holdin the intake feed to the radiator support, but it is very similar to the fan one.

Click image for larger version

Name:	uploadfromtaptalk1367162174788.jpg
Views:	176
Size:	90.7 KB
ID:	502805
Disconnect these wire from the left side of the fan.

Click image for larger version

Name:	uploadfromtaptalk1367162213171.jpg
Views:	164
Size:	83.1 KB
ID:	502806
The fan pulls straight up to remove.

The exhaust sensor is located above n behind the left vanos solenoid. Remove the bolt and the sensor pulls out pretty easily. Make sure the old o-ring comes out also before installing the new one.
Click image for larger version

Name:	uploadfromtaptalk1367162364115.jpg
Views:	194
Size:	105.4 KB
ID:	502807disconnect the sensor wire.Click image for larger version

Name:	uploadfromtaptalk1367162455554.jpg
Views:	188
Size:	86.7 KB
ID:	502808wire out sensor still in.

This is where the sensor came out from.Click image for larger version

Name:	uploadfromtaptalk1367162532066.jpg
Views:	196
Size:	65.4 KB
ID:	502810

Now reverse the steps to install the new one. Click image for larger version

Name:	uploadfromtaptalk1367162606037.jpg
Views:	179
Size:	112.0 KB
ID:	502811This is the new sensor with the o-ring oiled up and slid on and the new bolt.

Now for the intake side.

Remove the air box.
Remove the oil filter cover.
Remove the right vanos solenoid.

Click image for larger version

Name:	uploadfromtaptalk1367162768212.jpg
Views:	189
Size:	103.5 KB
ID:	502812
Air box out to access the connector at the opposite end of the intake sensor.

Click image for larger version

Name:	uploadfromtaptalk1367163017280.jpg
Views:	203
Size:	111.3 KB
ID:	502813
Solenoid out so you can see the sensor. I used channel locks to remove the solenoid. It was not extremely tight.

now it won't let me add more pics??? Be back soon!




Sent from my PG86100 using Bimmer App

Last edited by epistaxis2008; 04-28-2013 at 10:58 AM.
epistaxis2008 is online now   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use