Top not locking on drivers side - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > E46 Convertible

E46 Convertible
The E46 vert forum. Talk about dropping your E46 top here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-01-2013, 10:53 AM   #1
nadodude
Registered User
 
Join Date: Mar 2011
Location: Coronado
Posts: 164
My Ride: '04 330ciC/ '02 C230
Top not locking on drivers side

Hey guys on Monday I noticed that the top will not lock on the drivers side when I close it. I can hear the motor working, but it doesn't lock. The passenger side locks down though. A huge storm came yesterday and it leaked a little but luckily it wasn't too bad. I need to get this fixed ASAP. Does anyone have any suggestions as to what the issue might be? I've googled and searched and haven't seen this issue on the web. The top light does not come on indicating an issue either. The top still goes up and down perfectly fine. Thanks
__________________

Last edited by nadodude; 05-01-2013 at 10:53 AM.
nadodude is offline   Reply With Quote
Old 05-02-2013, 01:23 PM   #2
nadodude
Registered User
 
Join Date: Mar 2011
Location: Coronado
Posts: 164
My Ride: '04 330ciC/ '02 C230
Any insight would be great! Thanks
__________________
nadodude is offline   Reply With Quote
Old 05-02-2013, 02:12 PM   #3
taylor192
Registered User
 
Join Date: Feb 2012
Location: The Best Place on Earth
Posts: 2,553
My Ride: 2003.5 M3
If it is the lock at the windshield you are talking about, then likely what happened is one of the 2 rods that go from the motor to the lock assembly broke. I'm pretty sure it is #24 in this diagram:
http://www.realoem.com/bmw/showparts...74&hg=54&fg=10

You'll have to disassemble the front panel of the top. There is a DIY on this site somewhere explaining how, from what I remember it is simple, just remove a bunch of screws and nuts along the rear edge of the cover.

I would fix is asap. If the other rod breaks while the top is closed your only course of action is to cut that front panel open to disengage the locks.
taylor192 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-03-2013, 10:21 AM   #4
nadodude
Registered User
 
Join Date: Mar 2011
Location: Coronado
Posts: 164
My Ride: '04 330ciC/ '02 C230
Thanks Taylor I'll look for the DIY.
__________________
nadodude is offline   Reply With Quote
Old 05-03-2013, 12:46 PM   #5
taylor192
Registered User
 
Join Date: Feb 2012
Location: The Best Place on Earth
Posts: 2,553
My Ride: 2003.5 M3
Quote:
Originally Posted by nadodude View Post
Thanks Taylor I'll look for the DIY.
I see you have a C230 coupe. Thankfully you have the 2002 with the 2.3L engine that doesn't have the problems the 2003 with the 1.8L mine had.
taylor192 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 02:47 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - VerticalScope Inc. All rights reserved.