E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-06-2013, 01:17 PM   #1
django1
Registered User
 
Join Date: Nov 2012
Location: spalding lincs. uk.
Posts: 17
My Ride: bmw 318i
help, my bmw thinks its hot when its cold!

my 1999 318i saloon thinks its warm when its cold 1st thing in the morning.
the car is difficult to start and fires up but then stops, fires up again and runs badly for about 20 seconds.
also the temp gauge on the dash reads half way on the gauge BEFORE i even start the car. the poor starting has on ly happened since the temp gauge has gone faulty. the temp gauge reads in the red after driving the car only a couple of miles but there's no overheating at all and never has been.
the poor starting in the morning was never a problem until the gauge started to read wrong.
im covinced these faults are linked as they both happened exactly the same day.
car has covered 101k miles.
ive already changed the brass temp sensor on the side of the engine block and also fitted a new thermostat and coolant but this has made no difference at all.
any ideas?
django1 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 05-07-2013, 01:00 PM   #2
django1
Registered User
 
Join Date: Nov 2012
Location: spalding lincs. uk.
Posts: 17
My Ride: bmw 318i
i have obtained some bmw training manuals and after careful study i suspect the problem is with the main ecu. ive sent it away to be looked at.
django1 is offline   Reply With Quote
Old 05-14-2013, 08:13 AM   #3
stankins
Registered User
 
Join Date: Apr 2011
Location: nj
Posts: 23
My Ride: 325ci
gl. hope its a fast find
stankins is offline   Reply With Quote
Old 05-16-2013, 03:14 PM   #4
django1
Registered User
 
Join Date: Nov 2012
Location: spalding lincs. uk.
Posts: 17
My Ride: bmw 318i
ive got to the bottom of the problem. its the ecu reading wrong. i have checked the resistance of theoolant switch then warmed the switch up and wathced the resistance change is accordance with a chart i have and its reading correct. ive cut the 2 wires which go to the sender at the back of the ecu and the gauge is still reading nearly half when the ignition is turned on 1st thing in the morning. ive had to connect a 200 ohm resistor inline on the temp switch cable to trick the ecu into reding the correct temp on the dash but this wont overcome the cold start problem in the morning. ive sent the ecu away to be tested and it came back as tested ok which is wrong as its faulty. i complained to the company who tested the ecu as i never sent them the imobiliser or the key so i dont think they could actually test it but they claimed they had, utter crap! they sent me a refund. ive been getting quotes of around 300 for a new ecu coded to my car but im not going ti have it done now as ive bought a 318 tourer instead as we needed something abit bigger.
django1 is offline   Reply With Quote
Old 05-31-2013, 03:41 PM   #5
django1
Registered User
 
Join Date: Nov 2012
Location: spalding lincs. uk.
Posts: 17
My Ride: bmw 318i
for whats its worth, i did buy a second hand ecu, immobiliser unit and key chip, poped them on in half hour and the fault is gone, gauge reads correct and cold starting is back. still got car up for sale though as bought touring model now.
django1 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 03:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use