E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > BMW Regional Forums > Regional Forums > New England

New England
Have you seen another BMW while driving around in your area? Maybe you can find their car in the E46Fanatics Garage!
MA ME NH RI VT

If you don't have your garage setup, sign up today HERE

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-22-2013, 10:17 AM   #21
BMWCaptain
Registered User
 
Join Date: Sep 2011
Location: TEXAS - Where I give Real World advice and don't just criticize others. People here need to RESPECT other's opinions!
Posts: 1,682
My Ride: 03 325iT SportWagon
Quote:
Originally Posted by trizzuth View Post
Oh wait, technically, I was partially right, and all of you were wrong.



CLEARLY it is not the upper hose that broke, but the plastic piece that the hose is clamped to from the factory, so YES, while it is part of the hose assembly that you buy, the HOSE ITSELF did not shear off, it was the plastic.

WIN.
Hey Arse Fvcker, you can't say anything now because you were wrong and your Ho approach sucks.

No one cares!

Ps: FYI you said it was the nipple on the ET.
__________________
Founding Member of the Club of Dangerous Fanatics

Engine swap, HG, tranny swap, GM & ZF tranny rebuilds, shocks, struts, brakes, WPs, Thermostats, belts, tensioners, fuel pumps, radiators, window regs, hoses, PS pump, Spark Plugs, VCGs, coils, fuel filters, CVVs, VANOS seals, rack, LCABs, Exp. Tanks, OFHGs, RCABs, OP, boots, ABS, GUIDOs, starter, A/C, DISA, Diff, SAP

Ultra Premium Grand 10 Star+ Super Duper BMW-pedic Sport Plus +++
BMWCaptain is offline   Reply With Quote
Old 05-22-2013, 10:38 AM   #22
trizzuth
Registered User
 
Join Date: May 2005
Location: Rondoland
Posts: 5,160
My Ride: gobbles oil like a B
Quote:
Originally Posted by BMWCaptain View Post
Hey Arse Fvcker, you can't say anything now because you were wrong and your Ho approach sucks.

No one cares!

Ps: FYI you said it was the nipple on the ET.
yes, i realize this. when I said "nipple" I was struggling for the proper word choice, as obviously when you think "nipple" you are not thinking about a 2-inch size plastic hole. I was referring to the male piece of plastic that shoves into the female end of the upper radiator hose. Whatever you call that.

At least OP knows what is up now because of the horrible advice I gave him
__________________
trizzuth is offline   Reply With Quote
Old 05-22-2013, 02:05 PM   #23
BMWCaptain
Registered User
 
Join Date: Sep 2011
Location: TEXAS - Where I give Real World advice and don't just criticize others. People here need to RESPECT other's opinions!
Posts: 1,682
My Ride: 03 325iT SportWagon
Quote:
Originally Posted by trizzuth View Post
yes, i realize this. when I said "nipple" I was struggling for the proper word choice, as obviously when you think "nipple" you are not thinking about a 2-inch size plastic hole. I was referring to the male piece of plastic that shoves into the female end of the upper radiator hose. Whatever you call that.

At least OP knows what is up now because of the horrible advice I gave him
Hey Fvck tard, you don't even know the difference between male or female. It is female hose connection that goes on the Exp Tank and Radiator male connection.

Yeh, it looks weird because that is just the metal clamp that goes over the hose. Maybe you havent seen a hose before.

Just give it up Arse Fvcker.

PS: you didn't give the OP any advise, rather all you did was negate the advice I had given, which was correct.
__________________
Founding Member of the Club of Dangerous Fanatics

Engine swap, HG, tranny swap, GM & ZF tranny rebuilds, shocks, struts, brakes, WPs, Thermostats, belts, tensioners, fuel pumps, radiators, window regs, hoses, PS pump, Spark Plugs, VCGs, coils, fuel filters, CVVs, VANOS seals, rack, LCABs, Exp. Tanks, OFHGs, RCABs, OP, boots, ABS, GUIDOs, starter, A/C, DISA, Diff, SAP

Ultra Premium Grand 10 Star+ Super Duper BMW-pedic Sport Plus +++

Last edited by BMWCaptain; 05-22-2013 at 02:07 PM.
BMWCaptain is offline   Reply With Quote
Old 05-22-2013, 09:20 PM   #24
mg42
Registered User
 
Join Date: Jan 2009
Location: Cape Cod
Posts: 103
My Ride: 2000 323Ci
Ok So while y'all are arguing I REALLY dont know what I am doing I just got my upper hose and coolant tonight. Going to try to replace the hose and coolant tomorrow and see what happens. Hopefully that does the trick. Any advice/pointers is greatly appreciated as I have never personally messed with the cooling system. Looking up youtube videos.

Yes the coolant spilled everywhere, went up in a cloud of coolant smoke. I replaced my water pump and expansion tank this time last year so hopefully they are functioning properly.

I got BMW coolant but does it really matter?

Last edited by mg42; 05-22-2013 at 09:40 PM.
mg42 is offline   Reply With Quote
Old 05-22-2013, 11:34 PM   #25
trizzuth
Registered User
 
Join Date: May 2005
Location: Rondoland
Posts: 5,160
My Ride: gobbles oil like a B
What part of my cooling system did I break. Thermostat housing?

To BMW captain it does not matter, which means it does matter.


Sent from BimmerApp mobile app
__________________
trizzuth is offline   Reply With Quote
Old 05-23-2013, 12:00 AM   #26
E46Snowball
Registered User
 
Join Date: Dec 2012
Location: Portland
Posts: 152
My Ride: 330i
Re: What part of my cooling system did I break. Thermostat housing?

Trololol

Sent from my Droid using BimmerApp mobile app
__________________
2003 330i
Imola Red
Zhp Package
6 speed
E46Snowball is offline   Reply With Quote
Old 05-23-2013, 04:41 PM   #27
mg42
Registered User
 
Join Date: Jan 2009
Location: Cape Cod
Posts: 103
My Ride: 2000 323Ci
So I put the new hose in + coolant. Fired her up and everything looked fine. Drove up and down the road and the needle stayed right where it should. Then I decided to drive home, got a 1/4mi down the road and the needle started creeping up again. Pulled over, let the engine cool then drove back to my friends house. Watched the temp and it stayed right where it should. So I have come to the conclusion that either my car does not want to go back home or my thermostat is broken?
mg42 is offline   Reply With Quote
Old 05-23-2013, 05:50 PM   #28
7xWDC-MSC
Registered User
 
Join Date: Jun 2012
Location: Peoples Republik of Massachusetts
Posts: 218
My Ride: 2005 325xi
Quote:
Originally Posted by mg42 View Post
So I put the new hose in + coolant. Fired her up and everything looked fine. Drove up and down the road and the needle stayed right where it should. Then I decided to drive home, got a 1/4mi down the road and the needle started creeping up again. Pulled over, let the engine cool then drove back to my friends house. Watched the temp and it stayed right where it should. So I have come to the conclusion that either my car does not want to go back home or my thermostat is broken?
If your Tstat was broken the needle would move down as you drove, you likely have air still in your system.

Check out mangos cooling thread sticky in the general E46 forum for proper bleeding.
__________________
Rubs the roundel on its skin or else it gets the hose again.
7xWDC-MSC is offline   Reply With Quote
Old 06-08-2013, 06:40 PM   #29
WOLFN8TR
OEM ///Member
 
WOLFN8TR's Avatar
 
Join Date: Jul 2011
Location: Las Vegas
Posts: 449
My Ride: 05 330CI ZHP
X2...You need to bleed the air out of the system.

WOLFN8TR is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use