E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > ///M3 Forum

///M3 Forum
The BMW E46 ///M3 is the M version E46 and puts out an amazing 333 HP and 262 lb-ft of torque at stock specs! There are an amazing amount of modifications for both the coupe and convertible models so read up and get started modifying your cars today!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-12-2013, 11:48 AM   #1
turnerg1
Registered User
 
Join Date: May 2013
Location: Acworth, Ga
Posts: 32
My Ride: 330 CI
SMG pump priming

I have a 2004 330CI SMG ( i know its not an M3 but this is where the experience is).
I have an issue where the SMG pump primes randomly. Ive searched around for what could be causing this and cant find any direct problems.
Any suggestions here?
What ive done so far-replaced the pump relay in the hood fuse box, pulled what I thought were the smg fuses in the fuse holder in glovebox (oddly pump still primed with fuse 22 out). happens doors locked, unlocked, top up or down.
The only other symptoms ive noticed are that the rearview mirror has lost its auto dimming and if I use the keyfob to lock the doors, the alarm will go off randomly too. Locking the door manually does not cause alarm to actuate.
Im kindof lost on this one. I know its the smg pump priming as its the same noise made when the car wakes like opening a door or the trunk, or using the keyfob to unlock the doors. And I was actually under the car changing the transmission fluid when it cycled and I about ate 1000lbs of car metal.
Only nothing else comes on besides the red light at the gear shift knob.
Ive been dealing with a parasitic battery drain and Im thinking this random pump prime could be the culprit.
Thoughts?

Thanks,

Greg
turnerg1 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use