E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 155 votes, 4.90 average.
Old 06-07-2013, 06:17 PM   #1541
David McMahon
Registered User
 
Join Date: Feb 2013
Location: Suffolk, UK
Posts: 1,302
My Ride: 15/Dec/98 E46 328i
Quote:
Originally Posted by e46beater View Post
Well back to square one.. PA says everything is working under settings as far as the adapter being plugged in. Plug into car, then usb to laptop... run PA soft..wait for ignition prompt... turn key on wait about 10 seconds and get no IKE or EWS connections.

plugged into the 328i and get the same thing... uninstalled driver and same issue.. both cars on 4 amp charger while attempting..
I bet you probably have but disconnect the charger and connect car as normal then try, other than that I don't know especially as your other car seems to fail PA soft too.
David McMahon is offline   Reply With Quote
Old 06-08-2013, 10:46 AM   #1542
e46beater
Registered User
 
Join Date: May 2012
Location: Overland Park KS, USA
Posts: 145
My Ride: 00 328i
Quote:
Originally Posted by David McMahon View Post
I bet you probably have but disconnect the charger and connect car as normal then try, other than that I don't know especially as your other car seems to fail PA soft too.
Trying it again today.. I'm thinking the scanner went bad
e46beater is offline   Reply With Quote
Old 06-08-2013, 02:34 PM   #1543
kwake330xi
Registered User
 
Join Date: Jul 2012
Location: Philly PA
Posts: 34
My Ride: 03 330xi
*OFFICIAL* BMW Diagnostic Scanner PA Soft 1.4 Thread

Trying to run pa soft on windows 7 32bit. I get this
Click image for larger version

Name:	ImageUploadedByBimmerApp1370720040.841556.jpg
Views:	135
Size:	189.1 KB
ID:	509971

when I plug in the cable to USB Bad cable??


Sent from BimmerApp mobile app
kwake330xi is offline   Reply With Quote
Old 06-08-2013, 02:51 PM   #1544
e46beater
Registered User
 
Join Date: May 2012
Location: Overland Park KS, USA
Posts: 145
My Ride: 00 328i
Quote:
Originally Posted by kwake330xi View Post
Trying to run pa soft on windows 7 32bit. I get this
Attachment 509971

when I plug in the cable to USB Bad cable??


Sent from BimmerApp mobile app
I gave up using anything but XP.

FYI mines working again.. its intermittent but at least its coming up again.
e46beater is offline   Reply With Quote
Old 06-08-2013, 03:20 PM   #1545
David McMahon
Registered User
 
Join Date: Feb 2013
Location: Suffolk, UK
Posts: 1,302
My Ride: 15/Dec/98 E46 328i
Quote:
Originally Posted by kwake330xi View Post
Trying to run pa soft on windows 7 32bit. I get this
Attachment 509971

when I plug in the cable to USB Bad cable??


Sent from BimmerApp mobile app
Check cable and socket, also if you can try a test build of XP, Vista or 7 (32) no need to activate, just needs chipset drivers (normally Intel or AMD) and the driver that came with the scanner.
David McMahon is offline   Reply With Quote
Old 06-08-2013, 03:21 PM   #1546
David McMahon
Registered User
 
Join Date: Feb 2013
Location: Suffolk, UK
Posts: 1,302
My Ride: 15/Dec/98 E46 328i
Quote:
Originally Posted by e46beater View Post
I gave up using anything but XP.

FYI mines working again.. its intermittent but at least its coming up again.
At least that's something, perhaps try to narrow it down some more, I would be careful using it while intermittent as you may get half way though a write
David McMahon is offline   Reply With Quote
Old 06-08-2013, 03:54 PM   #1547
kwake330xi
Registered User
 
Join Date: Jul 2012
Location: Philly PA
Posts: 34
My Ride: 03 330xi
*OFFICIAL* BMW Diagnostic Scanner PA Soft 1.4 Thread

Quote:
Originally Posted by David McMahon View Post
Check cable and socket, also if you can try a test build of XP, Vista or 7 (32) no need to activate, just needs chipset drivers (normally Intel or AMD) and the driver that came with the scanner.
Can you explain the "test build" a little more? A little over my head with this driver update, etc


Sent from BimmerApp mobile app
kwake330xi is offline   Reply With Quote
Old 06-08-2013, 04:45 PM   #1548
David McMahon
Registered User
 
Join Date: Feb 2013
Location: Suffolk, UK
Posts: 1,302
My Ride: 15/Dec/98 E46 328i
Quote:
Originally Posted by kwake330xi View Post
Can you explain the "test build" a little more? A little over my head with this driver update, etc


Sent from BimmerApp mobile app
Sorry, what I mean is to get a spare HDD and install a "test" build of XP, ie put in a temporary HDD and a temporary install of XP.

You just need enough drivers to get the cable working.

The whole point is to rule out your existing computers Software load causing the problem.

Last edited by David McMahon; 06-08-2013 at 04:45 PM.
David McMahon is offline   Reply With Quote
Old 06-15-2013, 11:03 PM   #1549
effay
Registered User
 
Join Date: Aug 2010
Location: Mississauga
Posts: 173
My Ride: 323Ci
I plan to order this on friday, is he software compatible with windows 7? I'm mainly interested in little things like my lights flash on lock and unlock, my windows roll up when x2press of lock function. and the clown nose flash when car is locked. maybe little things down the road like door locking at 30mph. but you get the idea.


I plan to order from fleabay. I just want to know if its compatible with windows 7 before I commit to buy, Thanks.
effay is offline   Reply With Quote
Old 06-15-2013, 11:03 PM   #1550
effay
Registered User
 
Join Date: Aug 2010
Location: Mississauga
Posts: 173
My Ride: 323Ci
double post.

Last edited by effay; 06-15-2013 at 11:04 PM. Reason: double post
effay is offline   Reply With Quote
Old 06-16-2013, 06:42 AM   #1551
kenhale13
Registered User
 
Join Date: Apr 2013
Location: Jersey
Posts: 8
My Ride: '02 bmw 325xi
@effay u need to do some special things to make it compatible with windows 7, it can be done, do some more searching first cause i dont remember off hand, it involved manually installing the driver i do remember that.
kenhale13 is offline   Reply With Quote
Old 06-16-2013, 08:55 AM   #1552
Big Rick
Registered User
 
Join Date: Nov 2011
Location: Maryland - Land of Taxes!
Posts: 1,410
My Ride: 325Xi
I have installed this on numerous laptop builds of both XP and W7 with only one issue... I messed up the first time I installed it! I wasn't paying attention to the fact that you CANNOT be connected to a Wi-Fi network when it is installed. I had to delete the installation and then reinstall it with the Wi-Fi turned off. When I did that... No issues.
__________________
NWS and Advertising Removed.
Big Rick is offline   Reply With Quote
Old 06-16-2013, 01:20 PM   #1553
megraham
Registered User
 
Join Date: Mar 2013
Location: Ankeny, Iowa
Posts: 14
My Ride: 2001 BMW 325i
Just got my scanner yesterday. Got it to work with windows 7 64 bit and had a few errors. Does anyone see any major problems with the data?

I found very good instructions on getting it to work with windows 7 and took me about 45 minutes but works great. Now I just have to make some changes once I figure it all out.


# ERRORS IN UNITS
---------------------------------------------------------------------------------------------------------------------------
Unit BMWTNR HW SW-FSW ERRORS / SHADOW-MEMORY
---------------------------------------------------------------------------------------------------------------------------
EWS -> 6.905.670 03 08 2 errors
ABS* -> 6.750.364 04 0.0.0 3 errors
LEW -> 6.760.232 04 04 2 errors
A/C -> 6.914.009 24 06 1 error
SRS -> 6.905.491 01 06 no errors
IKE -> 6.906.897 10 20 1 error
LCM -> 6.907.950 10 20 no errors / 10 errors
ZKE -> 6.907.663 11 16 4 errors / 2 errors
MFL -> 0.000.000 01 09 no data
RAD -> 6.909.882 32 11 no errors
SZM -> 6.911.667 01 02 no errors / no errors
SHD -> 3.852.379 05 27 no errors
SPMFT -> 8.386.427 02 01 1 error / 3 errors
SPMBT -> 6.913.364 02 02 no errors / 3 errors
SMF -> 8.263.133 07 0B no errors


# ERRORS DETAILS - DTC(hex)/PARAM(hex)
---------------------------------------------------------------------------------------------------------------------------
EWS -> 33/05 - Toleration of changing code increased, key 3
0F/3F - Power on reset

ABS* -> 5E43/C0 - Steering angle sensor internal.
5DF4/40 - Vehicle power < 9 Volt.
5E1A/C0 - CAN DME/DDE Signal Error.

LEW -> 09/79 - No CAN message (ASC)
04/21 - 90 degrees difference of wiper too large (Adjustment operation)

A/C -> 1C/04 - AUC sensor

IKE -> D7/81 - Tank sensor 2

LCM -> Shadow-memory:
34/11 - Brake light, left
35/03 - Brake light, right
36/04 - Turn indicator, front left
37/11 - Turn indicator, front right
3B/02 - Sidelight, rear left
3D/01 - Sidelight, rear right
3F/1F - Turn indicator, rear left
40/04 - Turn indicator, rear right
41/03 - Low beam, right
42/02 - Low beam, left

ZKE -> 27/3F - Central locking system Relay Locking Driver's door: Contact for opening has open circuit or Contact for closing is sticking
3D/01 - Central locking system: Short circuit or Open circuit at Motor Tailgate
38/02 - Wiper: Pump for Window washing or Container is empty
0A/01 - Power window: Open circuit Motor or Relay Passenger door
Shadow-memory:
90/23 - Battery Voltage: Open circuit
95/02 - Repeat blocking: Power window

SPMFT -> 04/01 - Mirror-moving-switch, interruption
Shadow-memory:
00/01 - Low voltage ( U < 8,5 Volt )
02/8B - Low voltage mirror-heating
04/01 - Mirror drive, potentiometer plausibility

SPMBT -> Shadow-memory:
00/01 - Low voltage ( U < 8,5 Volt )
02/61 - Low voltage mirror-heating
04/01 - Mirror drive, potentiometer plausibility


# SCAN END



The LCM is showing a lot of light issues but all of them work. What exactly is shadow memory that is listed?

Last edited by megraham; 06-16-2013 at 01:23 PM.
megraham is offline   Reply With Quote
Old 06-16-2013, 02:58 PM   #1554
David McMahon
Registered User
 
Join Date: Feb 2013
Location: Suffolk, UK
Posts: 1,302
My Ride: 15/Dec/98 E46 328i
never mind

Last edited by David McMahon; 06-16-2013 at 08:03 PM.
David McMahon is offline   Reply With Quote
Old 06-16-2013, 05:43 PM   #1555
Big Rick
Registered User
 
Join Date: Nov 2011
Location: Maryland - Land of Taxes!
Posts: 1,410
My Ride: 325Xi
The way it was explained to me was that the shadow memory items are things that wouldn't be picked up by a regular BMW shop scan. The PA Soft scanner picks them up though... I wouldn't worry about shadow memory.
__________________
NWS and Advertising Removed.
Big Rick is offline   Reply With Quote
Old 06-16-2013, 06:19 PM   #1556
ac_2007
Registered User
 
ac_2007's Avatar
 
Join Date: Apr 2010
Location: Toronto
Posts: 6,881
My Ride: 2004 M3, 2001 325i
Quote:
Originally Posted by David McMahon View Post
Shadow memories are old errors that have not, or cannot be cleared from the system, I would note all of these Errors down (you have here!) and clear them, the ones that come back are the ones to look at, but keep the old ones as history.

Indeed I believe BMW has shadow memories to maintain a history of the car.
You're making things up.

Shadow codes are errors which have been registered at one point, but are not currently active. There are also a small portion of engineering codes which cannot be cleared because they don't apply to your car.

Ex.) Exhaust flap solenoid shadow code can't be cleared on my car because I don't have one.
ac_2007 is offline   Reply With Quote
Old 06-16-2013, 08:07 PM   #1557
David McMahon
Registered User
 
Join Date: Feb 2013
Location: Suffolk, UK
Posts: 1,302
My Ride: 15/Dec/98 E46 328i
Quote:
Originally Posted by Stiggles View Post
You're making things up.
Information was correct, best of my knowledge and after reading on this forum.

Trust me, I'd never "make up" something on a car forum, but if I did it would be something along the lines of "omg look at my new M3"
David McMahon is offline   Reply With Quote
Old 06-16-2013, 08:14 PM   #1558
effay
Registered User
 
Join Date: Aug 2010
Location: Mississauga
Posts: 173
My Ride: 323Ci
Quote:
Originally Posted by kenhale13 View Post
@effay u need to do some special things to make it compatible with windows 7, it can be done, do some more searching first cause i dont remember off hand, it involved manually installing the driver i do remember that.
Quote:
Originally Posted by Big Rick View Post
I have installed this on numerous laptop builds of both XP and W7 with only one issue... I messed up the first time I installed it! I wasn't paying attention to the fact that you CANNOT be connected to a Wi-Fi network when it is installed. I had to delete the installation and then reinstall it with the Wi-Fi turned off. When I did that... No issues.
Thank you Kenhale, my laptop has windows 7 only so I was hoping it would work!

and bigrick when your using PA soft after you install you must have WIFI on though right|?
effay is offline   Reply With Quote
Old 06-16-2013, 09:46 PM   #1559
ac_2007
Registered User
 
ac_2007's Avatar
 
Join Date: Apr 2010
Location: Toronto
Posts: 6,881
My Ride: 2004 M3, 2001 325i
Quote:
Originally Posted by David McMahon View Post
Information was correct, best of my knowledge and after reading on this forum.

Trust me, I'd never "make up" something on a car forum, but if I did it would be something along the lines of "omg look at my new M3"
I misread your wording, my mistake.

Shadow (yellow) codes which come back after clearing all codes are engineering codes. Active (red) codes cannot be cleared until the problem is fixed, such as the airbag.
ac_2007 is offline   Reply With Quote
Old 06-16-2013, 09:56 PM   #1560
David McMahon
Registered User
 
Join Date: Feb 2013
Location: Suffolk, UK
Posts: 1,302
My Ride: 15/Dec/98 E46 328i
Quote:
Originally Posted by Stiggles View Post
I misread your wording, my mistake.

Shadow (yellow) codes which come back after clearing all codes are engineering codes. Active (red) codes cannot be cleared until the problem is fixed, such as the airbag.
I'm going to have a look again tomorrow, fantastic tool.
David McMahon is offline   Reply With Quote
Reply

Tags
bmw scanner, diagnostic tool, error message, pa soft

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use