E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 21 votes, 5.00 average.
Old 06-22-2013, 03:13 AM   #181
esberelias
Registered User
 
Join Date: Dec 2012
Location: Edmonton, AB
Posts: 253
My Ride: '03 325i
Quote:
Originally Posted by knightrider5000 View Post
Just got a bmw 323i so my first upgrade was this D5150 nav system. I hope it works out good for me. I wish someone sold the sd cards preprogramed with igo with us maps so I don't have to figure it out myself. We need a vide from start to finish on how to install everything correctly so many bugs needed to be worked out.
you download it... copy it over to an SD card.... not rocket science dude

Gimme $50 bucks, I'll do it for ya! lol
__________________

Check out my ride

Last edited by esberelias; 06-22-2013 at 03:13 AM.
esberelias is offline   Reply With Quote
Old 06-22-2013, 03:17 AM   #182
knightrider5000
Registered User
 
Join Date: Jun 2013
Location: los gatos, ca
Posts: 62
My Ride: 1999 BMW 323i 4 door
Send a message via Yahoo to knightrider5000
Hey for some of us, its complicated. 1 I dont have a micro Sd reader. And theres so many Igo versions out there, which is the best. And which one is needed to run with the 5150 unit.
knightrider5000 is offline   Reply With Quote
Old 06-22-2013, 03:23 AM   #183
knightrider5000
Registered User
 
Join Date: Jun 2013
Location: los gatos, ca
Posts: 62
My Ride: 1999 BMW 323i 4 door
Send a message via Yahoo to knightrider5000
BTW guys, I ordered my 5150 with backup cam 2 days ago, got a call from fed ex, they will not send me my items, cause they only did an FCC paperwork for the LCD display and not the cam. So fed ex must of opened my box cause how did they know it had a cam inside to, and they say the invoice is missing off the box. So I email them and no reply yet to send fed ex the fcc papers for customs, kinda a drag, as I am anxious to install it. Should of had it already. Well fed ex said if they dont get the paperwork in 3 days it goes back to the supplier in hong kong.
knightrider5000 is offline   Reply With Quote
Old 06-22-2013, 06:59 AM   #184
Scooby24
Registered User
 
Join Date: Dec 2007
Location: Overland Park, KS
Posts: 371
My Ride: '03 330i ZHP Sedan
Quote:
Originally Posted by esberelias View Post
I just read on bimmerforums a user right a post that reads "I wired in a DEI 528T relay between the head unit and the CanBus. It has an adjustable timer from 0-60 seconds. Now the CanBus powers up after the unit keeping the unit as it was set on power down. Cheap fix for keeping your wheel controls."

I've PM'd him, and he's gotten to me since.. He will eventually write a DIY and once I have that I'll link it to you here...
Definitely let us know what you find out!
__________________
Scooby24 is offline   Reply With Quote
Old 06-22-2013, 07:09 AM   #185
Scooby24
Registered User
 
Join Date: Dec 2007
Location: Overland Park, KS
Posts: 371
My Ride: '03 330i ZHP Sedan
You guys gotten any errors with the igo maps? It was too big for the card they sent so I installed it on an old 8gb card. Noticed when copying transfer times would randomly slow down to a crawl so I'm hoping its just a card issue. Error said something about a component not able to be opened and then crashed.
__________________
Scooby24 is offline   Reply With Quote
Old 06-22-2013, 09:04 AM   #186
tnhl1989
Registered User
 
Join Date: Jan 2010
Location: Hadley, MA
Posts: 451
My Ride: 02 330xi(RIP),03 ZHP
Send a message via Skype™ to tnhl1989
Just ordered a Eonon D5150! (New version of Eonon D5113/Enco B146)

I'll be down to put the GPS program onto a sd for anyone. $50.00


Sent from BimmerApp mobile app
tnhl1989 is online now   Reply With Quote
Old 06-22-2013, 09:45 AM   #187
dopey88
Registered User
 
Join Date: Dec 2011
Location: Alberta
Posts: 26
My Ride: e46 323i, e90 325i
Just ordered a Eonon D5150! (New version of Eonon D5113/Enco B146)

I will do it for $49.99 ! Best price !!!lol


Sent from BimmerApp mobile app
dopey88 is offline   Reply With Quote
Old 06-22-2013, 10:01 AM   #188
esberelias
Registered User
 
Join Date: Dec 2012
Location: Edmonton, AB
Posts: 253
My Ride: '03 325i
Quote:
Originally Posted by Scooby24 View Post
You guys gotten any errors with the igo maps? It was too big for the card they sent so I installed it on an old 8gb card. Noticed when copying transfer times would randomly slow down to a crawl so I'm hoping its just a card issue. Error said something about a component not able to be opened and then crashed.
yes it is a card issue... I had a class 4 card before and it used to take like 40 seconds to boot... transferred over to a Class 10 sixteen gigabyte SD Card and now it loads within 10 seconds
__________________

Check out my ride
esberelias is offline   Reply With Quote
Old 06-22-2013, 10:03 AM   #189
esberelias
Registered User
 
Join Date: Dec 2012
Location: Edmonton, AB
Posts: 253
My Ride: '03 325i
Quote:
Originally Posted by dopey88 View Post
I will do it for $49.99 ! Best price !!!lol


Sent from BimmerApp mobile app
you maybe cheaper... but I offer warranty with customer support
__________________

Check out my ride
esberelias is offline   Reply With Quote
Old 06-22-2013, 10:06 AM   #190
esberelias
Registered User
 
Join Date: Dec 2012
Location: Edmonton, AB
Posts: 253
My Ride: '03 325i
Quote:
Originally Posted by knightrider5000 View Post
Hey for some of us, its complicated. 1 I dont have a micro Sd reader. And theres so many Igo versions out there, which is the best. And which one is needed to run with the 5150 unit.
I'm being totally honest right now... I've bought my SD card reader from the dollar store lol even if you buy a multi card reader from walmart or computer hardware store... you wont pay more than $10 bucks

an SD Card (I recommend a 16gigabyte card that is CLASS 10!!) that will run you like $19 bucks if you shop around

on previous pages if you go back and read the thread... a guy already posted links to the Igo program, the maps..... there are tons of GPS forums out there...
__________________

Check out my ride
esberelias is offline   Reply With Quote
Old 06-22-2013, 10:56 AM   #191
Scooby24
Registered User
 
Join Date: Dec 2007
Location: Overland Park, KS
Posts: 371
My Ride: '03 330i ZHP Sedan
Quote:
Originally Posted by esberelias View Post
yes it is a card issue... I had a class 4 card before and it used to take like 40 seconds to boot... transferred over to a Class 10 sixteen gigabyte SD Card and now it loads within 10 seconds
Sweet, I just bought a cheap 8gb class 10 card, loading iGo on it now.
__________________
Scooby24 is offline   Reply With Quote
Old 06-22-2013, 11:13 AM   #192
limpiabota809
Registered User
 
Join Date: Oct 2012
Location: NYC
Posts: 1,181
My Ride: 330 XI
Quote:
Originally Posted by esberelias View Post
I just read on bimmerforums a user right a post that reads "I wired in a DEI 528T relay between the head unit and the CanBus. It has an adjustable timer from 0-60 seconds. Now the CanBus powers up after the unit keeping the unit as it was set on power down. Cheap fix for keeping your wheel controls."

I've PM'd him, and he's gotten to me since.. He will eventually write a DIY and once I have that I'll link it to you here...
Any news on this though?
__________________
Instagram - @Limpiabota_e46
limpiabota809 is offline   Reply With Quote
Old 06-22-2013, 03:52 PM   #193
asdetail
Registered User
 
Join Date: Dec 2012
Location: brisbane australia
Posts: 270
My Ride: 2002 325ci coupe
Quote:
Originally Posted by knightrider5000 View Post
Just got a bmw 323i so my first upgrade was this D5150 nav system. I hope it works out good for me. I wish someone sold the sd cards preprogramed with igo with us maps so I don't have to figure it out myself. We need a vide from start to finish on how to install everything correctly so many bugs needed to be worked out.
full copy of igo primo with north American maps available as a torrent file out there,want to know where?,aaaarrgh me hearteys!,shiver me timbers!, there is a clue for you!
asdetail is offline   Reply With Quote
Old 06-22-2013, 07:20 PM   #194
esberelias
Registered User
 
Join Date: Dec 2012
Location: Edmonton, AB
Posts: 253
My Ride: '03 325i
Quote:
Originally Posted by limpiabota809 View Post
Any news on this though?
no not yet... hasn't been active on the forums either :S
__________________

Check out my ride
esberelias is offline   Reply With Quote
Old 06-22-2013, 07:20 PM   #195
E46AUS
Registered User
 
Join Date: Jun 2013
Location: Melbourne Australia
Posts: 8
My Ride: 2004 325Ci
Replacing OEM TV / BT unit w/ no GPS. Tips needed.

Hi team. I took the plunge based on this excellent thread and bought both the D5150 and the V0018 DTV units. Great pricing and features!

I have a few quick questions that might help me and others with the install if you guys may have some ideas. My 2004 325Ci RHD came from the factory with the in 2 DIN dash OEM screen with TV / Bluetooth, 6 CD stacker in the boot, but no sat nav.

1. Since I don't have a GPS unit in the trunk and don't have the HK system, do I need this long cable to connect to anything in the trunk? (I'm guessing not).

2. Since I have the OEM BT microphone already installed, can I make that work as the external mic for this Eonon D5150?

3. I already have the OEM TV aerial setup from the factory and works fine on OEM analogue TV. Does anyone know if this can be used for the V0018 DTV add on for the 5150?

4. Snce my car came with the OEM TV screen but no GPS unit, is there a chance my car has an OEM GPS antenna factory installed I can plug into the D5150? (wishful thinking I know).

Cheers in advance all for any tips, can't wait for this bad boy to arrive and will post any bugs or fixes I find along the way!

Last edited by E46AUS; 06-22-2013 at 08:47 PM.
E46AUS is offline   Reply With Quote
Old 06-22-2013, 10:33 PM   #196
asdetail
Registered User
 
Join Date: Dec 2012
Location: brisbane australia
Posts: 270
My Ride: 2002 325ci coupe
Quote:
Originally Posted by E46AUS View Post
Hi team. I took the plunge based on this excellent thread and bought both the D5150 and the V0018 DTV units. Great pricing and features!

I have a few quick questions that might help me and others with the install if you guys may have some ideas. My 2004 325Ci RHD came from the factory with the in 2 DIN dash OEM screen with TV / Bluetooth, 6 CD stacker in the boot, but no sat nav.

1. Since I don't have a GPS unit in the trunk and don't have the HK system, do I need this long cable to connect to anything in the trunk? (I'm guessing not).

2. Since I have the OEM BT microphone already installed, can I make that work as the external mic for this Eonon D5150?

3. I already have the OEM TV aerial setup from the factory and works fine on OEM analogue TV. Does anyone know if this can be used for the V0018 DTV add on for the 5150?

4. Snce my car came with the OEM TV screen but no GPS unit, is there a chance my car has an OEM GPS antenna factory installed I can plug into the D5150? (wishful thinking I know).

Cheers in advance all for any tips, can't wait for this bad boy to arrive and will post any bugs or fixes I find along the way!
1: yes you do
2: not without surgery on the unit
3:no
4:no
how do I know?,had the same setup in my car,found out the hard way.

Last edited by asdetail; 06-22-2013 at 10:35 PM.
asdetail is offline   Reply With Quote
Old 06-23-2013, 02:24 AM   #197
E46AUS
Registered User
 
Join Date: Jun 2013
Location: Melbourne Australia
Posts: 8
My Ride: 2004 325Ci
Quote:
Originally Posted by asdetail View Post
1: yes you do
2: not without surgery on the unit
3:no
4:no
how do I know?,had the same setup in my car,found out the hard way.
Hey thanks for the prompt and definitive feedback given you had the same setup.

Just for my interest, why do I need the long cable if I only have the CD changer in the trunk?

And why won't the TV antenna work? Is it a connector thing or something more complex?

Last edited by E46AUS; 06-23-2013 at 02:26 AM.
E46AUS is offline   Reply With Quote
Old 06-23-2013, 08:03 AM   #198
limpiabota809
Registered User
 
Join Date: Oct 2012
Location: NYC
Posts: 1,181
My Ride: 330 XI
Quote:
Originally Posted by knightrider5000 View Post
Just got a bmw 323i so my first upgrade was this D5150 nav system. I hope it works out good for me. I wish someone sold the sd cards preprogramed with igo with us maps so I don't have to figure it out myself. We need a vide from start to finish on how to install everything correctly so many bugs needed to be worked out.
http://lmgtfy.com/?q=igo%20primo%20w...merican%20maps
__________________
Instagram - @Limpiabota_e46
limpiabota809 is offline   Reply With Quote
Old 06-23-2013, 09:21 PM   #199
javanutsy
Registered User
 
Join Date: Dec 2005
Location: SoCal
Posts: 44
My Ride: 04 330Ci 6SP ZSP ZPP
Just ordered one... Great informative thread. Birthday gift for my 10 year old car
__________________
javanutsy is offline   Reply With Quote
Old 06-23-2013, 10:26 PM   #200
asdetail
Registered User
 
Join Date: Dec 2012
Location: brisbane australia
Posts: 270
My Ride: 2002 325ci coupe
Quote:
Originally Posted by E46AUS View Post
Hey thanks for the prompt and definitive feedback given you had the same setup.

Quote:
Just for my interest, why do I need the long cable if I only have the CD changer in the trunk?

And why won't the TV antenna work? Is it a connector thing or something more complex?
you need it because all the hardware that makes it work is in the trunk,only the display is in the dash.
you would need to extend the tv antenna cable from the trunk to the dash,and then no guarantees it would work properly with the eonon tv box,far easier to use the supplied antennae with the box.
asdetail is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use