E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-29-2013, 08:05 AM   #1
Monte330i
Registered User
 
Join Date: Aug 2010
Location: Calabash
Posts: 144
My Ride: 01 330i
Little help! Embarrassed to drive my e46... Pic inside.

Hey all. This is how my car looks in the evening:

Not so bad but notice that the right turn signal is on. It doesnt blink. It just stays on constantly if the headlights or parking lights are on. If the headlights and parking light are off then the signal operates normally. All bulbs are good and I have excluded the tail lights as the problem.
When the parking lights are off and I turn on the right turn signal I have noticed that the signal works fine but the amber backlighting in the dash blinks along with the green right signal arrow on the dash.

I obviously have a short circut that is connecting the right turn signal to whatever power wire that operates the parking lights. I figure its either in the LCM or in the stalk itself or in the wire loom. Any suggestions?
Anyone in the NC/SC beach area willing to let me test with thier LCM?
Where can i find a color code for the wires going to the tail light harness?
Is the LCM servicable?
Any help is appreciated. This problem is gonna get dangerous at night as the rear signal stays like this and wont blink for right turns. Front and side marker operates normal under all conditions. Help!
__________________
Monte330i is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 06-29-2013, 08:15 AM   #2
Lionelski
Registered User
 
Join Date: Jun 2004
Location: Long Island, NY
Posts: 1,164
My Ride: 325CIc
Fog light option?
__________________
'Ski
www.WarrenvilleRailroad.com
2001 325ci Convertible - Titanium Silver

Sport Package, Premium Package
Racing Dynamics Strut Tower Brace
Conforti Shark Injector, Conforti CAI
Interior: Leather, Euro Tray, M3 Dead Pedal
Lionelski is offline   Reply With Quote
Old 06-29-2013, 08:16 AM   #3
mjpgolf1
Registered User
 
Join Date: Mar 2013
Location: Cleveland Oh
Posts: 1,712
My Ride: 00 328i ZSP,05 745LI
Little help! Embarrassed to drive my e46... Pic inside.

Dont take this the wrong way but It looks like you are running cheap aftermarket led tail lights. If you still have your factory lights I would hook them up and see if the problem is in your cars wiring or the aftermarket tails. Just a suggestion to try to pinpoint the problem and eliminate the actual lights as being the issue. Good luck.


Sent from BimmerApp mobile app
mjpgolf1 is offline   Reply With Quote
Old 06-29-2013, 08:50 AM   #4
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 10,024
My Ride: '06 330CiC, '03 M5
OE LED tail lights did not come out much later, after facelift.

So you do have aftermarket tail lights and there may be a wiring or controller problem??
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temps, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose fan switch O-ring - BMW #13621743299
jfoj is offline   Reply With Quote
Old 06-29-2013, 08:52 AM   #5
Monte330i
Registered User
 
Join Date: Aug 2010
Location: Calabash
Posts: 144
My Ride: 01 330i
Fog lights operate normal and dont seem to factor into my problems. Tail lights are decent quaility and have been swapped from side to side and swapped back to my OEM incandecent bulb taillights with no difference in the problem. I am positive the problem is before the harness to the tail lights. Im leaning towards the LCM. Thanks in advance guys!
__________________

Last edited by Monte330i; 06-29-2013 at 08:54 AM.
Monte330i is offline   Reply With Quote
Old 06-29-2013, 09:14 AM   #6
2003 325i
Registered User
 
Join Date: Mar 2009
Location: New Hamburg, Ontario, Canada
Posts: 1,636
My Ride: '03 Orient Blue 325i
Trying to remember... ground wire recall for tail lights?? Forget how they acted up... was a couple years ago when I had the issue.
__________________
Quote:
Originally Posted by MTA330ci View Post
Does anyone have a recommendation on which is the best high performance valve stems?
2003 325i is offline   Reply With Quote
Old 06-29-2013, 10:47 AM   #7
Monte330i
Registered User
 
Join Date: Aug 2010
Location: Calabash
Posts: 144
My Ride: 01 330i
Does anyone have the pinout code for the harness?

Im about to remove the lcm and try to clean it and check the connections.

I wish some fanatics lived around here...
__________________
Monte330i is offline   Reply With Quote
Old 06-29-2013, 12:06 PM   #8
iRide113
Registered User
 
Join Date: Mar 2013
Location: Cali | Vegas
Posts: 371
My Ride: 2004 325i
You're embarrassed to drive it because of that? Wow, imagine if your car had a scratch or one of your Angle Eyes were out!
iRide113 is offline   Reply With Quote
Old 06-29-2013, 12:26 PM   #9
Alex323Ci
Registered User
 
Join Date: Jan 2005
Location: Huntington Beach -Surf City USA
Posts: 16,988
My Ride: M3 & 323Ci (sold)
Quote:
Originally Posted by jfoj View Post
OE LED tail lights did not come out much later, after facelift.

So you do have aftermarket tail lights and there may be a wiring or controller problem??
well obviously he has aftermarket LED tail lamps, bmw never made E46 sedan LED tails.

OP I would try swapping out from side to side to see if its that right side LED lamp or that right side wiring.
__________________
OE CSL WHEELS - OE CSL BRAKES - OE AUTOFLD MIRRORS - CSL TRUNK - CSL DIFFUSER - AA TUNE - AA PULLEYS - AS 40% SSK - BILSTEIN PSS9s
CF CSL LIP - NAVI - BMWPERF CF STRUT BAR - BMW GROUP N MNTS - GRUPPE M CF INTAKE - SUPERSPRINT - UUC BRKLINES, TRANS, RTABs - H&R SWAYS - 4.10 M-SPORT DIFF
Alex323Ci is offline   Reply With Quote
Old 06-29-2013, 12:46 PM   #10
3coupe
Registered User
 
Join Date: Nov 2007
Location: CA
Posts: 291
My Ride: 330Ci
Quote:
Originally Posted by Monte330i View Post
Fog lights operate normal and dont seem to factor into my problems. Tail lights are decent quaility and have been swapped from side to side and swapped back to my OEM incandecent bulb taillights with no difference in the problem. I am positive the problem is before the harness to the tail lights. Im leaning towards the LCM. Thanks in advance guys!
When You say no difference when you swapped, do you mean the right side was always on or the right tail light?

My guess is the wire for the turn signal and tail lights is touching somewhere. I'm not too familiar with the wiring in the e46, but the backlight blinking when the turn signal is activated seems like a clear sign that the power between the two are crossing somewhere. I would check the connectors and harness in the trunk first.

For wiring check out this site http://www.bmw-planet.com/diagrams/

The info you'll need is under components and signal information->components->E47

Last edited by 3coupe; 06-29-2013 at 01:18 PM.
3coupe is offline   Reply With Quote
Old 06-29-2013, 05:19 PM   #11
Monte330i
Registered User
 
Join Date: Aug 2010
Location: Calabash
Posts: 144
My Ride: 01 330i
yeah i switched the lamps and tried my old oems and the problem was always on the right side of the car . Im going to search the wiring diagrams and try to locate the crossed wires. I found a lcm for $55 but it has a position for autolights. my 2001 doesnt have the feature but i wonder if the harness will still plug in and work?
__________________
Monte330i is offline   Reply With Quote
Old 06-29-2013, 08:35 PM   #12
Snik
OEM ///Member
 
Snik's Avatar
 
Join Date: Dec 2007
Location: Around SJ AFB, NC
Posts: 20,686
My Ride: IR M3 Vert.
Little help! Embarrassed to drive my e46... Pic inside.

Lol@ all those knocking aftermarket LED tails. :smh:
The problem is likely the wiring where it enters the trunk.
That bend you see by the trunk hinge on the side. Remove the cover. Bet, those wires are damaged. Common on verts. Sometimes others. Check for ruptured wires. I'm told the best fix is to cut out broken wire. Replace with fresh wire. Solder. Cover. Then recover the loom.



Sent from BimmerApp mobile app
__________________
Quote:
Originally Posted by rohde88 View Post
^^^ do you spend all your free time on two wheels?
______________________________________
The Snikster posted sexy wiminz here
Do you ride a sportbike?
Do you have a question about Jamaica? Ask?
Snik is offline   Reply With Quote
Old 06-29-2013, 08:53 PM   #13
TnT817
Registered User
 
Join Date: Oct 2012
Location: Dayton, Ohio
Posts: 220
My Ride: 01 330ci
Little help! Embarrassed to drive my e46... Pic inside.

There should be a ground right by the tail light. Loosen that up then put a little dielectric grease on it and tighten it back down. Had a similar issue with mine.


Sent from BimmerApp mobile app
__________________
TnT817 is offline   Reply With Quote
Old 06-29-2013, 09:05 PM   #14
JS330
Registered User
 
Join Date: Aug 2010
Location: Melbourne
Posts: 1,107
My Ride: '01 330Ci 3 Pedals
if its coming on with the interior lights, id be willing to bet that there is a frayed or burnt connection in the lcm or behind it where the rear right indicator is coming into physical contact with a 12v live wire in thats connected to the interior dash lights
__________________
Quote:
Originally Posted by DeclanM3 View Post
I hope he isn't using Pirelli condoms..
JS330 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use