E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 07-12-2013, 03:16 PM   #1
id3550
Registered User
 
Join Date: May 2013
Location: Bay Area, California
Posts: 287
My Ride: 01 325xiT, 95 M3
Stock spring binding?

I recently repaired my strut tower using the 2x4 and reinforcement plate method and it worked like a charm. While I was there I replaced all struts/shocks as I was sure the damaged strut tower probably belt the strut too somewhere, there was somewhere in the neighborhood of 3 degrees of negative chamber. The old perches and pads were used; there was no apparent damage to any of them. The new Bilstien HD's show no sign of damage during shipping and rebounded normally

The issue I'm having only affects the repaired strut tower. It squeaks whenever it's compressed and feels stiffer than the other side. I've had someone compress that side and noticed a good amount of vibration coming from the spring. I've take the assembly off a few times and checked the inside of the tower and there doesn't seem to be any rubbing. The spring and pads were put in the right way and perches mounted properly and aren't rubbing the strut piston.

Could it be possible that the spring was damaged in a way that's not apparent in a visual inspection that would cause this? Everything was fine up until the repair. Everything attached to the suspension is torqued properly and the ride height is normal.

Anyone have any ideas? I'm at a loss.
id3550 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use