E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 6 votes, 5.00 average. Display Modes
Old 06-02-2013, 07:26 AM   #181
Hornung418
Registered User
 
Join Date: Dec 2010
Location: Bel Air, MD/ WVU
Posts: 1,013
My Ride: '04 MB ZHP
Re: MS42 < MS43 Compatibility Thread...

Still waiting on the parts pull to find an e46...

In other news, if I can figure out how to remove the chip in the DME, put it into a programmer and virginize the data, its possible to have it synch with the EWS, hopefully starting the car.

Sent from BimmerApp mobile app
__________________
Hornung418 is offline   Reply With Quote
Old 06-02-2013, 01:32 PM   #182
TerraPhantm
Registered User
 
Join Date: Feb 2008
Location: Mountain Top
Posts: 5,942
My Ride: 2005 M3 Coupe
I'm somewhat tempted to buy a programmer... If I do I'll let you know. The soldering is easy enough

Last edited by TerraPhantm; 06-02-2013 at 01:35 PM.
TerraPhantm is offline   Reply With Quote
Old 06-02-2013, 01:45 PM   #183
daniel_f.
Registered User
 
Join Date: Jul 2011
Location: Germany
Posts: 547
My Ride: 330iCA
Why soldering when there are clips ;-) Hope to get mine this week
__________________
kind regards
Daniel

daniel_f. is online now   Reply With Quote
Old 06-02-2013, 10:02 PM   #184
TerraPhantm
Registered User
 
Join Date: Feb 2008
Location: Mountain Top
Posts: 5,942
My Ride: 2005 M3 Coupe
Quote:
Originally Posted by daniel_f. View Post
Why soldering when there are clips ;-) Hope to get mine this week
By clips do you mean sockets? I don't like those because they're not stable under driving conditions. The SO-44 pin pitch isn't hard to solder, takes only a few minutes by hand. So why not?
TerraPhantm is offline   Reply With Quote
Old 06-03-2013, 10:22 AM   #185
daniel_f.
Registered User
 
Join Date: Jul 2011
Location: Germany
Posts: 547
My Ride: 330iCA
Shure its possible to unsolder and solder it, but theres always a risk of brick and thats exactly why i will not unsolder the Alpina EGS.

IŽll what for this little cuty

__________________
kind regards
Daniel

daniel_f. is online now   Reply With Quote
Old 06-03-2013, 12:11 PM   #186
TerraPhantm
Registered User
 
Join Date: Feb 2008
Location: Mountain Top
Posts: 5,942
My Ride: 2005 M3 Coupe
Oh those. Well for my own purposes they're not particularly helpful -- I have to replace EEPROMs on my MSS52 anyway since I want to convert it into an MSS54HP, and I can just BDM into it when I need to clear the flash counter. If I were regularly flashing / virginizing ECUs for profit, then perhaps it'd be useful. But I'm confident enough in my soldering skills that I can do it as a favor without breaking anything. I've done enough SO-44 chips that I'm not terribly worried.

Though I do see mouser has 1 in stock.. maybe I'll just order it since they seem to be back ordered everywhere else.
TerraPhantm is offline   Reply With Quote
Old 06-03-2013, 04:45 PM   #187
Hornung418
Registered User
 
Join Date: Dec 2010
Location: Bel Air, MD/ WVU
Posts: 1,013
My Ride: '04 MB ZHP
Re: MS42 < MS43 Compatibility Thread...

Interesting stuff.

No luck at the yards for a spare MS43. Everything seems to be MS42 or earlier. Plenty of 528 e39s and 328 e36s...

Sent from my SCH-I535 using BimmerApp mobile app
__________________
Hornung418 is offline   Reply With Quote
Old 06-26-2013, 09:12 AM   #188
Hornung418
Registered User
 
Join Date: Dec 2010
Location: Bel Air, MD/ WVU
Posts: 1,013
My Ride: '04 MB ZHP
Re: MS42 < MS43 Compatibility Thread...

Talking to Zach from RPM Motorsport. Hoping to get them to align the DME and EWS. They wilk also buy the matching MS42 set from me to offset the cost.

Looking to be driving again after the 14th of July.

Sent from BimmerApp mobile app
__________________

Last edited by Hornung418; 06-26-2013 at 09:18 AM.
Hornung418 is offline   Reply With Quote
Old 06-29-2013, 03:19 AM   #189
TerraPhantm
Registered User
 
Join Date: Feb 2008
Location: Mountain Top
Posts: 5,942
My Ride: 2005 M3 Coupe
Shame how this ended up. At least you should end up with a working car
TerraPhantm is offline   Reply With Quote
Old 07-01-2013, 01:00 PM   #190
Hornung418
Registered User
 
Join Date: Dec 2010
Location: Bel Air, MD/ WVU
Posts: 1,013
My Ride: '04 MB ZHP
Re: MS42 < MS43 Compatibility Thread...

Yep...purchasing the stuff tonight. Tomorrow I ship it out and it should be waiting by the time I get back from vacation. Then the car is going to the shop for its suspension refresh and hopefully its ready before bimmerfest!

Sent from BimmerApp mobile app
__________________
Hornung418 is offline   Reply With Quote
Old 07-04-2013, 09:31 AM   #191
Hornung418
Registered User
 
Join Date: Dec 2010
Location: Bel Air, MD/ WVU
Posts: 1,013
My Ride: '04 MB ZHP
Re: MS42 < MS43 Compatibility Thread...

Headed down south for 10 days.

Jack.chris came to the rescue and sent me a PM regarding a 2002 325I that has everything that I need. Going to be sending the parts back to Bavarian Motorhaus when I get back.

Looking like I will make it to bimmerfest east this year after all even if it is my backyard lol.

Sent from BimmerApp mobile app
__________________
Hornung418 is offline   Reply With Quote
Old 07-06-2013, 02:48 AM   #192
TerraPhantm
Registered User
 
Join Date: Feb 2008
Location: Mountain Top
Posts: 5,942
My Ride: 2005 M3 Coupe
Awesome!
TerraPhantm is offline   Reply With Quote
Old 07-07-2013, 05:13 PM   #193
Hornung418
Registered User
 
Join Date: Dec 2010
Location: Bel Air, MD/ WVU
Posts: 1,013
My Ride: '04 MB ZHP
Payment sent for new parts!!

Monday will be a glorious day, hopefully.
__________________

Last edited by Hornung418; 07-07-2013 at 05:14 PM.
Hornung418 is offline   Reply With Quote
Old 07-13-2013, 12:00 AM   #194
jdjg
Registered User
 
Join Date: Jun 2009
Location: Panama City, Panama
Posts: 324
My Ride: e39, m52tub30
MS42 < MS43 Compatibility Thread...

well, finally I did my MS42 ----> MS43 conversion today (e39 use to be 523, now 530)........
Here my story.....
I bought this BMW from my local BMW dealer in august 1999, it was a e39 523i m42tub25 automatic, titansilber metallic, interior black.... in 2011 I made my automatic to manual transmission swap, and in January of this year (2013), I stroke my motor, to the m54b30 specs. (intake/exhaust camshafts, crankshaft, pistons, rods, injectors, intake manifold using the Turnermotorsport plate), but I keep my MS42 DME and using the conventional throttle cable....
I spoke with Randy from Epic Motorsport, asking him a custom tuning, since I have all the internals of the m54b30, but still using the electronics of the m52tu..... he did a good job, but my car never run so good as now.....
Today finally, I did a complete DME swap, with all the DME harness from a 530i automatic...... I use two of the three engines harness (the principal harness, the one who control the throttle body, MAF, etc., and the other that came from the transmission and O2 sensors, and relays)....
All this swap became pretty straight forward, I need to fabricate my own gas Pedal harness (Fly by wire) and thats it.....
after the swap, I remap my MS43 to the euro spec (since I dont have cats, Im runing the Raceland headers and no 2nd air pump) and manual transmission, after this, code the EWS for a manual transmission and align the EWS with the DME........
What a great improve, my car keep around 750 - 800 rpm in idle (with the MS42, my idle bece erratic), what a GREAT intake sound (3" vs 2.5")......
Im pretty happy with my swap.....
Here are the list of all the parts I use:

- MS43 + Key + EWS + Ignition key, all from the same e39 530 US spec car
- m54b30 intake manifold
- m54b30 530 engine harness (main harness and the O2 harness, I modify this last harness, I took off the O2 sensors after cats)
- m54b30 throttle body
- m54b30 injector
- m54b30 MAF
- m54b30 DISA
- m54b30 motor air filter housing
- m54b30 intake hoses
- m54b30 intake/exhaust camshafts, crankshafts, pistons, rods

Regards,


Sent from BimmerApp mobile app
jdjg is offline   Reply With Quote
Old 07-13-2013, 06:59 AM   #195
jdjg
Registered User
 
Join Date: Jun 2009
Location: Panama City, Panama
Posts: 324
My Ride: e39, m52tub30
MS42 < MS43 Compatibility Thread...

but I have one issue, now in my cluster (mu car became with High OBC), send me a Oil Pressure Error and Oil Level Error, I think the MS43 read those sensor in different way in the cluster....
I need to figure it out this issue.....
Today, Im gonna swap a cluster from a e39 530 and see..... and try to see how the MS43 read those sensors in a OEM 530 MS43.....


Sent from BimmerApp mobile app
jdjg is offline   Reply With Quote
Old 07-15-2013, 09:15 PM   #196
Hornung418
Registered User
 
Join Date: Dec 2010
Location: Bel Air, MD/ WVU
Posts: 1,013
My Ride: '04 MB ZHP
Re: MS42 < MS43 Compatibility Thread...

New parts are here. But its so damn hot...even at 10 pm!!

Hopefully she starts tomorrow morning like...before 7 lol.

Sent from BimmerApp mobile app
__________________
Hornung418 is offline   Reply With Quote
Old 07-16-2013, 05:43 AM   #197
HakenTT
OEM ///Member
 
Join Date: Aug 2009
Location: gross deutsches reich USA
Posts: 544
My Ride: 323i with S54
Quote:
Originally Posted by Hornung418 View Post
New parts are here. But its so damn hot...even at 10 pm!!

Hopefully she starts tomorrow morning like...before 7 lol.

Sent from BimmerApp mobile app
Ask me about heat, I live in the city where all summer is 110f every day. I also have been searching for some parts, most sellers don't know that not all 99-05 stuff is the same.
HakenTT is offline   Reply With Quote
Old 07-16-2013, 08:33 PM   #198
Hornung418
Registered User
 
Join Date: Dec 2010
Location: Bel Air, MD/ WVU
Posts: 1,013
My Ride: '04 MB ZHP
New parts installed this morning. Still won't fire. Not exactly sure what my issue is

Doesn't look like Bimmerfest is happening this year if I can't get it to turn over.

Anyone want to remote guide me for some coding. I'm already set up. Sent a text to Terra, but he must be busy.
__________________
Hornung418 is offline   Reply With Quote
Old 07-16-2013, 11:07 PM   #199
jdjg
Registered User
 
Join Date: Jun 2009
Location: Panama City, Panama
Posts: 324
My Ride: e39, m52tub30
MS42 < MS43 Compatibility Thread...

Quote:
Originally Posted by Hornung418 View Post
New parts installed this morning. Still won't fire. Not exactly sure what my issue is

Doesn't look like Bimmerfest is happening this year if I can't get it to turn over.

Anyone want to remote guide me for some coding. I'm already set up. Sent a text to Terra, but he must be busy.
what do you need?
whats your problem?
what are you doing?


Sent from BimmerApp mobile app
jdjg is offline   Reply With Quote
Old 07-16-2013, 11:57 PM   #200
HakenTT
OEM ///Member
 
Join Date: Aug 2009
Location: gross deutsches reich USA
Posts: 544
My Ride: 323i with S54
Quote:
Originally Posted by Hornung418 View Post
New parts installed this morning. Still won't fire. Not exactly sure what my issue is

Doesn't look like Bimmerfest is happening this year if I can't get it to turn over.

Anyone want to remote guide me for some coding. I'm already set up. Sent a text to Terra, but he must be busy.
What new parts did you buy? Matching ews, and dme? try to align it with scan tool.

With the key on engine off, boot the scan tool, align the dme then turn the key to start. It must work if its true matching dme/ews

Last edited by HakenTT; 07-17-2013 at 12:01 AM.
HakenTT is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 06:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use