E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-12-2012, 06:32 PM   #1
azw131
Registered User
 
Join Date: Aug 2012
Location: Boston, MA
Posts: 36
My Ride: 325Xi
Bimmian Illuminated Updated Look Auto Shifter Not Lighting Up

So I ordered the illuminated updated look auto shifter (the one like the new cars have) off of bimmian and went to install it today. It came with a wiring harness, the shifter, and some crappy instructions. I hooked it all up correctly, but when I did the dot that shows what gear is selected wouldn't light up on my trim piece or the shifter. All the other stuff worked. Does know why this might be/ has anyone had experience with this particular shifter?
azw131 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-24-2013, 08:36 PM   #2
supercrew90
Registered User
 
Join Date: May 2008
Location: Houston
Posts: 48
My Ride: 03 bmw 330
BUMP
Anyone had this issue before
__________________
[SIGPIC]
supercrew90 is offline   Reply With Quote
Old 07-24-2013, 08:44 PM   #3
mjpgolf1
Registered User
 
Join Date: Mar 2013
Location: Cleveland Oh
Posts: 1,769
My Ride: 00 328i ZSP,05 745LI
Bimmian Illuminated Updated Look Auto Shifter Not Lighting Up

First off just because I'm making a suggestion here doesn't mean I think this shifter looks good in an e46 because I think it just looks out of place in the car. However did you make sure that you plugged in all of the connections when putting everything back together? It sounds like one of the plugs may not be completely seated in the harness.


Sent from BimmerApp mobile app
mjpgolf1 is offline   Reply With Quote
Old 07-24-2013, 08:50 PM   #4
supercrew90
Registered User
 
Join Date: May 2008
Location: Houston
Posts: 48
My Ride: 03 bmw 330
Yes I have connected the wires where they suppose to be and also switched around the wires see if they worked i got nothing the green lights dont turn on but the orange does but the radio illuminates orange also and stay like that after I lock the car. I dont know what can it be the problem.
__________________
[SIGPIC]
supercrew90 is offline   Reply With Quote
Old 07-24-2013, 09:18 PM   #5
Zell
Registered User
 
Zell's Avatar
 
Join Date: Jun 2009
Location: Such City
Posts: 5,715
My Ride: '02 Dogemobile Shibe
Another Bimmian product gone wrong.
__________________
Zell is offline   Reply With Quote
Old 07-24-2013, 09:25 PM   #6
supercrew90
Registered User
 
Join Date: May 2008
Location: Houston
Posts: 48
My Ride: 03 bmw 330
I bought it from jlevisw but yea another product thats wrong if theres other people with the same issue as me theres something wrong Im just gonna return it if i cant figure it out.
__________________
[SIGPIC]

Last edited by supercrew90; 07-24-2013 at 09:25 PM.
supercrew90 is offline   Reply With Quote
Old 07-24-2013, 09:27 PM   #7
Zell
Registered User
 
Zell's Avatar
 
Join Date: Jun 2009
Location: Such City
Posts: 5,715
My Ride: '02 Dogemobile Shibe
I've just had absolute **** luck with their products...and if you criticize them on the forums, they stop helping you. There's a reason why they aren't a sponsor here anymore.
__________________
Zell is offline   Reply With Quote
Old 07-24-2013, 09:32 PM   #8
supercrew90
Registered User
 
Join Date: May 2008
Location: Houston
Posts: 48
My Ride: 03 bmw 330
I knew I shouldnt of have bought, its a nice shifter but I think it looks out of place in the car too updated for the e46. Now the hassle to return it.
__________________
[SIGPIC]
supercrew90 is offline   Reply With Quote
Old 08-04-2013, 12:38 AM   #9
GodsSon
Registered User
 
Join Date: May 2009
Location: Mississauga
Posts: 72
My Ride: 325i
I had no problems at all with illuminated dials on the shifter or on my trim piece?

I actually love the shifter, I think It fits my car perfectly (check the pic below).

BUT I will give everyone out there a disclaimer if your thinking of picking this up. The quality of the shifter is SH*T!! I mean the parts are good but how they're assembled is SH*T!! after a few months of using this it fell apart in my hands! Literally at a stop light the thing split in half! I had to squeeze it all back together to shift gears! BUT after saying that, I liked the look and feel of the product so much that I decided to give it a second chance and repaired it myself with silicone caulking and super glue and havent had any problems since, i love it and use it to this day.

__________________
In God we Trust...all others Pay Cash.
_________________________________________________________
2005 BMW 325i
GodsSon is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use