E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-22-2013, 07:09 PM   #1
petrucho
Registered User
 
Join Date: Jul 2013
Location: toronto
Posts: 3
My Ride: BMW 328i
Exclamation Please help!! EGS module confusion.

Hello everyone i have been reading this forum quite a lot, great help and a lot of good info, however this is my first post. i have a 328i 2000. My problem is as follows: sometime in the past like 1 year ago my transmission light and check engine light came on, and transmition went into fail safe mode. Then i disconected the battery for like 10 min and transmission light went off, however the check engine stayed on. the car drove fine. i let it be for a while until i borrowed a GT1 /inpa software from my friend ... so here is the thing there are no codes stored in DME but when i try to access the EGS through GT1 it says that there is a problem in data transmission, the module does not respond or is not conected, when i tried the same thing with inpa it can conect to the module and read all the values for the transmission, activate/deactivate solenoids everything works, but when i try to access the fault code memory on EGS it says that module does not respond or not connected. So i figured it's defective. Just in case it would work and the problem is with software i reprogramed it using GT1. but still could not read or delete the codes. I went on ebay, bought a used one (same part number etc.) I programmed the new EGS unit following the instructions and when i started the car went into fail safe mode right away, when i read the codes through the GT1 it said internal module error replace the unit, so i;m thinking ok if i can read the codes on this one but not my old one it should be the problem with the module and they must have sent me a defective one, so i contact the seller say what the problem is and he agrees to send me another one, it arrived today and same problem transmition in fail safe the check engine light however is going off when i tried to erase the codes, but the same thing as the last one, GT1 says module is defective , action : replace the module. can it be that all three units are defective ?? what else can it be ? please help
petrucho is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-25-2013, 10:57 PM   #2
petrucho
Registered User
 
Join Date: Jul 2013
Location: toronto
Posts: 3
My Ride: BMW 328i
bump!
petrucho is offline   Reply With Quote
Reply

Tags
control unit, egs, gt1, internal fault, transmission

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use