E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-10-2011, 01:17 PM   #1
joeyxoxo
Registered User
 
Join Date: Feb 2009
Location: Framingham, mass
Posts: 123
My Ride: 2004 m3 smg
Send a message via AIM to joeyxoxo
smg issue please help

So my car is having an issue with the SMG gearbox. After 2nd gear if I'm under hard acceleration it won't shift into gear. Be it 2nd to 3rd or 3rd to 4th. The gear number will flash at me and then skip the gear and go to the next one. I'll completely lose the gear until I turn the car off and it resets. When this happens the cog light comes on also. Now this only happens if I really push the car above 5/6k rpms. If I drive normal its fine. I had my friend who is a master tech at BMW look at it. The clutch appears fine, Pump appears to be working and I just don't want to start throwing parts at it that I don't need. Has anyone else had this issue and if so how did you resolve it?
__________________


facebook.com/joeyfisher13
facebook.com/tattoosbyjoeyfisher
facebook.com/tbmamusic
twitter.com/tbmamusic
Instagram-tbmamusic
joeyxoxo is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-10-2011, 03:44 PM   #2
Loaded325i
Registered User
 
Join Date: Aug 2011
Location: oregon
Posts: 250
My Ride: bmw 325i
How come your master tech friend cannot find the problem?
__________________
A mechanical hobbyist and car enthusiast
1971 Datsun 240z Devil Z red
1999 740il Titanium Silver
2004 BMW 325i CW,PP and Sports Package
1996 toyota avalon-263,000-Sold
2003 Lexus Is300-Sold
2000 Acura TL-Sold
2000 Accord 5 speed-Sold
Loaded325i is offline   Reply With Quote
Old 10-10-2011, 06:52 PM   #3
queezy1
Registered User
 
Join Date: Jul 2008
Location: Walnut Creek, CA
Posts: 95
My Ride: '04 BMW 325 SMG
Check your SMG Relay. Search and you'll easily find the relay issue.

This is the best place to start. The only other thing I think it would be would be the SMG Pump. When mine went out, it would act strangely, reset, and the pump appeared normal. That was until it died while driving (thankfully at low speeds).

Good luck!
__________________

2004 325i SMG
Mods: BMW Performance Intake, Carbon Fiber Strut Bar, LED Angel Eyes, Xenesis Head/Fog Lights, Xexon Interiors, Clears all around, Matte Black Grille, M3 Trunk Lip Spoiler, Rear Tint, Black/White Roundels, Silver Trim/Knob, Silver Gauges/Rings, Aluminum Pedals, Alpine MP3 Changer, XM, GPS & Parrot Bluetooth all Hardwired, Alpine Speakers, Sub & Amps wired with Monster Connectors/Wires, Custom Sub Enclosure & Amp Rack
queezy1 is offline   Reply With Quote
Old 11-04-2011, 03:42 PM   #4
McPhaul
Registered User
 
Join Date: Apr 2004
Location: Atlanta
Posts: 5
My Ride: 06 Silver Grey/Black
This is my post reposted from another forum.


My '06 is at 135K miles (I bought it new 08/06) and I had trouble with my SMG last year at about 112K miles.

Note: I have driven this car at several HPDE's and I generally do about 25K miles a year in hard miles. I'm easier on rental cars than I am on my M3.

My car stopped shifting above 3500 RPM. You had full revs to use in each gear but the car would not shift to a new gear until the RPM's were back below 3500. It finally froze and would not go into any gear.

Long story short the dealers (2) that I had look at my car both wanted to put in new tranny's, 1 talked me into putting a new pump in. (BTW the pump was not the issue.) I finally found someone that had this problem and found the solution.

Part # 23-31-1-228-405 Compression spring had broken in 3 pieces. It's on top of the transmission so it's a pain to get to but it's a $3.00 part.

It's an easy fix but a scary issue until you find out what it is. Don't be scared of SMG. I'm really hard on my car and it's held up like a champ, except that damned spring.

Will
McPhaul is offline   Reply With Quote
Old 09-06-2013, 02:42 AM   #5
amdocjorge
Registered User
 
Join Date: Aug 2013
Location: Philippines
Posts: 2
My Ride: 2002 BMW 318i AT
Re: smg issue please help

My 318i AT have similar problems although not all the time. What happens is at times it doesnt shift when it should and I have to go to steptronic to shift it manually then bring it back to drive. Is this also caused by the compression springs? If not, whats wrong?

Sent from my GT-N7100 using BimmerApp mobile app
amdocjorge is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 10:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use