E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-31-2013, 08:59 PM   #1
rody1285
Registered User
 
Join Date: Dec 2005
Location: Philadelphia PA
Posts: 175
My Ride: 00' 323i, 05 M3 Vert
Send a message via AIM to rody1285
Speaker problem BM54

Fellow E46 fanatics,

I have a 2005 BMW M3 cabriolet with factory navigation screen and HK system. I noticed that my speakers in the front driver side door is completely out the {large bottom} and mid range/ tweeter. I also notice some distortion and the speaker cutting in and out from the remaining front passenger side speaker and rear passenger side when the volume is increased. It cuts in and out when the volume is up, but at low to moderate levels all the speakers work except the driver door. I was doing some research and I think the problem may be the BM54 unit. How can I be sure this is the problem? I was going to open the door panel to check the condition of the speaker, but I do not think the speaker is blown because the problem is affecting all the speakers in the door. I isolated fade and balance sound to the front driver door no sound from any driver speaker.

I appreciate if you can help me in any way.

I am not sure the source of the problem:

speaker
amp
bm54
head unit
mk4
__________________
 photo e46fianbtuc-1.jpg

Last edited by rody1285; 08-31-2013 at 09:00 PM.
rody1285 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 08-31-2013, 09:17 PM   #2
rody1285
Registered User
 
Join Date: Dec 2005
Location: Philadelphia PA
Posts: 175
My Ride: 00' 323i, 05 M3 Vert
Send a message via AIM to rody1285
bump ..............anyone?
__________________
 photo e46fianbtuc-1.jpg
rody1285 is offline   Reply With Quote
Old 08-31-2013, 11:28 PM   #3
Avetiso
Registered User
 
Join Date: Dec 2012
Location: Sacramento, CA
Posts: 248
My Ride: 2003 ZHP 6MT
Check the connections on the back of the HU?

Also, don't bump your thread after 18 minutes. You are going to have to wait longer than that to get a response; things don't usually work that fast on a board.

I hope you can get it figured out.
Avetiso is online now   Reply With Quote
Old 09-01-2013, 10:58 AM   #4
rody1285
Registered User
 
Join Date: Dec 2005
Location: Philadelphia PA
Posts: 175
My Ride: 00' 323i, 05 M3 Vert
Send a message via AIM to rody1285
What would I be looking for at the head unit?
__________________
 photo e46fianbtuc-1.jpg
rody1285 is offline   Reply With Quote
Old 09-01-2013, 11:08 AM   #5
e34m5freak199
Registered User
 
Join Date: Jan 2010
Location: Sydney Australia
Posts: 235
My Ride: E34 M5, E46 325
dude, that's not your speaker.

odds are you have lost that channel. Veyr Very Common failure in the bm54 unit.

Unfortunately your going to need a new / used bm54 and that not some 1/2 baked bs answer. The Becker units fail all the time. there is an extremly minor chance its your amp, but personally ive never seen them fair.
e34m5freak199 is offline   Reply With Quote
Old 09-01-2013, 04:32 PM   #6
rody1285
Registered User
 
Join Date: Dec 2005
Location: Philadelphia PA
Posts: 175
My Ride: 00' 323i, 05 M3 Vert
Send a message via AIM to rody1285
I just pulled my unit out and it looks like I have the bm53 by becker
__________________
 photo e46fianbtuc-1.jpg

Last edited by rody1285; 09-01-2013 at 04:32 PM.
rody1285 is offline   Reply With Quote
Old 09-07-2013, 02:23 PM   #7
rody1285
Registered User
 
Join Date: Dec 2005
Location: Philadelphia PA
Posts: 175
My Ride: 00' 323i, 05 M3 Vert
Send a message via AIM to rody1285
problem solved,

I purchased a used BM53 unit off of ebay, it actually came out of a Range Rover. Received the package today, connected unit and sound was restored to all four channels including the driver side door. I hope this helps someone in the future.
__________________
 photo e46fianbtuc-1.jpg
rody1285 is offline   Reply With Quote
Old 01-29-2014, 03:55 AM   #8
XKaLiBaR
Registered User
 
Join Date: Feb 2006
Location: london
Posts: 63
My Ride: M3 Imola Red/Red
These can also be repaired and added with better amps. Cheaper as well.
XKaLiBaR is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use