E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > ///M3 Forum

///M3 Forum
The BMW E46 ///M3 is the M version E46 and puts out an amazing 333 HP and 262 lb-ft of torque at stock specs! There are an amazing amount of modifications for both the coupe and convertible models so read up and get started modifying your cars today!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-10-2014, 11:25 AM   #1
Grendelsbane
Registered User
 
Join Date: Sep 2011
Location: Seattle
Posts: 446
My Ride: M3
SMG 2nd to 3rd gear only, shifts slow

I tried looking for the answer to this...found something on m3forum.net, but the post was from 2012 and the last guy didn't seem to get any answer.

I got my SMG pump serviced, salmon relay replaces, and compression springs done, but when I drive more "spiritedly" from 2nd to 3rd and only 2nd to 3rd there is a LOOOOOOOONG lag before it snaps into gear. It does seem that if you take your foot off the accelerator and then put it down again that it finds 3rd much faster, but still slow compared to the other gears. The issue seems to happens regardless of setting on the drive logic.

I have tried the SMG reset and still no joy. Does anybody have any ideas what could be causing the issue and more importantly fix the problem?
__________________
2004 Silver M3 / SMG / Koni Yellow shocks and struts / Vogtlands lowering springs / Eibach front and rear sway bars / Proflex bushings / Predator Orion V2 Multi-Color LED Angel Eyes / Laser Interceptors / Clear Bumper Reflectors / Mishimoto Aluminum Radiator / AKG Motor mounts / Rogue Engineering Transmission Mount / AKG differential bushings / Euro mirrors / B&B Exhaust / CSL SMG tune /DME CSL tune

Grendelsbane is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-10-2014, 04:07 PM   #2
Kyemaul
Registered User
 
Join Date: Nov 2013
Location: Queens, New york
Posts: 37
My Ride: 2006 E46 M3 Vert
My friend is experiencing the same problem ! He getting word its the gear position sensor
Kyemaul is offline   Reply With Quote
Old 01-10-2014, 05:20 PM   #3
Grendelsbane
Registered User
 
Join Date: Sep 2011
Location: Seattle
Posts: 446
My Ride: M3
I changed that thing though.

[EDIT]

Maybe not, I changed the crankshaft speed sensor. I will check out that Gear Position sensor.
__________________
2004 Silver M3 / SMG / Koni Yellow shocks and struts / Vogtlands lowering springs / Eibach front and rear sway bars / Proflex bushings / Predator Orion V2 Multi-Color LED Angel Eyes / Laser Interceptors / Clear Bumper Reflectors / Mishimoto Aluminum Radiator / AKG Motor mounts / Rogue Engineering Transmission Mount / AKG differential bushings / Euro mirrors / B&B Exhaust / CSL SMG tune /DME CSL tune


Last edited by Grendelsbane; 01-10-2014 at 05:23 PM.
Grendelsbane is offline   Reply With Quote
Old 01-11-2014, 07:51 PM   #4
$ilent ///M
Registered User
 
Join Date: Jan 2010
Location: So.Cal
Posts: 246
My Ride: 03.5 M3 smg lsb
how many miles do you have on the car
$ilent ///M is offline   Reply With Quote
Old 01-12-2014, 12:18 AM   #5
Grendelsbane
Registered User
 
Join Date: Sep 2011
Location: Seattle
Posts: 446
My Ride: M3
113k
__________________
2004 Silver M3 / SMG / Koni Yellow shocks and struts / Vogtlands lowering springs / Eibach front and rear sway bars / Proflex bushings / Predator Orion V2 Multi-Color LED Angel Eyes / Laser Interceptors / Clear Bumper Reflectors / Mishimoto Aluminum Radiator / AKG Motor mounts / Rogue Engineering Transmission Mount / AKG differential bushings / Euro mirrors / B&B Exhaust / CSL SMG tune /DME CSL tune

Grendelsbane is offline   Reply With Quote
Old 01-12-2014, 11:56 AM   #6
$ilent ///M
Registered User
 
Join Date: Jan 2010
Location: So.Cal
Posts: 246
My Ride: 03.5 M3 smg lsb
Try getting your clutch slip points and learning curves reset
$ilent ///M is offline   Reply With Quote
Old 01-12-2014, 07:04 PM   #7
Grendelsbane
Registered User
 
Join Date: Sep 2011
Location: Seattle
Posts: 446
My Ride: M3
Yeah, I think that is what I am going to do.
__________________
2004 Silver M3 / SMG / Koni Yellow shocks and struts / Vogtlands lowering springs / Eibach front and rear sway bars / Proflex bushings / Predator Orion V2 Multi-Color LED Angel Eyes / Laser Interceptors / Clear Bumper Reflectors / Mishimoto Aluminum Radiator / AKG Motor mounts / Rogue Engineering Transmission Mount / AKG differential bushings / Euro mirrors / B&B Exhaust / CSL SMG tune /DME CSL tune

Grendelsbane is offline   Reply With Quote
Old 01-16-2014, 12:59 PM   #8
Kyemaul
Registered User
 
Join Date: Nov 2013
Location: Queens, New york
Posts: 37
My Ride: 2006 E46 M3 Vert
Any updates ????????????? DID YOU CHANGE THE GEAR POSITION SENSOR?

Last edited by Kyemaul; 01-16-2014 at 01:00 PM.
Kyemaul is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use