E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-25-2014, 12:31 PM   #1
wrdriggs
Registered User
 
Join Date: Nov 2013
Location: CT
Posts: 21
My Ride: $1,000 02 BMW 325xi
LED Interior Problems.. Wagon

So I recently purchased a whole bunch of LEDs off superbrightleds.com. I purchased regular non can-bus led's. I installed them all and I am having a few issues -

1.) The floor lighting does not work as well as the center map light. Once the car has been sitting, I can push the center map light and you can see the floor lights turn on for a brief second and then turn back off. If I try to hit it again, nothing will happen. The rear map lights work both left and right, but the center one does not work either. The other LEDs that I installed - rear trunk, glove box, mirror lights all work perfectly. Do I need to repalce all the interior bulbs with can-bus leds? or is there just certain ones?

2.) The License place lights work all the time as they should, but when the car is turned off, they will stay dimmly lit for a few minutes before turning off completly. I think the fix for this is to just get a can-bus leds, but really isnt an issue since they work fine and are not killing the battery.

Last edited by wrdriggs; 01-25-2014 at 12:32 PM.
wrdriggs is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-26-2014, 07:58 AM   #2
wrdriggs
Registered User
 
Join Date: Nov 2013
Location: CT
Posts: 21
My Ride: $1,000 02 BMW 325xi
Bump ttt
wrdriggs is offline   Reply With Quote
Old 01-26-2014, 09:03 AM   #3
Phrygian
OEM ///Member
 
Phrygian's Avatar
 
Join Date: Jul 2013
Location: Crawfordville, FL
Posts: 214
My Ride: 2000 323i
Quote:
Originally Posted by wrdriggs View Post
So I recently purchased a whole bunch of LEDs off superbrightleds.com. I purchased regular non can-bus led's. I installed them all and I am having a few issues -

1.) The floor lighting does not work as well as the center map light. Once the car has been sitting, I can push the center map light and you can see the floor lights turn on for a brief second and then turn back off. If I try to hit it again, nothing will happen. The rear map lights work both left and right, but the center one does not work either. The other LEDs that I installed - rear trunk, glove box, mirror lights all work perfectly. Do I need to repalce all the interior bulbs with can-bus leds? or is there just certain ones?

2.) The License place lights work all the time as they should, but when the car is turned off, they will stay dimmly lit for a few minutes before turning off completly. I think the fix for this is to just get a can-bus leds, but really isnt an issue since they work fine and are not killing the battery.
Did you not read about the issues with LEDs in these cars beforehand? All of the lights that come on automatically (the dome, footwell, and rear courtesy lights) need to be canbus types, or you'll need to install a resistor in parallel with the circuit to trick the LCM.
Phrygian is online now   Reply With Quote
Old 01-26-2014, 10:06 AM   #4
jmillsner
Registered User
 
Join Date: Nov 2012
Location: Chicago, IL
Posts: 340
My Ride: 330Ci 6 Spd, 335Cic
this ^. you will need a resistor (or is it a capacitor?) to make those LEDs stay lit. i believe its because LEDs draw so little power that the car doesn't think they're there or something like that
jmillsner is offline   Reply With Quote
Old 01-26-2014, 11:56 AM   #5
Phrygian
OEM ///Member
 
Phrygian's Avatar
 
Join Date: Jul 2013
Location: Crawfordville, FL
Posts: 214
My Ride: 2000 323i
Just a resistor is needed. If the LEDs come on for a second and then go off, the LCM isn't sensing enough resistance so it shuts down the circuit. There's plenty of info on this board about how to get around that.

I should also mention that some of the non canbus LEDs are polarized. So if you have some bulbs that are not flashing at all, they may be installed backwards.


Sent from my Incredible 4G LTE using BimmerApp mobile app
__________________

Last edited by Phrygian; 01-26-2014 at 11:56 AM.
Phrygian is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use