E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Suspension & Braking Forum by BimmerWorld

Suspension & Braking Forum by BimmerWorld
Have some questions about suspension or brake setups for your E46 BMW? Get all your answers here!
Sponsored by BimmerWorld

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-02-2014, 10:36 PM   #21
Bavarian2009m3
Registered User
 
Join Date: Jul 2014
Location: Houston Tx
Posts: 11
My Ride: 2004 330ci
Will tackle install and report back. Thanks for all the help
Bavarian2009m3 is offline   Reply With Quote
Old 07-24-2014, 01:00 PM   #22
wallofgrath
Registered User
 
Join Date: Jan 2012
Location: Stamford, CT
Posts: 68
My Ride: 2001 330Ci
Any update? I have same problem. I had my wheels balanced recently, replaced CAB's, and replaced struts.
wallofgrath is offline   Reply With Quote
Old 07-24-2014, 01:57 PM   #23
generalvp
Registered User
 
Join Date: Sep 2013
Location: Minnesota
Posts: 285
My Ride: 2005 BMW 330ci ZHP
Looks like I'm not alone in this vibration issue. I recently replaced my lower control arm with Meyle HD control arms with pre-pressed bushings and got the same steering wheel vibrations from 60+mph. Mine you, I also replaced the front struts and all its components, like shocks, upper strut mounts, upper/lower spring pad, upper spring mount, bump stops. Did 2 wheel balance and 2 alignments but still same result. I think the Meyle control arms and bushings are at fault because this did not happen before the swap.
generalvp is offline   Reply With Quote
Old 07-24-2014, 02:12 PM   #24
wallofgrath
Registered User
 
Join Date: Jan 2012
Location: Stamford, CT
Posts: 68
My Ride: 2001 330Ci
Well I read that when you install new CAB's, it tightens it back up and can expose a vibration that would not have been noticed before. Still seems suspicious to me too! Maybe they are not all the way onto the arm? I'm going to have a shop re-balance my wheels, because Firestone probably did a half ass job.

Last edited by wallofgrath; 07-24-2014 at 03:26 PM.
wallofgrath is offline   Reply With Quote
Old 07-24-2014, 02:18 PM   #25
generalvp
Registered User
 
Join Date: Sep 2013
Location: Minnesota
Posts: 285
My Ride: 2005 BMW 330ci ZHP
Quote:
Originally Posted by wallofgrath View Post
Well I read that when you install new CAB's, it tightens it back up and can expose a vibration that would not have been noticed before. Still seems suspicious to me too! Maybe they are not all the way onto the arm? I am going to rebalance my wheels. I'm going to have a shop re-balance my wheels, because Firestone probably did a half ass job.
I was told that I needed to pre-load the car before tightening the nuts. I didn't do that at first but went back and took everything apart, pre-load it and then tighten them but still same result. The Meyle control arms I bought were from oembimmperparts and came with the bushings pre-pressed. My next step is new front tires.
generalvp is offline   Reply With Quote
Old 07-24-2014, 08:21 PM   #26
generalvp
Registered User
 
Join Date: Sep 2013
Location: Minnesota
Posts: 285
My Ride: 2005 BMW 330ci ZHP
I am sure I have found out what was causing my vibrations. Check my thread:

http://forum.e46fanatics.com/showthread.php?t=1045902
generalvp is offline   Reply With Quote
Old 07-26-2014, 09:50 PM   #27
wallofgrath
Registered User
 
Join Date: Jan 2012
Location: Stamford, CT
Posts: 68
My Ride: 2001 330Ci
I had all 4 wheels re-balanced today and it solved my problem. I guess Firestone did a bad balance job (only a few hundred miles prior to the vibration starting)

Last edited by wallofgrath; 07-26-2014 at 09:52 PM.
wallofgrath is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use