Heated seat issue - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-01-2017, 06:01 PM   #1
Chase.bandz
Registered User
 
Join Date: Oct 2016
Location: Maryland
Posts: 28
My Ride: 2002 325i Manual
Heated seat issue

I've had this car for about a year now and it's time to finally figure out what is wrong with my heated seats. I've checked the fuses so far and they are fine. When touching the buttons on both sides the lights all flash once and that is it. Any ideas before I start blindly buying parts?





2002 325i

Last edited by Chase.bandz; 04-01-2017 at 06:06 PM.
Chase.bandz is offline   Reply With Quote
Old 04-02-2017, 12:32 AM   #2
Monty330ci
Registered User
 
Join Date: Apr 2015
Location: Ontario, Canada
Posts: 89
My Ride: 2002 330ci, MT
I removed the front passenger seat without disconnecting the battery first.
Air bag light came on and only that seat wield not heat up anymore.
Bought a $15 Ebay airbag sensor reset tool. Worked and seat worked again.
I suggest disconnecting the battery. Disconnect the seats and spray them with electrical contact cleaner.
Reconnect the seats then plug the battery back in.
Might help...


Sent from my iPhone using Tapatalk
Monty330ci is offline   Reply With Quote
Old 04-02-2017, 12:35 AM   #3
Chase.bandz
Registered User
 
Join Date: Oct 2016
Location: Maryland
Posts: 28
My Ride: 2002 325i Manual
I'll give it a shot, thanks!

Quote:
Originally Posted by Monty330ci View Post
I removed the front passenger seat without disconnecting the battery first.
Air bag light came on and only that seat wield not heat up anymore.
Bought a $15 Ebay airbag sensor reset tool. Worked and seat worked again.
I suggest disconnecting the battery. Disconnect the seats and spray them with electrical contact cleaner.
Reconnect the seats then plug the battery back in.
Might help...


Sent from my iPhone using Tapatalk
Chase.bandz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-27-2017, 12:47 PM   #4
SaxxAppeal
Registered User
 
Join Date: Aug 2016
Location: New York, NY
Posts: 5
My Ride: 2000 323i
I'm having the same issue with just my driver's side heated seat (passenger seat works fine).

Did the battery disconnect and contact cleaner work for you?
SaxxAppeal is offline   Reply With Quote
Reply

Tags
broken, heated seat, problem, seat

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 09:12 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - VerticalScope Inc. All rights reserved.