E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-05-2005, 05:06 PM   #1
SammyV
Registered User
 
Join Date: Sep 2004
Location: Hoboken / Long Island
Posts: 1,378
My Ride: CB M3
Send a message via AIM to SammyV
Solaris Invisibulbs - suck?

Hey, i bought a set of Solaris invisibulbs from bimmian, ide say 3 months ago, installed on my car, yay great - today one blinker already went out, to me this seems like a huge let down, i spent over 60 dollars on these bulbs and one has already gone out, SUCKS

now its time to save up for some LEDs, really pissed with these solaris bulbs and i think its B**Sh** that they are already starting to blow....
any pros/cons with you guys with LEDs? how hard was it to install the resisitors that heat up?


thanks guys
SammyV is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-05-2005, 05:13 PM   #2
00323ci
Registered User
 
Join Date: Dec 2004
Location: Wisconsin
Posts: 264
My Ride: ::::EVOLUTION::8:::
Send a message via AIM to 00323ci
same thing happened to me after 3 weeks...worst of all i bought them from bimmian..its going to be a ***** to get a free bulb i think they want $5 per replacement bulb this is gay.
00323ci is offline   Reply With Quote
Old 03-05-2005, 06:38 PM   #3
Triflowm5+M3
Gear up, shut up!
 
Join Date: Jun 2003
Location: A hellions paradise
Posts: 1,240
My Ride: 2005 'Yota 4runner
Send a message via AIM to Triflowm5+M3
they dont last very long..i even got the rear license plate ones and one blew out about 2 months later and i got a ticket for it...so not only did i have to get another bulb (just bought crappy oem style ones) but also had to deal with a ticket for it.
__________________


Truth be told, I think I thrive under a lack of accountability[/SIZE]
Triflowm5+M3 is offline   Reply With Quote
Old 03-05-2005, 07:20 PM   #4
dustix
Registered User
 
Join Date: Mar 2004
Location: Miami
Posts: 9
My Ride: 2002 330 Ci
Fuk... I just some and decided to pick dem over LED's because of the plug-n-play aspect. I'm pissed now...
dustix is offline   Reply With Quote
Old 03-05-2005, 07:42 PM   #5
ronsega
Registered User
 
Join Date: Apr 2004
Location: Chula Vista
Posts: 870
My Ride: on 19s again
Send a message via AIM to ronsega Send a message via Yahoo to ronsega
I ordered a pair from bimmian a long time ago but never put them on. and a about a month ago I so wanted to put them in but I forgot where I stashed them

Guess I won't put them on after all
__________________
ronsega is offline   Reply With Quote
Old 03-05-2005, 07:45 PM   #6
VENDETTABMW
Registered User
 
Join Date: Feb 2003
Location: in a van down by the river
Posts: 719
My Ride: '78 datsun
mine r used, no problems..shouldbe warranty anyway...i bougth some led , didnt use, will sell in like 2 weeks, look for post.
VENDETTABMW is offline   Reply With Quote
Old 03-05-2005, 08:26 PM   #7
Jlevi SW
1.888.JLEVISW
 
Jlevi SW's Avatar
 
Join Date: Dec 1969
Location: 2942 Scott Blvd, Santa Clara CA
Posts: 12,398
My Ride: Vorsteiner 335i
Send a message via AIM to Jlevi SW
Hurrah for LEDs
JL
Jlevi SW is offline   Reply With Quote
Old 03-05-2005, 10:42 PM   #8
Asmodeus
Registered User
 
Join Date: Jun 2003
Location: Montreal, Canada
Posts: 742
My Ride: 328i
My two front ones went, and after seeing that I needed to pay a ridiculous amount in shipping for a company that is one province away I decided to go with SPP's Silvervisions, which should be arriving on monday
__________________
328i - TiAg / Black with PP - HK - 35% Tint - TiAG Headlight Trim - RSM - Gauge Rings - Clears - GruppeM - Silvervision - Koni Adjustables - UUC T.M.E., Clutch Stop, DSSR, Pulleys, Swaybars, LTW - EPS Pump - SS Brake & Clutch Line - MTech II Front - Angel Eyes - M3 Lip Spoiler - Z211, K104 - M6 Wheels -

TLC/BMW Instructor
Asmodeus is offline   Reply With Quote
Old 03-06-2005, 01:43 AM   #9
jEEliX
Registered User
 
Join Date: Aug 2004
Location: Arizona
Posts: 963
My Ride: 2000 323i
Send a message via AIM to jEEliX
I use Stealthbulbs. They have a lifetime warranty all oyu have to do is send your blown one back in the original package and they will send you a new one. I've had the side marker ones for 8 months and they are like new and the front corner ones for about 4 months with no problems.

Http://www.store.stealthauto.com
jEEliX is offline   Reply With Quote
Old 03-06-2005, 03:49 AM   #10
akhbhaat
Lying, drunken cheat
 
Join Date: Apr 2003
Location: Second Circle of Hell
Posts: 4,364
My Ride: German Civic
I'll recommend silvervisions once again. I've had mine in for nearly two years, and all four of the originals still work.
__________________
No significant quantities of judgment-impairing narcotics were consumed during or before the creation of this message.
akhbhaat is offline   Reply With Quote
Old 03-06-2005, 04:44 PM   #11
biMmeRsTrYkeR
Registered User
 
Join Date: Aug 2003
Location: SF Bay Area, NorCal
Posts: 113
My Ride: 00 E46/01 GTi/90 E30
Send a message via AIM to biMmeRsTrYkeR
I contacted aaron at bimmian and he sent out a new pair the next day
__________________
*nofüknjoke*

Rieger | GruppeM | Supersprint | AC Schnitzer | BFP | UUC | Iforged Senekas | DDE's | Sharked | Phoenix Gold | H&R Cupkit | Sparco | StopTech

My GTI Eurotuner Feature: http://www.eurotuner.com/featuredveh...18t/index.html
biMmeRsTrYkeR is offline   Reply With Quote
Old 03-06-2005, 05:01 PM   #12
E46 SC3
Registered User
 
Join Date: Dec 2004
Location: San Francisco Bay Area (510)
Posts: 997
My Ride: 03 TiAg S/C'd 330i
Just had my first Solaris blub go out last night

Where can I find these "Silvervision" blubs?
__________________

Technik ASA SK1 Supercharged w 8psi pulley/MTechII with Kerscher lip spoiler/19"BBS CH's/Eagle F1 GS-D3 235/35F&245/35R/Brembo4potBBK355mmF&345mmR/UUC's TSE3,EVO3 w DSSR,Magnesium Strutbarbarian,Gen2Swaybarbarians/BilsteinPSS9's/GC-RSM's/PredatorOrionV2/Xtec6000k/HID fogslamps/TiAg kidney grills+foglamp trim/M3mirrors+lip spoiler/OEM Clears/CF interior trim+seatbacks/Momo CF Shot shiftknob/LeatherZ gauge panel/HuperOptik tint
E46 SC3 is offline   Reply With Quote
Old 03-06-2005, 05:58 PM   #13
ct323i
Registered User
 
ct323i's Avatar
 
Join Date: Jul 2004
Location: Westchester
Posts: 3,579
My Ride: pushing 235k miles!!
Send a message via AIM to ct323i


should have gotten sylvania silverstar's, oem quality.
__________________


"ct323i: breaking new suspension equipment since 2007"
ct323i is offline   Reply With Quote
Old 03-06-2005, 06:39 PM   #14
roller84
Registered User
 
Join Date: Dec 1969
Location: Queens, NY
Posts: 205
My Ride: E46 330i & E90 335i
You guys may want to check if the bulb is making contact in the socket. I have a full set of Solaris bulbs and had issues with the bulbs going out in the front and rear. It seems as if the base of the bulb is not designed like the stock ones. I believe there may be an issue with it being a bit short in length. I noticed that the bulb did not sit snug in the socket. I would then wiggle the bulb around and it would turn on and off. A quick fix that I did was to put a good amount of solder on the very tip of the base of the bulb and haven't had issues since.
__________________
roller84 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use