E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-22-2005, 04:06 PM   #1
Slick26
Registered User
 
Join Date: Jun 2005
Location: Va Beach, Virginia
Posts: 12
My Ride: 04 m3 wrecked :(
changed my tires... ???

I need some help please.. I have had my bmw for like 3 months and never really did anything but drive it. I just bought some new tires and but them on and now my speed o-meter will not work and neither will my mpg gauge. My abs,brake, and traction control light is on. I have no idea what to do thanks alot. The tires i but on were 235/40/18 which i am sure are the right size. I would really appreciate some advice. thanks alot
Slick26 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-22-2005, 05:29 PM   #2
blayzirell
Registered User
 
Join Date: Oct 2005
Location: Redwood City
Posts: 96
My Ride: 03 325i
wow thats strange i suggest you take the car to the dealer. hopefully they are not pricks about it. i was going to change my tires last week as well but i couldnt find my damn wheel locks. turns out my dealer didnt give me the key from the beginning. ended up getting whole new wheel lock set for free. you just gotta pressure them or else u will call BMW customer service and rate 1 instead of 5
blayzirell is offline   Reply With Quote
Old 10-23-2005, 12:21 AM   #3
Slick26
Registered User
 
Join Date: Jun 2005
Location: Va Beach, Virginia
Posts: 12
My Ride: 04 m3 wrecked :(
...

thanks has anyone ever herd of this problem??
Slick26 is offline   Reply With Quote
Old 10-23-2005, 02:16 AM   #4
my330ci04
Registered User
 
Join Date: Apr 2005
Location: Chicago
Posts: 308
My Ride: 04 330 ci, 06 650i
Check your fuse box for blown fuses. I don't know what this would have to do with new tires though. If you still have problems go to the dealer.




Quote:
Originally Posted by Slick26
thanks has anyone ever herd of this problem??
my330ci04 is offline   Reply With Quote
Old 10-23-2005, 08:53 AM   #5
Canuck328i
Registered User
 
Join Date: Jan 2004
Location: Happyland, Ontario, Canada
Posts: 1,173
My Ride: 09 Altima Cpe
My guess, assuming nothing else happened or was done to cause this, is one of the ABS sensors was somehow damaged or disconnected. The vehicle speed is measured at the wheels via the ABS sensors, so all your symptoms would point to a sensor failure.

Unfortunately you will probably have to go to the dealer so they can diagnose where the failure is.

Mark
Canuck328i is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use